• W10 22H2 Drops Internet Download Speed Dramatically

    Home » Forums » Networking – routers, firewalls, network configuration » W10 22H2 Drops Internet Download Speed Dramatically


    I have two self built computers that have been running W10 21H2 without problems for months.  Yesterday I updated both to ver  22H2.  One updated without problems and my internet speed is what it has always been.  On the other, the install apparently went fine, but now the internet speed has dropped by 90%.  Searching on the net has indicated that this is an apparent problems for a significant number of people although none of the things suggested as a fix seem to work.  Since one computer is fine and the other problematic, I know that the internet itself is not the problem.  I’ve updated the software for the controller and that does not seem to help either.

    Any suggestions as to things that might have worked for others would be appreciated.


    Viewing 6 reply threads
    • #2559136

      What’s the brand of the Internet driver, have you disabled such items as rss and toe?

      Susan Bradley Patch Lady

      • #2559159

        The Internet Driver is Realtek Gaming GbE Family Controller. I see RSS is enabled but note nothing in the way of toe if I understand it correctly.  FYI the controller in the unit that is NOT having any problems is an Intel Ethernet Connection (7) 1219-V

    • #2559138

      Try disabling IPV6 (only on the trouble computer) and then full reboot router and all computers.

      1 user thanked author for this post.
      • #2559150

        That’s what worked for me and I haven’t “yet” run into any sites I can’t access/view using IPV4.

      • #2559261

        Sadly, disabling IPV6 on the problem computer, rebooting both computers the router did not have a positive impact on the speed, but thanks for the suggestion.

    • #2559292

      On the other, the install apparently went fine, but now the internet speed has dropped by 90%

      It is interesting you saying the speed has dropped by 90%. Have you checked the link speed on that adapter?
      From PowerShell you can run the following command to quickly check: Get-NetAdapter | select interfaceDescription, name, status, linkSpeed

      It’s somewhat of a longshot but a lower link speed would align with your reduction in internet speed. Some Realtek Ethernet adapters had an issue previously where the adapter would get stuck at a 100Mbps link even when connected to a gigabit switch port.
      Generally the issue was fixed by installing the latest driver from the motherboard manufacturer or the Realtek website (not from Windows update) but it appears you have updated the driver already.

      I’ve updated the software for the controller and that does not seem to help either.

      Some were able to workaround the link speed issue by changing the adapter setting for speed and duplex from Auto Negotiate to 1.0 Gbps full duplex.

      • #2559683

        When tested, the link speed was determined to be 1000/1000Mbps

        • #2559713

          That cannot be correct. No software can transfer at wire speed because there is always some overhead.
          You must run a test that copies software between machines to find out the true speed.

          cheers, Paul

          • #2559834

            You are correct, I didn’t realize that what I was doing was internal to one machine. However when I try to use LAN Speed Test to check one PC to the other that doesn’t work at all even though I know that I have the right IP numbers for each NIC.  When I check internet speed with only one computer connected at a time and directly to the modem, one runs at 50 and the other now has degraded to about 2. Which brings me back to the original question I asked:  Why would updating from W10 21H2 to 22H2 have no detrimental effect on one computer and make it essentially impossible to get a working download speed on the other , especially since it was built less than a year ago so it doe not have a lot of aging parts!!  I’m wondering if anyone else has had this kind of problems after updating to 22H2 and if so was there a solution other than possibly updating the software on the NIC which is on the motherboard, which I have already done with no improvement in speed on the problem plagued PC.


            Thanks in advance for any further suggestions from the group.

    • #2559295

      Check the speed between your computers to see if it’s the network controller or something else.

      You can use the built-in robocopy (see this post) to do the speed test.

      cheers, Paul

    • #2559911

      the other now has degraded to about 2

      You need to test machine to machine to eliminate the network card, then you can concentrate on the internet speed.

      cheers, Paul

      • #2560047

        You are correct, I didn’t realize that what I was doing was internal to one machine. I have now used LAN Speed Test to check speeds.  Computer G checking upload and download from J shows download of 688 and upload of 349.  However, J cannot do anything from G and the error message suggests problems with permissions.

        I should mention that since the time that I built J, it has never been able to view files on G even though G can easily see shared files on J.  But both G and J show as computers on the network when the network is viewed from either machine.  The kicker is that while G can be seen from J, when you try to look at files an error message of “Windows cannot access G” appears. One would think that data should go both ways. So far, searching on the web and talking with friends with more network experience than I have, has not been able to provide any suggestions that solved the problem so that is why I am reaching out to AskWoody with so many more folks that are computer savvy.

        While I ultimately want to solve the networking problem, my most important task is to get the internet speed back to normal on J.  Until I updated both machines to 22H2 they both had download speeds of about 50Mbps.  G has maintained that speed but J has dropped to about 2 Mbps (even if hooked directly to the modem and not going thru any switches).

        Thanks for sticking with me on this.


    • #2560146

      I assume you have tested with different browsers?

      I would make an image backup and then re-install Windows using the over the top method.

      cheers, Paul

      • #2561690

        I finally got an opportunity to try a reinstall of the operating system using the over the top method. Sadly that has not changed anything i.e. the download speed with chrome is still 6 Mbps and computer J still cannot see files on G.

        Now I did try briefly, as you suggested, to connect to the net via Edge and the downlead speed did increase to 25 Mbps and 42 Mbps on two tries, which I don’t quite understand as I thought Edge was based on Chrome.

        Any other thoughts would be appreciated.

        ATB, Gary

    • #2561740

      Now install Firefox and test speed with that.
      Then uninstall FF and Chrome and test with Edge.

      cheers, Paul

      p.s. Edge is based on Chrome but the code is separate.

      • #2562095

        I’m going to have to put this on hold for a time as some unexpected travel has come up.  I’ll try the suggestions as soon as I am able.

    Viewing 6 reply threads
    Reply To: W10 22H2 Drops Internet Download Speed Dramatically

    You can use BBCodes to format your content.
    Your account can't use all available BBCodes, they will be stripped before saving.

    Your information: