News, tips, advice, support for Windows, Office, PCs & more. Tech help. No bull. We're community supported by donations from our Plus Members, and proud of it
Home icon Home icon Home icon Email icon RSS icon
  • What am i doing wrong? (Networking problems)

    Posted on jwhiz56 Comment on the AskWoody Lounge

    Home Forums AskWoody support Windows Windows 10 Questions: Win10 What am i doing wrong? (Networking problems)

    This topic contains 20 replies, has 6 voices, and was last updated by

     jackpet 2 weeks ago.

    • Author
      Posts
    • #1846422 Reply

      jwhiz56
      AskWoody Plus

      I have a tower, laptop and several MS Surface’s.  All were on Win 10, 1809.  On the tower, I have an attached USB storage unit with 8 drives in it.  It is visible/accessible via explorer, network.  I upgraded the tower to 1903.  it can see the laptop and surfaces.  but, the laptop and surfaces can no longer see the tower.  This happens EVERY time I upgrade windows and persists until all units are on the same windows version.

      what am I doing wrong?  what am I missing?

      thanks
      john

      John W Zerkel

    • #1846449 Reply

      Rick Corbett
      AskWoody_MVP

      You aren’t doing anything wrong. Windows networking is going through changes (with some features like HomeGroup removed altogether and others like SMBc1 being turned off by default) and many people who’ve installed 1903 are experiencing similar network discovery/view issues.

      It could be either that a) SMBv1 is turned off by default or b) some services needed for network discovery aren’t configured correctly.

      To turn SMBv1 back on, do this:

      1. On the tower, right-click on the Start button and choose Run.

      2. In the Run dialog, copy paste the following command then press the Return/Enter key: explorer shell:::{67718415-c450-4f3c-bf8a-b487642dc39b}

      3. When the Windows Features dialog opens, scroll down to SMB 1.0/CIFS File Sharing Support and click on the + (plus) sign to expand the entry.

      4. Tick the client and server checkboxes:

      smb1903

      5. Re-boot the tower.

      (Alternatively, from an elevated PowerShell prompt, use the following command:

      Enable-WindowsOptionalFeature -Online -FeatureName smb1protocol

      This works but is less granular because it re-enables the SMB feature to automatically disable SMBv1 again if you haven’t used the protocol within 15 days.)

      If this doesn’t fix the network discovery/view issue then reverse the change and, instead, do this:

      1. Make sure the following services are set to both automatic and are running.

      Function Discovery Provider Host (FDPHost)
      
      Function Discovery Resource Publication (FDResPub)
      
      Network Connections (NetMan
      
      UPnP Device Host (UPnPHost)
      
      Peer Name Resolution Protocol (PNRPSvc)
      
      Peer Networking Grouping (P2PSvc)
      
      Peer Networking Identity Manager (P2PIMSvc)

      (Thanks to @cadesertrat for this list)

      Please let us know which, if either, solution works for you… because so far I’m unaware of a definitive answer. (The SMB solution works for me but that may be because I have Linux devices on my home network.)

      Important: Please note that SMBv1 is now turned off for very legitimate security issues so you need to be aware of this. Have a look at this ZDNet article on the subject for more info. I choose to turn SMBv1 back on within my home network but – with laptops – disable it again if using the laptop away from home.

      Hope this helps…

       

      Attachments:
      2 users thanked author for this post.
      • #1846550 Reply

        Rick Corbett
        AskWoody_MVP

        If you are comfortable using PowerShell then a more granular approach to re-enabling it is to use these 2 commands:

        Enable-WindowsOptionalFeature -Online -FeatureName “SMB1Protocol-Client”
        Enable-WindowsOptionalFeature -Online -FeatureName “SMB1Protocol-Server”

        … then reboot.

        This will re-enable both the client and server protocols but *won’t* re-enable the ‘Automatic Removal’ feature.

        (I was going to add this info to my previous post but wasn’t able to edit, not even to correct the typo in first sentence. 🙁 )

        As I have a mixed home environment (Windows, macOS, Linux) that requires SMBv1 for full network discovery/view, I now just use an AutoHotkey script to turn SMBv1 back on again (and am working on a location-aware script that automatically disables SMBv1 when a device is away from my home network environment):

        ; Prompt to 'Run as Admin', i.e. show UAC dialog
        If Not A_IsAdmin
        {
           Run *RunAs "%A_ScriptFullPath%"  ; Requires v1.0.92.01+
           ExitApp
        }
        
        psScript =
        (
           Enable-WindowsOptionalFeature -Online -FeatureName “SMB1Protocol-Client”
           Enable-WindowsOptionalFeature -Online -FeatureName “SMB1Protocol-Server”
            
           # This may not work on Home versions of Windows... I haven't yet tested )
        )
        
        ; Use this call if you don't want to see PowerShell output
        ;RunWait PowerShell.exe -Command %psScript%,, hide
        
        ; Use this call if you want to see PowerShell output
        RunWait powershell.exe -NoExit -Command %psScript%
        
        MsgBox Now reboot for the change to take effect.

        Hope this helps…

        1 user thanked author for this post.
    • #1846639 Reply

      Rick Corbett
      AskWoody_MVP

      Here’s an MS article – SMBv1 is not installed by default in Windows 10 Fall Creators Update and Windows Server, version 1709 and later versions – explaining why SMBv1 is no longer enabled by default. IMO it’s more factual, less prosaic than the Ed Bott article on ZDNet I linked to in my previous post.

      Hope this helps…

      1 user thanked author for this post.
    • #1848811 Reply

      jwhiz56
      AskWoody Plus

      there is no joy in mudville.  I tried all listed suggestions on the tower AND the surfaces.  The tower can still see the surfaces but the surfaces can’t see the tower.  my next experiment is to upgrade my 2017 surface to 1903 and see if it clears the problem up as I suspect it will.

      Thanks for the suggestions even if they didn’t work.  any others?

      john

      John W Zerkel

      • #1848860 Reply

        Rick Corbett
        AskWoody_MVP

        IMO the tower – which you’ve upgraded to 1903 – isn’t advertising itself on your network (which is a different issue to being ‘discoverable/seen’ but not accessible… which is usually an account/permissions issue).

        Reports I’ve read elsewhere suggest this is an issue with 1903… so I’m not at all sure that you would be well-advised to upgrade another device to 1903 at this moment. From the reports I’ve seen, it’s *upgrades* to 1903 (as opposed to *clean* installs) that are experiencing the most numerous network issues.

        If you do decide to upgrade your 2017 Surface, do you have the means to save a disk image of it first – just in case a restore is needed?

        For info, what anti-malware protection do you use on each device?

        You haven’t mentioned the laptop in your last post. Can it see the tower?

        Do you know how to ‘ping’ devices by IP address (to test IPv4) and computername (to test IPv6) from within an elevated command or PowerShell prompt? If so, what results do you get pinging the tower from one of the Surfaces and from the laptop using both IP address and computername? How about vice versa?

        Hope this helps…

         

    • #1849248 Reply

      Rick Corbett
      AskWoody_MVP

      After looking at a number of recent posts on several different forums about recent problems with Windows 10 networking with other client devices (both discovery and access), I’ve tried to distill them all into a set of questions to query from each affected device in order to (hopefully) spot issues.

      From my decidedly amateur standpoint, it appears a query tool needs to output answers to the following automated queries:

      ; ***** BASIC SETTINGS *****
      ; Hostname? (needs to be unique)
      ; Workgroup name? (needs to be the same)
      ; IP? (needs to be unique)
      ; Subnet? (needs to be the same)
      ; Gateway? (needs to be the same)
      ; IPCONFIG output in full (?)
      ; OS edition?
      ; OS version?
      ; OS build.release?
      ; Homegroup or workgroup or domain?
      ; Homegroup services running?

      ; ***** HARDWARE DISCOVERY *****
      ; What network adapters are in use?
      ; Are network adapters set as metered? (probably irrelevant)

      ; ***** NETWORK DISCOVERY – ALL NETWORK DEVICES *****
      ; Is network Private or public? (should be Private)
      ; Computer Browser (Browser) service startup type?
      ; Computer Browser (Browser) service status? (running/stopped)?
      ; Is device master browser?

      ; ***** NETWORK DISCOVERY – NEWER NETWORK DEVICES *****
      ; (Values: 2 = Automatic ¦ 3 = Manual ¦ 4 = Disabled)
      ; Function Discovery Resource Publication (FDResPub) service startup type? [Default is Manual (Trigger Start]
      ; Function Discovery Resource Publication (FDResPub) service status? (running/stopped)?
      ; Function Discovery Provider Host (FDPHost) service startup type? [default is Manual (Trigger Start) / 3]
      ; Function Discovery Provider Host (FDPHost) service status? (running/stopped)?
      ; Network Connections (NetMan) service startup type?
      ; Network Connections (NetMan) service status? (running/stopped)?
      ; Peer Name Resolution Protocol (PNRPSvc) service startup type?
      ; Peer Name Resolution Protocol (PNRPSvc) service status? (running/stopped)?
      ; Peer Networking Grouping (P2PSvc) service startup type?
      ; Peer Networking Grouping (P2PSvc) service status? (running/stopped)?
      ; Peer Networking Identity Manager (P2PIMSvc) service startup type?
      ; Peer Networking Identity Manager (P2PIMSvc) service status? (running/stopped)?
      ; UPnP Device Host (UPnPHost) service startup type?
      ; UPnP Device Host (UPnPHost) service status? (running/stopped)?

      ; ***** NETWORK DISCOVERY – OLDER NETWORK DEVICES *****
      ; Is NETBIOS running?

      ; SMB – FOR OLDER/DIVERSE NETWORK DEVICES LIKE NAS, LINUX, ETC.
      ; SMB1 parent protocol installed?
      ; SMB1-client protocol installed?
      ; SMB1-server protocol installed?
      ; SMB Direct installed?

      ; ***** MISCELLANEOUS *****
      ; Use Sharing Wizard checked?

      ; File and print sharing turned on?
      ; Public folder sharing enabled?

      ; Password-protected sharing status? (turned on/turned off)?
      ; (IF password protected sharing is turned ON, only people who have a user account and password
      ; on the device can access shared files, attached printers and the Public folders. If access to
      ; shared files is needed without requiring them having an account and password on your computer,
      ; then turn password protected sharing OFF.)

      ; List of user accounts?

      ; File sharing encryption level? (128-bit or 40/56-bit)?

      ; ***** FINISH UP – HOW TO PROVIDE RESULTS *****
      ; Show on screen, log to file, copy to Windows clipboard, tattoo on first male child… or what?

      (Apologies for the format… I’ve just plonked thoughts down in a [hopefully] logical order to hopefully query using a combination of AutoHotkey wrapped around PowerShell cmdlets. However, I would be the first to admit that I’m not at all sure if I’m not barking up the wrong tree…)

      Any networking gurus out there? IMO no-one currently has a handle on the network issues so many people are experiencing with Windows 10 at the moment, especially with Windows 10 1903.

      • This reply was modified 3 weeks, 4 days ago by
         Rick Corbett.
      2 users thanked author for this post.
    • #1849292 Reply

      NetDef
      AskWoody_MVP

      I’m a networking guru, and after they killed HomeGroup I could NOT get a peer to peer home LAN working reliably without turning on SMBv1 . . . and even then it’s spotty at best.

      And I have not had the time so far (or a home network anymore) to look deeply into what’s wrong. (I got so frustrated I installed an old copy of WServer 2012-R2 on an old computer laying in my basement to solve it.)

      The aggravating thing is that work networks that use MS Server Active Directory with DNS have no such problems (at this time.)  And here’s the best part:  Windows 10 Home can see peers on the LAN as well as AD joined workstations just fine when a Microsoft DNS server is on the subnet with them.  Even though they are not members of the domain. And without resorting to SMBv1.

      Things to try:  What if someone with the problem were to disable SMBv1, and deploy a tiny DNS server with machine name resolution for their LAN?  What happens to the P2P scenario then?

      ~ Group "Weekend" ~

      • #1849393 Reply

        mn–
        AskWoody Lounger

        Hm, I don’t have enough of Windows systems at home to test this… but a LAN-internal DNS server is a good idea for several reasons, especially if you have low-end networking gear that may or may not do funny things to broadcasts and…

        My current home router had the internal DNS turned on by default, actually.

      • #1849397 Reply

        Paul T
        AskWoody MVP

        Are we talking DNS and DHCP server?
        This implies the network IP as a name is available in the DNS, as is reverse lookup data.

        cheers, Paul

        • #1849723 Reply

          mn–
          AskWoody Lounger

          … yes, that’s what I meant.

          Not very rare for home routers and such nowadays to put up an inside-only DNS zone and populate it with the nodenames it gets with DHCP requests.

          It may not be on by default even if the feature is there, and if your device lets you specify a domain suffix while turning it on, take care to not override a TLD you need…

        • #1850190 Reply

          NetDef
          AskWoody_MVP

          Exactly, going to see if I can do an experiment this weekend to see what happens in this scenario.

          Assuming the bug(s) repro – half the time I try something like this everything decides to start working on it’s own . . . before testing.  😉

          ~ Group "Weekend" ~

    • #1849766 Reply

      Rick Corbett
      AskWoody_MVP

      Hmmm, network gurus… there’s a good chance you’ve scared the heck out of the OP…. and me. 🙂

      So… what can we do about this that is achievable by Joe Public?

      My broadband provider (hi, Virgin [on the ridiculous]) supplies a locked down cable modem/router that I just cannot change, other than the most rudimentary settings (Wus yur name?, etc.)…

      My difficulty is that I personally haven’t experienced this issue… possibly (probably?) because I always *clean* install rather than use an in-place upgrade?

      However, I do have pre-1903 (physical) devices that I can in-place upgrade (after saving a Macrium Reflect disk image, of course).

      Thoughts?

      • #1850201 Reply

        NetDef
        AskWoody_MVP

        Not sure what we can do for Joe Public directly, but if this idea works (and I just don’t know yet) we at least have actionable information.

        Not sure what we DO with that info:   report it to Microsoft, make recommendations on home network gear that does it right, or at least better understand the problems.

        ~ Group "Weekend" ~

    • #1851686 Reply

      NetDef
      AskWoody_MVP

      Some notes so far on my experiment.

      SMBv1 disabled on everything.

      Windows 10 Pro version 1903 and 1803 mix.

      An old server running Server 2012-R2 running DNS and DHCP in Workgroup mode (no DC, no AD.)  (A side note, Server 2012 really wanted me to DCPromo it when I installed the DNS service – I was able to get past that easily though.)

      Disabled DHCP on the home router. (There can be only one!)

      Had to muck around with deep network settings on the client systems to register themselves with DNS on the server (one has to manually set the Connection-specific DNS Suffix – delivering it via DHCP on a non Active Directory system does not work, which is a bug.)

      dnstest619a

       

      I can easily get to any peered network share if I know it’s name.  BUT the File Explorer still has inconsistent results on the Network group.

      Still investigating, but first thoughts is that this is not for the faint of heart, and I am not sure this is the right path.

      ~ Group "Weekend" ~

      Attachments:
    • #1852013 Reply

      Rick Corbett
      AskWoody_MVP

      Looking at posts on the interwebs, many people are posting that the following services need to be running:

      • Function Discovery Resource Publication (FDResPub)
      • Function Discovery Provider Host (FDPHost)
      • Function Discovery Provider Host (FDPHost)
      • Network Connections (NetMan)
      • Peer Name Resolution Protocol (PNRPSvc)
      • Peer Networking Grouping (P2PSvc)
      • Peer Networking Identity Manager (P2PIMSvc)
      • UPnP Device Host (UPnPHost)

      A quick check can be carried out using this:

      1. *Right*-click on Start; choose Windows PowerShell (Admin).

      2. At the PS prompt copy/paste the following:

      "FDResPub", "FDResPub", "FDPHost", "NetMan", "PNRPSvc", "P2PSvc", "P2PIMSvc", "UPnPHost" | foreach {Get-WmiObject -Class Win32_Service -Filter "Name = '$($_)'" | select Name, State }

      This gives me:

      query_services

      My difficulty is… my devices – a mixture of Win 10 (multiple versions), Win 7 and Linux Mint can all see each others’ respective shares… yet the WMI query quite clearly shows that I only have 2 of the supposed ‘required’ services running.

      Now I need to disable SMB1 on my Win 10 devices and play around with those services shown as not running. 🙁

      Hope this helps…

      Attachments:
      1 user thanked author for this post.
      • #1853607 Reply

        NetDef
        AskWoody_MVP

        Looks like we are on the same page.  What’s odd is that MS does not start two of the critical services automatically, the end-user-admin has to set them to start Automatically (delayed or not) in the Services MMC.

        Those two are:

        “Function Discovery Provider Host”
        and
        “Function Discovery Resource Publication”

        Further playing around continues.

        Edit:  the PnP Hosting service can be left on Manual.  It will trigger automatically if you install a service or device that requires it.

        ~ Group "Weekend" ~

        • This reply was modified 3 weeks, 2 days ago by
           NetDef.
    • #1857446 Reply

      NetDef
      AskWoody_MVP

      I’m going to try to write up what will likely be a long post on this topic, not sure I’m going to have time to finish it this week (awful lot going on at work.)

       

      Very short summary of my experiment: it failed to solve the problem.

      Very short summary of what almost worked: Setting just two key services to Automatic.

      “Function Discovery Provider Host”
      and
      “Function Discovery Resource Publication”

      Overall very short summary of the situation:  It’s badly broken, and has been since Windows 10 1803 – for both Home and Pro versions.  Even with the above minor changes, peer to peer LAN sharing is not reliable.

      Rant ON:

      Microsoft deprecated HomeGroups, which used to work fine. They failed to provide a working solution afterwards that does not require installing SMBv1.  The current situation feels and smells like a serious bug, and worse the results are not at all consistent between settings changes, and even on reboot with NO changes.

      / end rant

       

      And finally:  a very short summary of a workaround:

      After you create your shares, create shortcuts to them using UNC format.  You can copy those shortcuts to a USB drive and copy them to ALL your machines – and they will always work.

      A UNC file path looks like this:

      \\computername\sharedfolder (note the backslashes)

      Cheers!

       

      ~ Group "Weekend" ~

    • #1857767 Reply

      Rick Corbett
      AskWoody_MVP

      Whilst looking at this network issue I noticed the following on a PC running 1903 – a warning that it wasn’t connected to a network… displayed above the navigation pane showing another 2  networked PCs:

      1903_network_bug

      Clicking on the warning gives an option to ‘Connect to a network’… which does nothing.

      It turned out that the default power-saving is to disable power to the NIC which then recovers but still displays the warning. I’ve turned the power-saving off to save having to dismiss the warning each time it happens.

      Attachments:
    • #1859142 Reply

      Rick Corbett
      AskWoody_MVP

      I found this TechNet forum post – Master Browser Service broken after Creator update – the most informative one I’ve read so far about the issue. Although the original post date is September 2017, the latest post is March 2019 so covers the most relevant Win 10 versions… 1903 just continues the saga. If you do read the article, read through to the end before attempting any changes to your own network’s configuration.

      (It’s an interesting viewpoint that not providing a secure replacement computer browser service was a deliberate decision by Microsoft.)

      I also used Scottie’s Tech‘s LanScan 2.00 to determine which device is currently the Master Browser in my home network – see At long last, LANscanner works on Windows 10! for more info.

      Hope this helps…

      1 user thanked author for this post.
    • #1864370 Reply

      jackpet
      AskWoody Plus

      Makes me angry that Microsoft got rid of homegroup.  My network connectivity has now been  *spotty* (some days working, some days not) until I did the following:

      1 – Obviously, make sure sharing is on for the folders you want available on your network.

      2 – Make sure your smb settings are on in Programs and Features as outlined above.

      3 – Use the ipconfig command in the command prompt to find the lan ip for each of your networked computers.  (In Linux, it’d be the ifconfig or ip command).  It will look like this for any of you newbies out there – 192.168.0.xx  where xx is the specific number to each of your specific computers.  In my case, the range of xx could be any number between 10 and 200.

      4 – In the start menu search box of your main computer, type in the address of the machine you want to access exactly like this (without the quotes):   “\\192.168.0.xx”   (Make sure the slashes are as shown here and xx is a number.)  Create a folder (I called mine “Network” and create a specific shortcut to each \\192.169.0.xx you just accessed.  Of course, I then renamed the shortcuts to the names of the individual computers.)  This never fails.  You will open the networked folder *even if Windows is not seeing the networked computer.*    Now the problem is that your router is dynamically assigning ip addresses to your networked computers, changing the xx number every week or so in my case.  But we have a solution even for this.

      5 – You now need to know how to access your router.  Again, it has a local lan ip which in my case and in most cases is 192.168.0.1  Type this number in your browser to access your router.  You can find the username and password for your router by googling its model name and number.

      Almost all routers will allow you to *reserve* ip addressess.  (Important note: This is not the same as assigning a static ip address.  That would cause conflicts down the road.)   It merely means the router will not attempt to assign any different xx number to a machine that you have reserved a specific number for.  In my Hitron modem, I found the desired control under BASIC – DHCP RESERVATION.  I then reserved the xx numbers currently assigned to my 4 networked computers (one of them running Manjaro Linux), making these numbers permanent to their specific machine.  (The procedure for doing so was simple in my case – all point and click).

      You will have to repeat the above procedure on all of the networked computers that you wish to control the network from, if you want to have “2-way access.”  I had to do this in 3 of my 4 computers.  My wife doesn’t network from the 4th one so there was no need to give her the capability to access the other 3, but of course, there is still “1-way access” to her computer.

      I repeat.  *This never fails to open the desired shared network folder* even when Windows is being “finicky” and not allowing me to network otherwise.  (BTW FYI  The same trick works in Manjaro if you type “smb://192.168.0.xx” in your Thunar folder address box.  Of course, Samba has to have been enabled.)

      Hope this helps.  It may sound complicated for some but it’s not really.

    Please follow the -Lounge Rules- no personal attacks, no swearing, and politics/religion are relegated to the Rants forum.

    Reply To: What am i doing wrong? (Networking problems)

    You can use BBCodes to format your content.
    Your account can't use Advanced BBCodes, they will be stripped before saving.