News, tips, advice, support for Windows, Office, PCs & more. Tech help. No bull. We're community supported by donations from our Plus Members, and proud of it
Home icon Home icon Home icon Email icon RSS icon
  • Why so many Firefox processes?

    Posted on alphacharlie Comment on the AskWoody Lounge

    Home Forums AskWoody support Questions: Browsers and desktop software Why so many Firefox processes?

    Viewing 14 reply threads
    • Author
      Posts
      • #2256024 Reply
        alphacharlie
        AskWoody Plus

        I was surprised to see multiple instances of Firefox in Task Manager, when I think I am running one Firefox with 3 tabs.  What is the explanation here?

        screen shot attachedSnipped-2020-04-27-161407

        Attachments:
        2 users thanked author for this post.
      • #2256053 Reply
        anonymous
        Guest

        Interesting. For my part, I’ve always had a number of processes equal to exactly: OpenTabs + 1.

      • #2256109 Reply
        Lars220
        AskWoody Lounger

        I noticed this also. I use Firefox 75.0 on Windows 10 v1909.720 and my 2013 computer has just been upgraded to 16.0 GB of RAM from the previous 8 GB of RAM. But yes, Firefox likes to use many processes and especially with more tabs open. Here is a link to support mozilla org with some interesting information and some items to try / check out.

        “At times, Firefox may require significant system resources in order to download, process, and display web content. If you are experiencing periods of sustained high resource usage while using Firefox, this article presents some options for you to review.”

        https://support.mozilla.org/en-US/kb/firefox-uses-too-much-memory-or-cpu-resources

        Maybe one of our AskWoody tech experts can further enlighten us   🙂

        2 users thanked author for this post.
      • #2256152 Reply
        bratkinson
        AskWoody Plus

        As I almost always use Firefox with one tab open, I’ve noticed I always have 5 processes running and more if I have additional tab open.

        I’m guessing that Firefox has one of the active processes doing an occasional check for updates, the same as Adobe, Microsoft, and others do with their products.  It’s also likely there’s a process to ensure that it hasn’t been tampered with or pirated, also like Adobe, Microsoft, and A/V products.

        There may even be a process to ensure that the others haven’t been ‘killed’ (terminated) and will automatically restart any that were.  In fact, most products, including Windows and A/V software have that kind of code in every module, that checks all the others to ensure they’re still running, and restarts them if they’re not.  I think viruses started with that ‘trick’ to make removing them quite difficult.

        What are the other processes doing?  The downloaded file activity checker I use reveals Firefox is occasionally reading files buried deep in the users\<user id>\Appdata\Roaming\Mozilla\Firefox\Profiles folder.  It’s also reading some Microsoft files in \Apdata\Roaming\Microsoft as well.  In addition, it’s reading files in my Norton 360 folder due to the Norton Safe Browsing add in to Firefox.  Which process is doing what is open to conjecture.

        • This reply was modified 7 months, 1 week ago by bratkinson.
        • This reply was modified 7 months, 1 week ago by bratkinson.
        3 users thanked author for this post.
      • #2256262 Reply
        Paul T
        AskWoody MVP

        Multiple browser processes is usually a way to prevent bad actors crashing the browser and affecting your PC (malware). If a process crashes it remains isolated and can be closed without affecting the browser.

        cheers, Paul

        4 users thanked author for this post.
      • #2256304 Reply
        Bundaburra
        AskWoody Plus

        It allows FF to run multiple browser processes, usually at least one per open tab.  To quote from the above support article:  “You can set between one and eight content processes. The default is eight. Having more content processes can improve performance when using multiple tabs but it will also use more memory. You can reduce the number of content processes if your computer is running out of memory.”  The number of processes is set in Options > General > Performance > Content Process Limit, with a default maximum of 8, but if you have plenty of memory and want to go higher than 8, the setting in About:Config is dom.ipc.processCount.

        Windows 10 Pro 64 bit 20H2

        4 users thanked author for this post.
      • #2256335 Reply
        Alex5723
        AskWoody Plus

        I was surprised to see multiple instances of Firefox in Task Manager, when I think I am running one Firefox with 3 tabs.  What is the explanation here?

        Just copying Google’s Chrome multiple tasks 🙂

      • #2256576 Reply
        anonymous
        Guest

        Chrome and I think even Edge have been running multiple processes for quite some time now. They usually open up a new process for each domain name visited and group all of the processing activity under that one process. It helps with stability and security: stability in that, if one process crashes, it won’t take down the entire browser; and security in that, if one tab goes rogue, it won’t affect the other tabs and can easily be sandboxed. Firefox was actually the last of the main browsers to adopt this system, but they’ve technically been running multiple processes since Firefox 3.6 I think (yes, I’m not that young), when certain plugins like Flash and Silverlight ran in a process called “plugin-container.exe”, so if the Flash Player crashed, it wouldn’t crash the entire browser.

        1 user thanked author for this post.
      • #2256887 Reply
        Ascaris
        AskWoody_MVP

        The e10s project in Firefox (short for “electrolysis”), which broke up the browser into multiple processes instead of just one (as browsers used to be back in the single core CPU days) was about more than security.  That was a big part of it, but e10s, or multiprocess Firefox, also allows it to be much more responsive and smooth in use, especially on multicore CPUs that have been the norm for a long time now.

        The older single-process Firefox would often stutter and judder and suffer from all kinds of jank, which was particularly noticeable while scrolling.  When the content rendering is happening in the same process as handling the drawing of the UI and responding to user input, sometimes there is a long blocking operation in a content rendering thread, meaning that once the CPU begins to execute that bit of code, it can’t do anything else until it’s finished. Normally, a multitasking OS can switch from one thread or process to the next at will (and it does so all the time), but a long operation hangs it up until it’s done, and it can’t switch around to make things more responsive.  Multiple cores make this task switching that much easier for the OS to accomplish, but if there’s only one process for a browser, a long operation just stops the whole browser until it is done.

        While this takes only a fraction of a second, usually, if the user is trying to scroll or click something right during that time, there will be a perceptible pause or lag while the CPU finishes what it was doing to get ready to do the next thing.  This can happen multiple times in a second, and it’s definitely noticeable to the user (some more than others).  I’m one of those who is quite sensitive to it, and for me, the juddery jankiness is just maddening.

        In multiprocess Firefox, though, the process that renders the UI and accepts user input does only that, while the content is rendered in one or more additional processes.  While the blocking operations still take place, they no longer force the UI to wait, so scrolling is smooth even while the content process handles the long operations.  Recent versions of Firefox have a number of content rendering processes (it might be one per tab at first, but as the number of tabs grows, each process expands to cover multiple tabs) in addition to the main thread and another one dedicated to addons (which should show up as “webextensions” in the task manager).

        For me, e10s is a “killer” feature, and is why I never really warmed that much to Pale Moon in recent years.  I like what they are trying to do, but there are no plans to ever include e10s.  I recently revisited PM after a few years of using multiprocess Firefox and derivatives (like Waterfox), and I was a little surprised that the jank wasn’t as bad as I had remembered single-process being, but it still was not as glassy smooth as Waterfox and Firefox.

        It is possible to set a pref to restrict the number of processes that Firefox will use, including turning e10s off and having it run in a single process, like it used to years ago.  I am not sure why one would want to do that in a practical sense, outside of using some older addons that don’t work with e10s (which is not an issue with Firefox proper anymore, as addons that old can’t be used anyway), but it is possible.

        It is true that the overhead for each process means that more RAM is used for multiple processes, but unless you’re having problems with being short on available memory, that’s not a problem… the RAM is there to be used.  Even on my RAM-challenged Acer Swift, which has 4GB and isn’t upgradeable (the RAM is soldered to the motherboard), I use the maximum number of processes that Waterfox allows. When there are a lot of tabs open, as there usually are in my case, and Waterfox is using a lot of RAM, the OS can swap the bits not in use at any given time out to the virtual memory swap file on the SSD.

        If it was possible to add more RAM, the enhanced use of the swap file would not be necessary, and indeed, on my PCs that have more RAM (16GB), virtual memory is seldom used at all.

        Group "L" (KDE Neon Linux 5.20.4 User Edition)

        4 users thanked author for this post.
      • #2258914 Reply
        George S. Augustas
        AskWoody Plus

        Whilst reading this article, I checked Task Manager just now. I only have one tab open, and Firefox is using five processes. I wondered if it might be due to the browser add-ins: I have Adblock, Adblock Plus, Hide Google Doodles, Disable Autoplay, and Autofill Forms.

        • #2259316 Reply
          WSJCitizen
          AskWoody Lounger

          @George S. Augustas — Actually I was going to say that is what the true purpose of multiple instances of the same browser usually are. The previous reasons are true, but since I usually only use one tab at a time, I did a little experiment to see what happened when I ended each task. It turned out each “extension” quit as I ended each process. Since modern browsers no longer accept the old plug-in and extension model, they had to go to the “app” model – if that is a good term – so each process is separate but used through the original window, or tab of each browser – Chrome does the same thing. This improves the security of the browser to vulnerable “extensions”.

      • #2259441 Reply
        anonymous
        Guest

        The reason some of these three extra processes are appearing in the Background processes section of Task Manager is unclear and would require further investigation, that behavior happens sometimes when using Waterfox. (Just wanted you to know that you are not the only person to see those separated processes in Task Manager.)

        Looking forward, in progress is Mozilla’s Project Fission, their attempt to recreate site isolation like Google has created for their Chrome browser. When they are able to complete the work there probably be more processes when using Firefox.

      • #2313314 Reply
        anonymous
        Guest

        E10s is a nightmare for me using the 32Bit version (32BitWindows10)…

        If I try to open a link from an Email Client (e.g Thunderbird) Firefox (Always latest version) just opens to a blank white page. When they first implemented E10s I could disable it with a statement in Environment Variables. I used that for years to get rid of E10s which allowed me to open Email Links correctly. Then they took away the ability to disable E10s in environment variables in around Firefox 79. So now if I click an email link and Firefox is closed Firefox opens to a blank white page. If Firefox is open I can click on an Email link and Firefox responds correctly but I have to make sure Firefox is first open.

        And before someone says disable addons, or start in safe mode or uninstall and reinstall Firefox…I’ve tried all of those. Does not fix the problem for me and is the same on all NINE of my Windows 10 machines (ALL 32 BIT Versions). I am so frustrated with Firefox taking away the ability to disable E10s I am seriously considering switching browsers after having been a loyal Netscape/Firefox user for more than 20 years. The new Edge (Chredge) does not have the problem but I don’t trust it. I’ve been contemplating a switch to Brave but not sure if it’s really security tested.

        • #2313323 Reply
          Ascaris
          AskWoody_MVP

          I had not been aware that Mozilla had removed the ability for single-process Firefox. I’ve been using multiprocess since well before it was officially released, and I haven’t tried to disable it in a long time. It’s not surprising, though.

          I’ve been very critical of Mozilla on many occasions for removing valued options in the interest of simplifying the browser, but in this case, I can’t fault them for making multiprocess standard. Now that Classic addons that don’t support e10s are all obsolete anyway, there’s not any real reason to disable it. The issue you describe is not the intended behavior for multiprocess Firefox… there’s a bug or misconfiguration somewhere messing things up, and that being the case, the best answer would be to fix it instead of keeping around an obsolete feature (from a time when everyone used single core CPUs, and where browser security wasn’t really a big issue) to allow working around the bug.

          The most common objection I’ve seen to e10s is about memory use. To that end, you can go to performance under Preferences and set the content processes to 1 (you will have to uncheck the box for “use recommended performance settings” to see it). That will eliminate the per-process overhead for each content process, though the main process will still be separate from the content process (and if you use extensions, that process will be separate too).

          Note that Chrome has had multiprocess from the start, and it can’t be turned off either.  It seems to me that the real issue isn’t that Firefox took away the ability to turn e10s off, but that Firefox does not work as intended when following links from Thunderbird (which it should do even with e10s on).

          The first step to troubleshoot would be to create a new profile on Firefox, set that as default, close Firefox, and then try to open a link from Thunderbird there. If the issue persisted with the new profile, you would know that the issue is not in the Firefox profile.

          In your attempts to fix it before, did anyone suggest going into the Thunderbird settings under attachments and reset the HTTP and HTTPS types to “always ask,” then choose Firefox from there (and after you see that it works, do it again and check the box to make the choice permanent)? I’ve had other issues with opening links from Thunderbird (specifically, it kept opening a browser that was not the default one), and that fixed it, even though it had said “Firefox” before (and was still opening it in something else).

          I would also be interested in knowing the contents of the prefs network.protocol-handler.app.http and network.protocol-handler.app.https in Thunderbird. I am not sure if those prefs are in use anymore (things change so often, it’s hard to keep up), but if they are still current, a malformed entry here could be at fault if the above didn’t help. There was one reference I saw to someone using the Linux version of FF and TB that had the same issue you do, and the problem was that the path in the prefs above just had /usr/bin/firefox, not /usr/bin/firefox %u, where the %u was the placeholder for the URL that would be passed to Firefox.

          Another reference to the same behavior you describe in a search was reportedly fixed by using the Firefox “refresh” feature, which would be one way of trying to address the issue if the new profile test showed that the issue was in the old profile. That’s liable to undo some prefs you don’t want to have undone, which you would have to put back in, but it’s possible that an errant pref (that you may have inadvertently copied to all of the other computers if you would do it as I would, which is to say you would copy the profile over) is at fault.

          It sounds like you’ve already been down this road, but if you want to try to troubleshoot it, just post a thread with the issue described in the title and we can try to help.

          If you do decide to switch to Brave or another Chromium derivative (I would suggest Vivaldi if you like a lot of customization), that is certainly your prerogative, of course. You could also use Firefox ESR, which is currently based on 78, one version before you said they no longer allowed turning off e10s, or Waterfox current (based on 68 ESR, but with security fixes still up to date). I’d suggest finding the root cause (I think e10s isn’t the root cause, but is just forcing some other problem to the surface) and leaving e10s on, even if you turn it off until an answer is found, but that is up to you.

          Group "L" (KDE Neon Linux 5.20.4 User Edition)

          • #2313382 Reply
            anonymous
            Guest

            Thanks for your help. This is a many year problem on all my computers that have been upgraded countless times to new versions of Windows 10, Firefox, and Thunderbird.

            BTW the problem is exactly the same when I had Eudora set as the email default. Eudora also would open Firefox to a blank white page “IF” E10s was enabled. This problem first surfaced when E10s was first enabled (I think four or more years ago. At first you could disable E10s in about:config. Then they took that away. That left being able to disable E10s only through an Environment Variable. They finally took that away as I said I think in Firefox 79.0.  It has been a royal PIA since then. If I click on a link in Thunderbird with Firefox closed it opens to a blank white page. I failed to mention after I do that I have to close Firefox and then kill the Firefox processes in Task Manager before I can open Firefox again (Or let Windows bark at me that Firefox is already open and do I want it to close it for me before reopening). Like I said if I have Firefox already open then I can click on a link in Thunderbird and the link is passed through to Firefox correctly and Firefox goes to the webpage. Others in the past have reported this behavior but some reported they were able to correct it by make a new profile or reinstalling Firefox. Neither has worked for me. I just tested again creating a new profile in about:profiles and set it to default. I then tried clicking a link in Thunderbird (With Firefox closed). It opened the new Firefox profile to a BLANK PAGE (Just the same as with my normal profile). My memory processes are already set to 1 (As like many I dislike having memory eaten up especially since I am on a 32 bit machine where the max I can ever have is about 3.5GB memory available. Changing the memory process figure has no effect on this problem. Firefox is set as the default browser and I verified Thunderbird is set as the default Email Client.  I also tried starting Thunderbird in SAFE MODE disabling everything and opening the new profile in Firefox…And it opened to a BLANK WHITE PAGE. It seems to be a memory issue with how http or https links are passed as if I have Firefox already open it works correctly and if Firefox is closed  then the system hangs requiring me to close Firefox blank white page and then kill Firefox  processes in Task manager. This has been the same situation for years with my systems in regards to E10s but of course in the past I could disable E10s and eliminate the issue. Now I can’t. I agree that fixing the problem rather than disabling E10s is preferable but I’ve never been able to get it to work any other way.

            • #2313557 Reply
              Ascaris
              AskWoody_MVP

              My memory processes are already set to 1 (As like many I dislike having memory eaten up especially since I am on a 32 bit machine where the max I can ever have is about 3.5GB memory available.

              Intel and AMD both stopped manufacturing 32-bit consumer CPUs in about 2006. Are you certain that the machines in question are not just 64-bit with not a lot of memory? Machines from that era would be single-core slowpokes with modern software.

              My out and about laptop, the Acer Swift 1 (which I am using now, as I am out and about!) has 4GB RAM, non-upgradeable, which ends up at 3.7 GB available to the OS when the iGPU and other such things take their bits out of the total. It came with Windows 10 64-bit, which I quickly replaced with Linux 64-bit.

              I considered using 32-bit, given the memory constraints of the platform, but I ultimately went the same way as Acer when they chose x64. Whether we like it or not, x86 (32 bit) is on its way out. Ubuntu stopped offering 32-bit versions starting with 19.10, and the current LTS release (20.04) upon which many downstream distros like the one I use, KDE Neon, are based is 64-bit only. Virtualbox is only offered in 64-bit now, and the browser I was using when I bought the Swift, Waterfox (now Waterfox Classic) only ever had a 64-bit version. It’s happening more and more, and it won’t stop.

              As for content processes, I crank ’em all the way up on the Swift (set to 8, the current maximum). I keep a lot of things open all the time, and I use a lot of tabs in the browser, so things like using 32-bit and one content process are not going to be enough. I did a test (described in one of my posts, though I have no idea what I called it) a while back on 32-bit browsers vs. 64-bit browsers, and also single content process vs. multi content processes, and there was a difference, but it wasn’t a massive one.

              As such, I rely on Linux’s robust virtual memory subsystem to keep things going (Windows’ virtual memory is quite good too). The sites that are in background tabs are going to be swapped out if necessary anyway, so I might as well put the pedal to the metal. I use Linux, so my examples will be of Linux, but the principles are the same in Windows.

              Linux has several parameters that can be used to tune the virtual memory behavior, and the best known one is called ‘swappiness.’ It tells the system how eager it should be in swapping RAM out to the swapfile (called pagefile in Windows). While a lot of “speed up” guides suggest people set theirs to low values (default is 60, on a scale of 0-100, for Ubuntu), I put mine at 100. It swaps early and eagerly, as you might expect, and that’s what I want. My thought is to get the stuff that is idling in the background out of RAM and save that precious resource for active programs that need it!

              By swapping long before memory pressure begins to build (memory pressure occurs when the system is finding it more difficult to find available RAM to assign when programs need it), the idea is to prevent the dreaded thrashing. Avoiding thrashing is what people think they are doing when they set swappiness to a low number like 5 or even 1.

              People confuse VM (virtual memory, in context, not virtual machine) with thrashing, so they think delaying the use of VM delays thrashing, when the system grinds to a crawl and is struggling not to crash. Linux will eventually begin killing processes to recover their allocated RAM and prevent crashing, while Windows will bluescreen.

              Without VM, though, the system would already have crashed or started killing processes long before the time that the thrashing started with VM. VM delays the memory crisis (often long enough to prevent it completely, if the reason for the memory crisis is the user opening a lot of programs and not a memory leak that will consume it all of it eventually). VM isn’t the cause of the memory crisis!

              I am not sure if Windows offers VM tuning like what I described, but even without it, VM can make a low-RAM PC a lot more usable than it otherwise would be.  I found Windows’ VM to work quite well in limited RAM situations, and at first (when I bought the Swift) I was skeptical that Linux would be able to do as well as Windows, but it does for me as it is configured.

              In the case of my Swift, the swap file is on a SSD (SATA, as the m.2 slot is not wired for NVMe), and that helps a lot. It wouldn’t be nearly as responsive and quick feeling if it was a hard drive, and the whole “use VM as much as you can” strategy may not work as well as it does. The swapping is far faster, in or out, and the result is that I’ve quit worrying about RAM on the Swift… I just use it, and it handles the memory for me nicely.

               

              Group "L" (KDE Neon Linux 5.20.4 User Edition)

        • #2313324 Reply
          Bundaburra
          AskWoody Plus

          Could you effectively disable E10s by setting Content Process Limit to one, or even zero (via dom.ipc processCount)?

          Windows 10 Pro 64 bit 20H2

          • #2313387 Reply
            anonymous
            Guest

            I just tried editing dom.ipc processCount in about:config. You can only toggle from True to False (In Firefox 83.0). I tried that. Then clicked on a link in Thunderbird and it opened Firefox to a BLANK WHITE PAGE.  Toggled the setting back to True.

             

            • #2313658 Reply
              Bundaburra
              AskWoody Plus

              I am also running FF 83.0, but when I look at dom.ipc.processCount it contains a number.  Tried changing it to a different number and back again, which seemed to work.   Stands to reason that if it is a “process count” then it should contain a number.

              Earlier this year I was having a similar problem to yours with Firefox 73.0 – see this post, and in particular my entries #2140952 and #2153174.  But I have not had those problems since then.

              Windows 10 Pro 64 bit 20H2

      • #2313618 Reply
        anonymous
        Guest

        Ascaris,

        All my machines are 32bit Windows 10 Home or Pro versions (They are all OLD) All were upgraded this month to 20H2 (32Bit)… I prefer to stay with 32 bit as I have no need for a 64bit OS as my drives now are all SSDs of 512MB or less and my memory is 4GB on all systems except for one tiny Windows 10 tablet that has 2GB RAM…The funny thing is I discovered that the little Windows 10 tablet (32bit) with only 2GB of RAM doesn’t have the problem that all the other Laptops and Desktops do. It will pass a email link from Thunderbird to Firefox without issue with E10s enabled. I also have lots of old devices that still work great under Windows 10 32bit but may or may not work under 64bit Windows. And I’m certainly not going to redo the OS and all applications on the eight Windows 10 machines just to fix this nagging problem that has existed since E10s was implemented. So…I’ll use it like this until I’ve had enough then uninstall Firefox and go to a different browser. I know Chredge works without issue with E10s enabled opening webpages without issue from Thunderbird even if Chredge is closed. So that’s always an option. I don’t believe Firefox 78 ESR is a long term solution as they’ll probably just break that in the next year or two…I’m not sure I want to go with the smaller Firefox Forks….I do have one system that boots an Ubuntu fork and I use that for grins once in a while…Very fast….But the lack of Application support makes me not use it very much (I do keep it updated)…Thanks for your help…I suspect my Firefox days are numbered.

        P.S. today I also completely uninstalled Firefox and deleted all leftover entries with RevoUninstaller…Then installed a brand new copy of Firefox with a totally new Profile with no addons. Then I tested to see if it would open a Thunderbird email link when the new copy of Firefox was closed. NOPE….Did exactly the same thing…Opened to a blank white page. That was with a totally fresh install of Firefox with a new profile and no customizations or addons.

        PS Meant SSDs are 512GB or less and of course Chredge works as it doesn’t have anything to do with E10s…Getting late here (Old brain)…

        • #2313979 Reply
          Ascaris
          AskWoody_MVP

          All my machines are 32bit Windows 10 Home or Pro versions (They are all OLD) All were upgraded this month to 20H2 (32Bit)… I prefer to stay with 32 bit as I have no need for a 64bit OS as my drives now are all SSDs of 512MB or less and my memory is 4GB on all systems except for one tiny Windows 10 tablet that has 2GB RAM

          That’s what I am trying to tell you. It’s certainly your choice, but the suggestion for 64-bit is not just about the amount of RAM you have. It’s also that 32-bit is on its way out across the computing world, and 32-bit versions of programs will be phased out eventually (several of the ones I use all the time already had this happen, but it’s coming for the rest).

          The number of people using 32-bit is shrinking all the time, and any software in its 32-bit version that is still being offered will almost certainly be tested less than its 64-bit versions (Windows 10 included, now that consumers are the beta testers), and bugs that may be specific to 32-bit won’t be detected as easily as those that show up in the 64-bit versions. It is possible that the Firefox issue you have been having is like that, and I do see that you said you are not about to redo all of those machines in 64 bit to fix that one bug (perfectly understandable, as that’s a lot of work), but it’s more to illustrate the principle that less people on 32-bit means bugs that only affect 32-bit (if they exist) will probably escape detection before the software is released.

          In addition, when you search the web to try to find solutions, whether by searching for others with the same issue or by finding a forum to ask the question directly, the odds are that advice that is based on a recent program, like Firefox 83, will all be about 64-bit versions, and it may or may not apply to your situation.

          It could also be that this bug has nothing to do with the “bitness” of Firefox or your OS, and there is some other weird thing going on.

          Ultimately, if your only problem with 32-bit at the moment (if it’s even a function of that, which we do not know!) is that Firefox does not behave when a link is opened from the email client, and you find it to be an acceptable solution to use a Chromium based browser, then there’s nothing more to fix, and obsolescence only happens when your OS or hardware can’t do what you need it to do.

          Group "L" (KDE Neon Linux 5.20.4 User Edition)

          • #2314138 Reply
            wavy
            AskWoody Plus

            and even the Raspberry PI is going 64 bit 🙂

            🍻

            Just because you don't know where you are going doesn't mean any road will get you there.
      • #2313898 Reply
        anonymous
        Guest

        Bundaburra,

        I went and looked at dom.ipc processCount again…I hit the garbage can icon to get rid of the current value and then I had the option for a number…I tried 1, 0, -1. Each time restarting Firefox. Unfortunately it appears that E10s multiple processes are enforced (for me) as I still had three to five copies of Firefox in memory even after trying each of those settings. And of course my email link problem remained as E10s was still intact.

        Others are also trying to find a way to disable E10s….The only success thus far has been to load an older Portable version for Firefox which then allows the Environment variable to work…But unfortunately this is not a long term solution.

        https://www.sevenforums.com/browsers-mail/424467-looking-way-disable-e10s-firefox.html?s=c981d4f9df81d8811896a58f45ebb51f#post3480747

      • #2313993 Reply
        anonymous
        Guest

        Ascaris…You are right of course regarding 32bit and 64bit…But I have so much old software and devices that still run great on Win10 32bit I decided a long time ago I will just stay with 32bit Windows until it no longer exists…And at that time I’ll make the move to 64bit Windows…I’ll use migration software (I’m very familiar with PCMover and can get multiple copies for a low price compared to other migration software)…I’ve used PCMover to do lots of migrations of old software to new(er) computers but never from 32 to 64bit (But PCMover can do that as well)….I’ll probably have to spend 1 to 2 weeks doing it unless my systems die before then…I don’t need all of them but I never met a PC I didn’t like…I use 3rd party AV and Malware protection above and beyond what is in Windows. I’ve tested 64bit Windows before on an older system with 4GB of RAM and to be honest there was no appreciable speed difference and I wouldn’t be upgrading any RAM on anything (Or installing a gamer GPU 🙂  .  Infact the 64bit version of Windows did in fact introduce it’s own list of problems (drivers) and I didn’t even try to install older 32bit applications. I’m pushing 60 so who knows if I’ll even be around (or compus mentus) when x86 is finally killed off…Might have to bury me with my original IBM XT 286 (Which I still have in a box in the attic…Last time it was powered on and it was fully working was 1996 it has in Intel AboveBoard Memory card in it with SIP memory that gave me a whopping 1.5MB of RAM. (The  hard disk is HUGE (5MB).)

        I signed on to the Internet with a 386SX with 4MB of RAM, Windows 3.1 and a 14.4 modem in December 1996 with Netscape Navigator 1.x and have been using Netscape/Firefox pretty much since then so leaving Firefox is a little hard to do (sentimentally) but it may have to be the case. I checked with my AV today and it only supports IE, Firefox, Chrome and Edge. So it has to be one of those….So Edge is already installed so that transition will be simple…But I’ll hold on to Firefox a while longer…………

    Viewing 14 reply threads

    Please follow the -Lounge Rules- no personal attacks, no swearing, and politics/religion are relegated to the Rants forum.

    Reply To: Why so many Firefox processes?

    You can use BBCodes to format your content.
    Your account can't use Advanced BBCodes, they will be stripped before saving.