• Win 10 22H2 upgrade woes-gpedit User; KB 5005463

    Home » Forums » AskWoody support » Windows » Windows 10 » Windows 10 version 22H2 » Win 10 22H2 upgrade woes-gpedit User; KB 5005463


    Updated from 21H2 w/Jan CU installed to 22H2 via KB5015684 (as per post #2491427).


    • I use Winshowhide. Ran right after ‘manual’ update. Dreaded KB5005463 that has been hidden for a yr no longer shows in either ‘Hide’ nor ‘Unhide’? It does not show in ‘Apps & Programs’ to uninstall, is awol.
    • searching for gpedit (Edit Group Policy) no longer works in my USER account. In Admin Account, searchbox for ‘Edit Group Policy’ shows only HKEY & HKCU for that (Admin) account only. Using ‘Run’ gpedit.msc in User throws error ‘access denied’, when I was able to access prior to upgrade. Means I have no way to modify HKCU settings for User acct at all  ie get rid of the pesky “trending searches’ which was successful in Admin acct.
    • other Stgs were flipped on, and sure wish I would have taken scrn shots of 21H2 services.msc, as there is a holy host of new ones on.

    I read here not to use GRC In Control when using Winshowhide. GP Target Release is holding at Win 10 22H2. No ‘Win 11 pending’.

    Older Dell Optiplex, only changes to note, other than ‘Accounts\Sync Stgs’ were on, and in Notifications & Actions “Edge, MS Store, Backup” stgs defaulted to ‘on’ yet again. Device Security processor details (manufacturer change to ST Microelectronics vs Dell), and TPM has a subversion now of “2,3” even though BIOS shows 1.2.? No ‘Dell recovery’, no bitlocker.

    Didn’t know whether to split this up under multiple topics, but it is odd this all just occurred in minutes.

    No Dell Support Assist nor Command update installed at this time (last was Aug, uninstalled, no devices out of date).  Pretty bare bones setup-not sure why this occurred with 22H2. Help?

    • This topic was modified 1 month, 3 weeks ago by Deo.
    • This topic was modified 1 month, 3 weeks ago by Deo.
    • This topic was modified 1 month, 3 weeks ago by Deo.
    Viewing 15 reply threads
    • #2531649

      Is this a Windows 10 professional or Windows 10 Home?

      Susan Bradley Patch Lady

      • #2531662

        Win 10 Pro. GP edit “2” etc, as per  knowledge base 2000016

        NOTE: stgs hardened via GP edit: NO drivers via windows..no Mstore auto update etc. No conflicting programs (very few: itunes, M/Reflect,few intel mgmt, RST), no Ffox-uninstalled, nothing much else).

    • #2531674

      Maybe your hardening results in an inability to use GPedit  after 22H2?

      This thread has a possible solution.

      cheers, Paul

      1 user thanked author for this post.
    • #2531679

      Thank you Paul, yet you would think others on 22H2 would have a problem with a local User HKCU suddenly NOT even showing up under a local admin account via gpedit? If so, then why no access via User to it’s own HKCU? I’m not nec looking for User to have all access (otherwise I’d just make it an Admin acct). Your thread is interesting, yet from 2015, and seems to suggest just that? Hmm something is off here-prior to 22H2, I could at Least see & access HKCU of User under admin, and make subtle changes there with 21H2 and before… and where did kb5005463 go? (I did a clean sfc /scannow prior to installing 22H2 as per above;  I made no changes to any Hkey, not even for the Edge thing, just rode it out. I only use GPedit, haven’t changed a thing there)

    • #2531682

      I’d run DISM and SFC again to be sure.

      cheers, Paul

    • #2531683

      I read here not to use GRC In Control when using Winshowhide

      You don’t need InControl on Windows Pro. Just set TRV in GPEdit.

      Try fixing the GPEdit problem by running DISM Check health , DISM Restore health and SFC Scannow.


      1 user thanked author for this post.
      • #2531696

        Anyone using directions in this minitool site, pls note DISM.exe will throw you an error 18. Just use DISM solo no . exe, followed by commands depending on what you’re doing.

        • #2531707

          Those commands work fine with the .exe, and that’s how Microsoft always list DISM commands in their documentation:

          DISM.exe /Online /Cleanup-image /Restorehealth

          Use DISM

          DISM.exe {/Image: | /Online} [dism_global_options] {servicing_option} []

          DISM Global Options for Command-Line Syntax

          Windows 11 Pro version 22H2 build 22621.1485 + Microsoft 365 + Edge

          • #2531830

            Thk you, both versions work – was a late night typo re: DISM.exe command. Feel free to delete my reply.

            1 user thanked author for this post.
    • #2531695

      Ran both. 2x to be sure. All clean.

      Just wrote in depth reply… tried to post, got Bad Gateway 505 if I remember correctly????

      Problems at Ask Woody?? Maintenance I assume?

      HKEY Users under admin acct now have 6 folders: . Default; S-1-5-18, 19, 20, & two 21’s with long strings ending in -1004, 1004_Classes. Prior to, my user was clearly annotated. With one as my User name vs a probable ‘public’ folder is no longer discernible as it was before update.

      No HKCU other than Admin. Gpedit user still no longer accessible when in User, no HKCU there.

    • #2531756

      HKEY users should have multiple children. The long strings are the user(s), which map to HKCU when you are that user.

      What exactly do you get when you try to run Gpedit?

      cheers, Paul

    • #2531788

      Just a data point – on my Windows 10 22H2, but I believe it was always true, in my Limited user account running gpedit.msc gives error “you do not have permission to perform this operation.” “access is denied”  then when closing the error it opens with a non-functional red x.

      I always had to right click it and run as admin or run it from admin command prompt.

    • #2531822

      What exactly do you get when you try to run Gpedit?

      This is GPedit from User account

      I always had to right click it and run as admin or run it from admin command prompt.

      That doesn’t seem to work, I end up in Admin Group policy.

      Trying to “run” regedit in User account gives me this error:


      This issue, (lack of User access to either gpedit or regedit), part of my original post, came to light as I was simply trying to get rid of ‘Trending Searches”, as per this workaround https://answers.microsoft.com/en-us/windows/forum/all/how-do-i-remove-this-trending-searches-window-from/9937e3fe-3fd7-4eed-966b-1764d35c610b which was successful in Admin account. However, can’t access User account registry to apply it to User account.

      Still don’t know what happened to kb5005463? As well, I can no longer use the Search Box OFFLINE in the User Account since upgrade to 22H2  (just get a black box)…?

    • #2531826

      HKEY users should have multiple children. The long strings are the user(s), which map to HKCU when you are that user.

      This is what I get in my Admin acct (see attached):

    • #2531878

      Back to the 5005463 anomaly:
      It shows NOWHERE as ‘installed’, not even in registry, Prog & apps, WU updates, windows  flyout.
      -Could it be ‘waiting in the wings‘? Prior to restart after updating via enablement pkg, I put ‘metered connection ON’ so as to run winshowhide as soon after reboot and online (when noticed it disappeared from winshowhide).
      -enablement package kb5015684 shows up as installed under Windows updates, unlike some users reporting only in ‘control panel’ here at AW kb-5015684-shows-up-in-update-history-

      -ALL my restore points going back to Jan 9 (2H12) are still visible???

      -The only ‘GPedit stgs” I have in place are: GP ‘2’, TRV at Windows 10, 22H2; block windows drivers updates; One Drive disabled (local accounts, don’t use it); new & interests disabled. That’s it.
      -still no longer have ‘offline search’ in User since install 2H22. Still no regedit access via User. (Offline search was same pain for 2 months in early last year, finally worked after updates June?)

      -Removed ‘tweak’ key I was attempting (above) in Admin for ‘trending searches’ from Admin before posting yesterday. Backed up registry.
      -checking C:/Windows/SoftwareDistribution/ReportingEvent.log as txt file shows what I presume as winshowhide holding back 3 updates. Out of my realm to read.

      -Still wondering why TPM change as in my OP. Haven’t been on this PC more than 3x/mo.

      Anyone else have this expercience? What to do. Cheers!

      PS tried admin command prompt “wusa /uninstall /kb:5005463” to no avail.

    • #2531900

      Trying to “run” regedit in User account gives me this error

      Do you get the UAC prompt to run regedit as admin? If not that may be why you can’t add keys.

      This is what I get in my Admin acct

      You have 2 users on your system, as can be seem from the 2 long entries. this is normal.


      This is the PC health check app and is not required.
      You can’t find it in Control Panel.
      From itechtics

      Navigate to Settings app >> Apps and then search for “Windows PC Health Check” in the search bar. Click on the app and then click Uninstall. If prompted for confirmation, click Uninstall again.

      cheers, Paul

    • #2533474

      See original post. KB5005463 is awol since installing 22H2, and not in Stgs>apps. No longer in wushowide.

      • #2533530

        Did you find “Windows PC Health Check”? If so, it would not show in wushowhide because it is already installed.
        If it was installed and has done its work then WU may not show it as a required update.

        cheers, Paul

        1 user thanked author for this post.
    • #2533693

      @PaulT Thx but I have replied ad nauseam that there is NO ’Windows PC Health Check’ nor that KB listed anywhere. I’m not completely computer illiterate, and as stated Stgs App is the first place I checked, and many other areas. (kb5012170 & kb4023057 remain hidden via winshowhide).

      Does anyone else have any ideas?

    • #2533698

      KB5005463—PC Health Check Application – Microsoft Support does not say it applies to 22h2. It could be it is integrated into the 22H2 update. As such, it would not be offered.


      1 user thanked author for this post.
    • #2533816

      Ty, will see what shows up when running winshowhide on Patch Tues. I’ll post back results. (Searched AW site Aug 2022-present day: anything to do with updating to 22H2, noone mentioned this issue.) Perhaps the enablement pkg had recently changed.

      Off to figure out User UAC/ regedit/gpedit issue since upgrading to 22H2…
    Viewing 15 reply threads
    Reply To: Win 10 22H2 upgrade woes-gpedit User; KB 5005463

    You can use BBCodes to format your content.
    Your account can't use all available BBCodes, they will be stripped before saving.

    Your information: