News, tips, advice, support for Windows, Office, PCs & more
Home icon Home icon Home icon Email icon RSS icon

We're community supported and proud of it!

  • Win10 Update causes lost Internet

    Home » Forums » AskWoody support » Windows » Windows 10 » Questions: Win10 » Win10 Update causes lost Internet

    • This topic has 10 replies, 5 voices, and was last updated 1 week ago.
    Author
    Topic
    #2402411

    I usually follow Susan Bradley’s DEFCON settings but this time I missed one computer that updated on the 17th November, which has resulted in a loss of Internet connectivity.

    It is a Lenovo Desktop model 30A1A005AU (x64) i7-4770 CPU @3.4GHz running Windows 10 (10.0.19042 build 19042).

    While the SHARKBAY v0B98401 PRO baseboard has an Ethernet port, I have had to use an Unitek Y-3461 USB3.0 Gigabit Ethernet Adapter dongle to connect to the Internet since I acquired the machine.  From the System info, I have deduced that the onboard Ethernet is Ethernet-3 and the dongle is Ethernet-4. There is no Wi-Fi option for this desktop.

    The windows update appears to be the Win10 20H2.

    I have gone through the usual routine:
    1) restarted the comp with the dongle connected to the ethernet cable – engaged as it has been for the last 5 years
    2) restarted the comp connected to the onboard Ethernet port (Eth-3)
    3) disabled/enabled the network adaptors for both Eth-3 and Eth-4
    4) uninstalled the Win10 20H2 update.
    5) restarted the comp with each change in parameters

    However, I seem to be going around in circles.

    My Router IP address is 192.168.0.1. However, the IP address for the dongle (Eth-4) is 169.254.168.184 under IP4.
    When I change the IP address for Eth-4 to 192.168.0.54 (as an example to connect it to the Router) I get a message that tells me “Multiple default gateways are intended to provide redundancy to a single network (such as an intranet or the internet). They will not function properly when the gateways are on two separate disjoint networks (such as the one on your intranet and one on the internet). Do I want to save this configuration?”

    Sadly, I can not confirm connectivity using my laptop as it is connected by WiFi using a Google Network Extender. The IPv4 Address for my laptop is 192.168.86.71.

    Both the Ethernet cable for the Desktop and the Google Network Extender are connected to the Router using a Netgear GS116 16port Gigabit Switch.

    The ONLY component that has changed in the Desktop setup is the Windows Update.

    I would appreciate any help on how to resolve this puzzling issue!

    Thank you!

    Megan in Sydney, Australia

     

     

    Viewing 6 reply threads
    Author
    Replies
    • #2402493

      If you’ve uninstalled the update, the problem may not be with the patch but rather the reboot triggered something else.  Mere reboots can trigger catastrophic failures.

      What’s the full IP address you are entering (192.168.86.71 then a 255.255.255.0 for the subnet – now what’s the Gateway IP address you are putting in there.  As if the router is 192.168.0.1 your static IP should be 192.168.0. – and then any number from 2 to 254 that isn’t already taken by a device in your network.  What device hands out dHCP – and can you try it letting the computer pick up the IP rather than putting in a static one?

      The dongle address of  169.254.168.184 tells me it’s not getting Internet to then pick up an IP address.  169.x.x.x = I can’t get an IP address so I’m assigning a non routable IP address.

      Susan Bradley Patch Lady

    • #2402533

       

      Hi Susan – thank you for all your hard work and thank you for responding to my problem!

      I have to say that I’ve had to do some research on the internet (using my laptop!!!) to figure out what a dHCP is!

      As I previously stated, my Router IP address is 192.168.0.1 == I got that from entering that IP into a browser window and my router connection appeared.

      The diagnostic panel that appears under Advanced shows:
      . Broadband – Ethernet connected
      . Internet access – WAN Sensing L3: L3DHCP; DHCP on WAN IP is 1.158.61.210
      . Local Network – DHCP enabled – Gateway IP is 192.168.0.1 and netmask is 255.255.255.0
      . Devices – 1 ethernet device connected; 0 Wi-Fi devices connected [I am assuming that this is because I am using the Google Network Extender to connect my laptop via WiFi]

      The current settings (using ipconfig) for the motherboard ethernet port (Eth-3) are:
      Windows IP Configuration

      Ethernet adapter Ethernet 4:
      Media State . . . . . . . . . . . : Media disconnected
      Connection-specific DNS Suffix . :

      Ethernet adapter Ethernet 2:
      Media State . . . . . . . . . . . : Media disconnected
      Connection-specific DNS Suffix . :

      Ethernet adapter Ethernet 3:
      Connection-specific DNS Suffix . :
      Autoconfiguration IPv4 Address. . : 169.254.168.184
      Subnet Mask . . . . . . . . . . . : 255.255.0.0
      Default Gateway . . . . . . . . . :

      Ethernet adapter Ethernet:
      Media State . . . . . . . . . . . : Media disconnected
      Connection-specific DNS Suffix . :

      Ethernet adapter vEthernet (Default Switch):
      Connection-specific DNS Suffix . :
      Link-local IPv6 Address . . . . . : fe80::ccf2:ffcc:2ac6:7420%28
      IPv4 Address. . . . . . . . . . . : 172.17.192.1
      Subnet Mask . . . . . . . . . . . : 255.255.240.0
      Default Gateway . . . . . . . . . :

      As I have NEVER been able to use the Motherboard Ethernet Port (Eth-3) I am of the opinion it is because I have been unable to edit/change the “Autoconfiguration IPv4 Address. . : 169.254.168.184” to an IPv4 address using 192.168.0.____ as a base.

      And the ipconfig settings for the Dongle (Eth-4) are:

      Windows IP Configuration

      Ethernet adapter Ethernet 3:
      Media State . . . . . . . . . . . : Media disconnected
      Connection-specific DNS Suffix . :

      Ethernet adapter Ethernet 2:
      Media State . . . . . . . . . . . : Media disconnected
      Connection-specific DNS Suffix . :

      Ethernet adapter Ethernet 4:
      Connection-specific DNS Suffix . :
      IPv4 Address. . . . . . . . . . . : 192.168.0.11
      Subnet Mask . . . . . . . . . . . : 255.255.0.0
      Default Gateway . . . . . . . . . : 192.168.0.1

      Ethernet adapter Ethernet:
      Media State . . . . . . . . . . . : Media disconnected
      Connection-specific DNS Suffix . :

      Ethernet adapter vEthernet (Default Switch):
      Connection-specific DNS Suffix . :
      Link-local IPv6 Address . . . . . : fe80::ccf2:ffcc:2ac6:7420%28
      IPv4 Address. . . . . . . . . . . : 172.17.192.1
      Subnet Mask . . . . . . . . . . . : 255.255.240.0
      Default Gateway . . . . . . . . . :

      The Dongle (Eth-4) shows the Default Gateway that matches my Router (192.168.0.1) but there is no internet connection.

      In my testing yesterday, when I tried to change the IP addresses on the Desktop, I used the following:
      192.168.0.54 as the new IPv4 address
      255.255.255.255 as the new Subnet Mask
      192.168.0.1 as the Default Gateway
      ….but none of the values were saved at the time of the change (I entered the values, but when I went back to check, the settings had reverted to the originals).

      I’m not sure how to remove the static IP addresses – do I just delete them and reboot the computer?

      Thank you for your assistance!

      Megan in Sydney, Australia

    • #2402583

      Probably already tried, but I would turn off the router and desktop, then turn back on the router wait 1 or 2 minutes.  Then turn on desktop.  Does the dongle have lights to show connectivity?

    • #2402637

      Hopefully you still have the device drivers disk that came with your computer and/or a good backup.

      About 3 weeks ago, I did a Windows 10 update on my desktop (21H1) and everything worked except my add-in Sound Blaster card.  I tried rolling back the update,  but the update had ‘magically’ wiped out the ability to do so!  All of the manually created, weekly ‘restore points’ had disappeared during that update!  Thank you, Microsoft for making my life miserable!

      So, I tried the most recent drivers for the Sound Blaster that I had manually downloaded not long after I installed it on top of the original versions but that ran, but didn’t restore the sound, even after a power down/up.  Fall back to the original CD that came with the Sound Blaster.  STILL NOTHING!

      Fortunately, I make a full clone of my C: drive (256GB SSD) every Sunday night.  I built my computer with all slide-bays for all drives, so it was easy to move the former C: to the drive 1 bay so I could copy updated documents, and put the clone in the drive 0 bay.  Booted up and miracle of miracles, the Sound Blaster works fine!

      I have had the updates ‘locked down’ since then!

      • #2403172

        Sorry for the delay in response, but I had to find the CDs that came with the machine.

        The CDs are for Windows version 8, and the two sets of 2 CDs are :

        • Windows 8 Recovery Media for Windows 8 Products
        • Operating System Recovery Disk Windows 8 Pro

        Both sets of CDs are dated August 2013.

         

        From what I can tell when I examine my system, the earliest file date is 2019.

         

        And, the second issue, besides the CDs that came with the machine, is how to identify which driver files to actually update.

    • #2403261

      It’s not clear what exact model of Lenovo desktop this is. I couldn’t find any results for “model 30A1A005AU”.

      However, as far as I can tell from Googling, Lenovo i7-4770 (3.4GHz) desktops in 2013 used integrated Realtek ethernet adapters.

      I’m surprised that the installation of Windows 10 x64 didn’t detect the integrated ethernet adapter as Realtek. It’s therefore likely that Device Manager shows an Unknown device under Other devices.

      Try this: *Right*-click on Start and select Device Manager from the list.

      Do you see something like this?

      unknown_device

      The Windows 10 x64 driver for this particular ethernet adapter is available here:

      https://support.lenovo.com/gb/en/downloads/ds104312-realtek-ethernet-lan-driver-for-windows-10-64-bit-desktop

      This covers models like the M83 and M93/M93P which shipped with that processor configuration. Whilst the URL is for Lenovo support in the UK, I know of no reason why this driver cannot be used for US models as well.

      Hope this helps…

    • #2403523

      Hi Rick,

      It is a Lenovo ThinkStation E32 – 30A1A005AU – MT-M 30A1 – A005AU Desktop, and it might be an Australian “special release” which may be why it is different to the Lenovo site.

      The Device Manager listing only shows the ASIX AX88179 USB 3.0 Gigabit Ethernet Adapter for the dongle – as I have said, the motherboard Ethernet has not worked since day-1, so that would explain the absence of a Realtek driver.

      The only Realtek driver in the Device Manager listing is for the card reader (SD and memory card readers/slots).

      2021-11-26-Device-Manager-Network-Adapters

      This is what I see.

      Megan in Sydney, Australia

      • #2403548

        You are correct, in that your PC is, indeed, made for Australia. Since Rick couldn’t find much about it on Lenovo’s site for the UK, and I couldn’t find a thing about it on the U.S. part of the Lenovo site, I modified the URL a bit for Australia (pcsupport.lenovo.com/au/en…) and got results. The link below is for the drivers and software download page for your computer. Once you’re there, feel free to input your machine’s exact serial number in the box that says “Enter Serial Number” under the image of your machine, OR feel free to click on the links for the item you’re looking for a driver for, and you’ll be shown a list of applicable drivers or software for that item.

        https://pcsupport.lenovo.com/au/en/products/workstations/thinkstation-e-series-workstations/thinkstation-e32/downloads/driver-list/

        Because there are many drivers for the 64 bit version of Windows 10 (x64) but fewer drivers for the 32 bit version of Windows 10, please make absolutely sure that your machine has a 64 bit version of Windows 10 and not a 32 bit (x86) version. This can also make a big difference in the drivers either working or not working as well.

        When you first go to the page, it will default to showing you only 32 bit drivers. If you do indeed have a 64 bit version of Windows, then you’ll need to click on the blue link labeled “Select Additional OS ˅” (that last character is a blue-colored “down arrow”) and then select “Windows”>”Windows 10 (64-bit)” from the resulting list with check boxes.

        Per your screenshot above from Device Manager, you have an Intel brand Ethernet adapter in your system, not a Realtek brand Ethernet adapter. Getting the correct driver for your Intel I217-LM Ethernet port will very likely enable you to use it without having to resort to using the USB to Ethernet dongle, which may uncomplicate things for you.

        I hope this helps a bit.

        • #2404211

          Thank you, Bob991

          Ok, I used the link Bob99 provided to the ThinkStation Drivers and entered my ThinkStation E32 Serial number and a message popped saying to hit the button to automatically scan the Driver files for installation.

          I backed out of that situation and selected the Network Adapters option and chose the Intel update == Intel Ethernet Connection I217-LM Driver.
          It installed correctly as the Device Manager shows the Intel Driver working correctly. I restarted the computer.

          I then opened CMD with Administrator privileges and then did the following at the prompt:

          1) netsh winsock reset ====> Success
          2) netsh int ip reset ====> Failed – access denied
          3) restarted the computer
          4) netsh int ip reset ====> Failed – access denied
          5) ipconfig /flushdns ====> Success – as far as I can tell, but based on the netsh int ip reset failure… the flush probably didn’t succeed
          6) restarted the computer
          7) stopped for this message….

          I need to understand how to get the netsh int ip reset to succeed.

          Attached is the txt file for the netsh int ip reset (2021-12-01 – netsh int ip reset — failed #1.txt)

          • This reply was modified 1 week ago by Megastar_Magus. Reason: spelling
    • #2404219

      Update – I now see that the “Failed” message is a sort-of default message and there really was no apparent failure.

      I went back through the process again:

      I opened CMD with Administrator privileges and then did the following at the prompt:

      1) netsh winsock reset ====> Success
      2) netsh int ip reset ====> Failed – access denied
      3) restarted the computer
      4) netsh int ip reset ====> Failed – access denied
      5) ipconfig /flushdns ====> Success – as far as I can tell,
      6) restarted the computer
      7) used Network Connections – Properties – to change the IPv4 IP allocations to obtain an IP address (and DNS Servier address) automatically – the fields were all blank
      8) uninstalled the Driver previously installed then used the Hardware Changes Scan to either find the Driver or indicate to me that I would have to reinstall the Driver. The Hardware Changes scan reinstituted the driver
      9) restarted the computer
      10) there was still no internet connection though the Network Adaptor now shows that I have a connection – the message is now showing UNKNOWN NETWORK.
      11) ran CMD with Administrator privileges and then ipconfig /release
      12) ipconfig /renew
      13) ipconfig /flushdns
      14) restarted the computer
      15) reinstalled the driver
      16) restarted my broadband, modem and router
      17) ran CMD with Administrator privileges and then ipconfig /all

      As the Ethernet Cable is plugged into the Motherboard Ethernet Port, the following showed under ipconfig/all:

      Ethernet adapter Ethernet 3:

      Connection-specific DNS Suffix . :
      Description . . . . . . . . . . . : Intel(R) Ethernet Connection I217-LM
      Physical Address. . . . . . . . . : 44-39-C4-4F-0B-76
      DHCP Enabled. . . . . . . . . . . : Yes
      Autoconfiguration Enabled . . . . : Yes
      Link-local IPv6 Address . . . . . : fe80::f4a8:8101:c6fe:a474%7(Preferred)
      Autoconfiguration IPv4 Address. . : 169.254.164.116(Preferred)
      Subnet Mask . . . . . . . . . . . : 255.255.0.0
      Default Gateway . . . . . . . . . :
      DHCPv6 IAID . . . . . . . . . . . : 38025668
      DHCPv6 Client DUID. . . . . . . . : 00-01-00-01-1B-11-01-37-44-39-C4-4F-0B-76
      DNS Servers . . . . . . . . . . . : fec0:0:0:ffff::1%1
      fec0:0:0:ffff::2%1
      fec0:0:0:ffff::3%1
      NetBIOS over Tcpip. . . . . . . . : Enabled

      18) as can be seen above – the IPv4 address is 169.254.164.116

      However the Broadband address (my internet provider) using the IP address 192.168.0.1 to interrogate the connection via a browser shows as:

      WAN IP: 1.158.85.277
      Connection Type: Ethernet

      Router IP: 192.168.0.1
      Hostname: mymodem
      FW Version: 20.3.c.0329

      LAN IP: 192.168.0.186
      Device name: Unknown-88:3d:24:cc:0e::86
      Linkspeed: 1000Mbps

      19) I then used the Network Connections to try and change the Automatic detection of IP addresses to a static address (192.168.0.54) and change the DNS Server to 8.8.8.8/8.8.4.4 (Google DNS). The DNS change took but I have an error on the IPv4 address that I input.

      20) As the ThinkDesk connects to the internet through a Netgear 16-port switch (IP 192.168.0.239), I’m pretty sure that this is not a problem…

      Megan in Sydney, Australia

    Viewing 6 reply threads
    Reply To: Win10 Update causes lost Internet

    You can use BBCodes to format your content.
    Your account can't use Advanced BBCodes, they will be stripped before saving.