News, tips, advice, support for Windows, Office, PCs & more
Home icon Home icon

We're community supported and proud of it!

  • Win7 ESU Year 3 Update Problem

    Home » Forums » AskWoody support » Windows » Windows 7 » Win7 beyond End-of-life » Win7 ESU Year 3 Update Problem

    Author
    Topic
    #2418168

    Hi Guys. I am running Win 7 Pro x64 ESU (Year 3).

    Why still with Win7?
    Well, that involves my attempts to rescue and resuscitate data from a very old “home-built” accounting software package. There is a mountain of valuable data on floppies – which concern existing entities. Concurrent internet access is required to consult with others and to transfer data. I am just over 90% done and am now dealing with some of the most difficult bits. Hope to finish in a few months.

    I am having trouble with only one of the updates offered.

    All steps necessary to activate the Y3 “licence” have been completed.
    1. Y3 ESU Product Key installed.
    2. Y3 ESU Activation ID found.
    3. Y3 Product Key activated.

    See attached Shot: “Win7 ESU Y3 Product Key”.

    On 12 January I discovered 4 updates were available to download, these being the first major updates for 2022:

    1. 2022-01 Security & Quality Rollup for .NET Framework 4.8 (KB5009719)
    2. Security Intelligence Update for MS Security Essentialls (KB2310138)
    3. Windows Malicious Software Removal Tool x64-v5.97 (KB890830)
    4. 2022-01 Security Monthly Quality Rollup for Win7 x64 (KB5009610)

    The first 3 installed OK but not No.4: KB5009610. Same error code each time.
    Error Code: : “WindowsUpdate_80073701” “WindowsUpdate_dt000”
    A search of the error code produces no tangible results.

    I have now attempted 3 times to install KB5009610 but without success.

    Suggestions most welcome.

    Viewing 19 reply threads
    Author
    Replies
    • #2418188

      Maybe you could try Security-Only: KB5009621

      • #2418228

        That is a pretty good idea. If the security only update installs successfully, then the .NET update can separately be installed.

      • #2418328

        Thank you for replying.  Forgive my ignorance please, but I’m not sure what you mean by “Security Only……”.

      • #2418333

        Have you only tried it from Windows Update?

        Thank you also for your reply.  The answer to your question is: Yes.

        Following your suggestions, I turned off Windows Update and proceeded to download the relevant file but I have not been able to install it. Each time I attempt to open/install it, I get a pop-up that says (in effect) Windows can’t open the file and to choose a program.

        The downloaded file name is: “Unconfirmed 503993.crdownload (378,881KB)”  The file type is “CRDOWNLOAD”

        How does one go about installing this file?

        New edit 1:  I have just discovered that this type of file involves Google Chrome. A well-meaning neighbour suggested that I use MS Edge to download the relevant file as MS might not play well with Firefox. I took that advice and the “Crdownload” file was the result.

        I shall now download the file from MS using Firefox and hopefully get a stand-alone file to install.  I will report back  with the result.

        New edit 2:  The download was successful but the installation was not. See attached screenshots: “Win7 Update Catalog #2”;
        “Win7 Standalone Update Failure #1”, and #2

        To my untrained eye, this is starting to look like a real problem.

        • This reply was modified 1 week, 6 days ago by buttonupboots. Reason: New information acquired
        • #2418362

          The update is an installable .msu file.

          To download right-click on the .msu link and select ‘save link as’
          If you are download with Chrome you will get a warning. Select ‘keep’

    • #2418214

      You reminded me I need to purchase 1 ESU.  I’ll do that and report if mine is a happy camper.

      Susan Bradley Patch Lady

    • #2418229

      Check the C:\Windows\winsxs\Temp\PendingRenames folder. If the PendingRenames folder isn’t empty, then you have issues of either a recently failed update or past failed updates. If the PendingRenames folder isn’t empty, how many files are in that folder?

      • #2418326

        Thank you ( and to others) for taking the time to reply.

        I apologize for the delay in responding, there was a fault with my ISP/RSP.

        I have checked the Folder you mention and it is empty.

        See attached screenshot:  “Pending Renames Folder”

        I am steadily working thru the other recommendations and will report back shortly.

    • #2418220

      Have you only tried it from Windows Update?

      If so, maybe you could try downloading the update from here:
      https://www.catalog.update.microsoft.com/Search.aspx?q=KB5009610

      Then try to install it manually.

      Before you do, though, go into Services and make sure Windows Update is turned off. Otherwise, you’ll be “Searching for Updates on this Computer” for a long time.

      1 user thanked author for this post.
    • #2418366

      The update is an installable .msu file.

      Thank you. I discovered the .msu file early in the process. See the attached screenshots.  At that point I chose to “Open With” which automatically started the install process – which failed.

      At the second attempt I chose to save the file as a “Microsoft Update file” [.msu], the manual installation of which also failed.

      Have I understood you correctly Alex5723 ?

       

       

      • This reply was modified 1 week, 6 days ago by buttonupboots. Reason: Omitted screenshots
      • #2418373

        You download the .msu file to your desktop and double click and install the file.

    • #2418381

      You download the .msu file to your desktop and double click and install the file.

      Thank you again.  I  downloaded the .msu file to the desktop and then double clicked.

      Unfortunately I get the same result each time that I attempt to deal with the .msu file –  the installation gets only so far and then fails.

    • #2418385

      0x80073701 = ERROR_SXS_ASSEMBLY_MISSING
      meaning the components store (WinSxS) is corrupted or missing some files

      – Follow this guide (except step 4) to generate fresh CBS.log
      https://community.spiceworks.com/how_to/173479-resolve-0x80073701-error_sxs_assembly_missing

      – If you cannot find the details, zip and upload the log, this may help determine the faulty files
      http://put.nu/

      – Or, go ahead abd try the SUR tool (it will take long time to finish)
      https://www.catalog.update.microsoft.com/Search.aspx?q=947821

    • #2418390

      If you can, zip and upload the files in C:\Windows\Logs\CBS

      Thank you for your assistance.  I have tried to zip the files shown in the attached screenshot but could not. Part of the WinZip log file reads:

      <<You are trying to create a new Zip file on a disk that is read-only: “C:\Windows\Logs\CBS\CBS.zip”.
      Irrecoverable Error: The archive file cannot be opened for output.>>

      I shall try your other suggestions tomorrow.  It is almost 11.50pm local time and I have to be up very early the morning.

      BTW, it only just occurred to me, when you say:

      <<Or, go ahead abd try the SUR tool (it will take long time to finish)>>

      Forgive my ignorance, but what am I meant to do once at this site ?

      • #2418401

        Copy the files to another location (e.g desktop) then zip
        CBS.log alone could be enough

    • #2418488

      Copy the files to another location (e.g desktop) then zip

      Thank you once again. There are some odd things happening. Last night when attempting to zip (at least) the CBS.log, I was denied access when I tried to copy this file to the desktop.     I then logged-in as Admin but was still denied access.

      Also something else, in my previous screenshot, the CBS.log is close to 170Mb but when I logged-in this morning there has been a substantial change. See screenshot.

      I am now able to copy that file. Do you want me to upload the file to http://put.nu/  ?

      • #2418509

        You could rename the copy of the cbs.log to cbs.txt and then attach it to your next post.

    • #2418527

      You could rename the copy of the cbs.log to cbs.txt and then attach it to your next post.

      Thank you again for your help.

      I have done as you suggested and attached the current .log file as a .txt file to this post.

      As I mentioned in my last reply to abbodi86 (#2418488), there is a major, major difference in the sizes of the log files from last night and today – with the result that the current CBS.log is way, way smaller – from nearly 170Mb to 4Kb and, the larger one has vanished.

      Consequently I simply don’t know if the current log file contains any relevant information to the problem, or indeed contains sufficient information.

      Acting on the assumption this might be so, and given that the large log file that was present last night now seems to have completely disappeared, would it help if I was to re-start the Win Update Service, download and attempt to install the troublesome Update in the “normal” way ?

      If the process failed again, as I’m guessing it will, would the CBS.log then contain any further, or relevant information – assuming of course that I can access it – which has been a no-no in the recent past. On that point, see also #2418488.

    • #2418534

      Download KB5005633 Rollup

      After downloading both files and placing them in an empty folder, I right-clicked on the BAT file (as Admin). The Command Prompt opened at <C:\Windows\Sytem32\cmd.exe> and I was asked to “Press any key to continue….” which I did, whereupon the Command Prompt immediately disappeared. I waited for about half an hour and then checked the installed updates.

      Again forgive my ignorance please (all this is very new and strange), but if the object was to install KB5005633 x64, that has not happened. See screenshot: “Installed Updates #1”

      If during this process I have managed to screwup then I heartily apologize.

      For what it’s worth, I also attach a copy of the current CBS.log as a .txt file.

    • #2418550

      …………here’s fixed script

      Thank you once again.  The “operation” was successful.

      Even tho’ I feel that I have taken up too much of your time, what’s the next step?

      Apologies, I forgot to attach a shot of the Cmnd Prompt.

    • #2418658

      You can copy the mentioned CAB file to another folder, then rename its CAB extension to ZIP, and then you can upload it.

      Thank you once again.  I changed the file type and attempted to upload to this post.

      There was an immediate problem:

      Name: CbsPersist_20220115125401.zip

      Size: 9019 kb, Extension: ZIP

      Error! The file is too big.

      • #2418717

        I created a Dropbox folder so that you can upload the ZIP file. I will send you a private message with the link.

        • #2418736

          We do not recommend using private messages. If it can’t be said in public…



          @buttonupboots
          , it may be easiest to zip the file (right click in Explorer, Send to, Compressed (zipped) folder. Check that the file is small (200k ish), then upload.
          If you can’t get it down to size we may need to try other things.

          cheers, Paul

    • #2418739

      We do not recommend using private messages. If it can’t be said in public…

      Thank you Paul T for your interest.  I appreciate your concern.

      The file in question (already zipped) was over 9MB and it seemed that Dropbox offered a ready-made solution – one which has now been adopted.

       

       

    • #2421313

      Hi buttonupboots,

      You mentioned in DM that your partner had inadvertently selected the Year 2 ESU key while trying to activate the Year 3 ESU. That might have caused some issues even though you ran the Year 3 ESU activation again wth the correct Year 3 key. I looked at the CbsPersist_20220115125401.log in the ZIP file you uploaded to Dropbox. Below is what I found, and further below is my suggested solution. I suggest that you wait for the AskWoody experts to chime in, before you try my suggested solution.

      It appears that System Restore is disabled on your computer. This was noticed before TrustedInstaller started to install KB5009610:

      2022-01-15 22:35:28, Info CBS Opened cabinet package, package directory: C:\Windows\SoftwareDistribution\Download\c48f85c3947e1fda0a096779dcabcd36\, sandbox location: \\?\C:\Windows\SoftwareDistribution\Download\c48f85c3947e1fda0a096779dcabcd36\inst\, cabinet location: \\?\C:\Windows\SoftwareDistribution\Download\c48f85c3947e1fda0a096779dcabcd36\Windows6.1-KB5009610-x64.cab, manifest location: \\?\C:\Windows\SoftwareDistribution\Download\c48f85c3947e1fda0a096779dcabcd36\inst\update.mum
      2022-01-15 22:35:32, Info CBS Disabling LKG boot option
      2022-01-15 22:35:32, Info CBS Perf: Begin: nested restore point – begin
      2022-01-15 22:35:32, Info CBS Failed setting restore point [HRESULT = 0x80070422 – ERROR_SERVICE_DISABLED]

      While trying to install KB5009610, TrustedInstaller found missing files related to the installation of KB5007236. KB5007236 is the November 2021 Monthly Rollup. Below you will see instances of 0x80073701 which is the error code you saw after KB5009610 failed to install:

      2022-01-15 22:40:01, Error CSI 0000000e (F) HRESULT_FROM_WIN32(ERROR_SXS_ASSEMBLY_MISSING) #491220# from Windows::ServicingAPI::CCSITransaction::ICSITransaction_PinDeployment(Flags = 0, a = 2088bcf074ca819493ba8553200cb4c2, Version = 6.1.7601.25767, pA = PROCESSOR_ARCHITECTURE_AMD64 (9), Culture neutral, VersionScope = 1 nonSxS, PublicKeyToken = {l:8 b:31bf3856ad364e35}, Type neutral, TypeName neutral, PublicKey neutral, cb = (null), s = (null), rid = [83]”Package_668_for_KB5007236~31bf3856ad364e35~amd64~~6.1.1.13.5007236-2531_neutral_LDR”, rah = [2]”16″, manpath = (null), catpath = (null), ed = 0, disp = 0)[gle=0x80073701]

      2022-01-15 22:40:01, Info CBS Failed to pin deployment while resolving Update: 5007236-2531_neutral_LDR from file: (null) [HRESULT = 0x80073701 – ERROR_SXS_ASSEMBLY_MISSING]

      2022-01-15 22:40:01, Info CBS Failed to resolve execution update. [HRESULT = 0x80073701 – ERROR_SXS_ASSEMBLY_MISSING]

      2022-01-15 22:40:01, Error CBS Failed to resolve execution package: Package_668_for_KB5007236~31bf3856ad364e35~amd64~~6.1.1.13 [HRESULT = 0x80073701 – ERROR_SXS_ASSEMBLY_MISSING]

      2022-01-15 22:40:01, Info CBS Failed to resolve execution chain. [HRESULT = 0x80073701 – ERROR_SXS_ASSEMBLY_MISSING]

      2022-01-15 22:40:01, Error CBS Failed to process single phase execution. [HRESULT = 0x80073701 – ERROR_SXS_ASSEMBLY_MISSING]

      2022-01-15 22:40:01, Info CBS WER: Generating failure report for package: Package_for_RollupFix~31bf3856ad364e35~amd64~~7601.25829.1.10, status: 0x80073701, failure source: Resolve, start state: Resolved, target state: Installed, client id: WindowsUpdateAgent

      2022-01-15 22:40:01, Info CBS SQM: Reporting package change completion for package: Package_for_RollupFix~31bf3856ad364e35~amd64~~7601.25829.1.10, current: Resolved, original: Resolved, target: Installed, status: 0x80073701, failure source: Resolve, failure details: “(null)”, client id: WindowsUpdateAgent, initiated offline: False, execution sequence: 2178, first merged sequence: 2178

      2022-01-15 22:40:02, Info CBS Exec: Processing complete. Session: 30935555_4220188540, Package: Package_for_RollupFix~31bf3856ad364e35~amd64~~7601.25829.1.10 [HRESULT = 0x80073701 – ERROR_SXS_ASSEMBLY_MISSING]

      My suggested solution:

      1. If System Restore is disabled, please enable it.

      2. Download the correct version of KB5007236 and reinstall it.

      3. Download KB5009610 (I think that you already have downloaded it) and install it.

      Best regards,

      –GTP

      1 user thanked author for this post.
    • #2421438

      2. Download the correct version of KB5007236 and reinstall it.

      Many thanks for your efforts; it is greatly appreciated.

      I have re-enabled System Restore, but before I proceed further I have a question:

      Your reference to “the correct version” and “reinstall” has me a bit confused (as usual).

      I have looked thru Installed Updates for KB5007236 and it is not installed.

      SO, from the list shown on the attached screenshot, which one do I choose?

      I am guessing that the same goes for the troublesome KB5009610, again which one?

    • #2421447

      Hi buttonupboots,

      You pick the update version depending on whether you have Windows 7 64-bit or Windows 7 32-bit. I am pretty sure that you are running Windows 7 64-bit. Go to Control Panel and then click on System. The popup window will tell you if you have Windows 7 32-bit or Windows 7 64-bit.

      I don’t know if your ESU license key issue caused a problem with KB5007236. I think it did since TrustedInstaller clearly indicated that seven parts of KB5007236 were missing (amongst the several hundred parts of that update). This could potentially have been caused by various issues. In any event, download what you think is the correct version of KB5007236. If your Windows 7 is 64-bit (I am pretty sure it is) and if you tried to install the KB5007236 version for 32-bit Windows 7, Windows will report that the update is not applicable to your computer. Then obviously you need to download the 64-bit version. Your computer is basic Windows 7. Your computer is not a Server, and it is not Embedded Windows 7. It is just Windows 7. So in your screen captures, that narrows it down to the 32-bit or 64-bit versions of the updates for plain old Windows 7.

      KB5007236 is listed as not installed since something either went wrong during its installation, or something happened to seven of its files after it was installed. Do you recall if you installed the Monthly Rollup for November 2021? If you do, then you did install KB5007236 yet something else occurred which messed up a few of its files or the manifests for those files. It doesn’t matter what caused the issue since the simple fix is to re-install KB5007236.

      If the above doesn’t work, then we need to seriously look at other issues, including a potentially failing hard drive.

      Best regards,

      –GTP

       

      • #2421448

        OK. Thanks once again.  I shall now download the appropriate file for KB5007236 and let you know what happens.

    • #2421453

      I shall now download the appropriate file for KB5007236 and let you know what happens.

      Well, I did that but found a “strange” error message. Below is a screenshot of the actual file that was downloaded, plus the result of trying to install it.

    • #2421460

      Alrighty. So now the situation appears to be that Windows “thinks” that KB5007236 is fully installed on your computer. Now we need people here who are more expert than me to assist. I have a couple of other ideas, yet I think it would be best for the forum’s more expert people to chime in. You might want to post your Dropbox link for the ZIP file of the CBS log.

    • #2421464

      You might want to post your Dropbox link for the ZIP file of the CBS log.

      OK thanks.  Dropbox link below:

      https://www.dropbox.com/s/0gltixllfmqo2b8/CbsPersist_20220115125401.zip?dl=0

    Viewing 19 reply threads
    Reply To: Win7 ESU Year 3 Update Problem

    You can use BBCodes to format your content.
    Your account can't use all available BBCodes, they will be stripped before saving.