News, tips, advice, support for Windows, Office, PCs & more. Tech help. No bull. We're community supported by donations from our Plus Members, and proud of it
Home icon Home icon Home icon Email icon RSS icon
  • Windows 10 blind to NAS box

    Posted on rogertrigg Comment on the AskWoody Lounge

    This topic contains 17 replies, has 7 voices, and was last updated by  PaulK 2 weeks, 4 days ago.

    • Author
      Posts
    • #1961801 Reply

      rogertrigg
      AskWoody Plus

      I have a home network of 2 PCs and a WD NAS box (WDMyCloudMirror) installed 2 years ago with both PCs running Win 8.1 Pro. Both PCs could see the box in File Manager and all was well. Both PCs were upgraded to Win 10 about 18 months ago and could still see the WD box. One PC was replaced and came with a brand-spanking new fresh Win 10 Pro setup. This PC cannot see the WD box while the other PC can. Also, the blind PC cannot find the router hub when I key ‘192.168.1.254’. Instead I get sent to a screenful of web search results while the other PC finds the hub as it should. These aberrations have to be related. What is there about a clean Win 10 installation that blocks what should happen?
      I’ve lived with this problem for months, tried all the tips found by Google from others who have had a similar troubleand found none of the suggestions successful.

    • #1961831 Reply

      PKCano
      Da Boss

      I’ve lived with this problem for months, tried all the tips found by Google from others who have had a similar troubleand found none of the suggestions successful.

      It would be good to start by telling us the things you have tried that weren’t successful, so we don’t waste time repeating them.

      Also, it would be good to know what your settings are in:
      Network and Sharing Center, advanced sharing settings.
      Control Panel\System\Advanced system settings on the Computer name tab.
      Is SMB1 turned on on this computer and/or the other one? See #1947500.
      Some other settings you might want to look at are here.

      Your information will be helpful in troubleshooting.

    • #1962694 Reply

      rogertrigg
      AskWoody Plus

      I’ve implemented all the recommedations given in # 1947500 and #1948537 without success. SMB1 is off on the PC that can see the WD box. Turning it on and off on the errant PC makes no difference. A correction is required to my opening message: the other PC is running Win 10 Home, not Pro.

      WD supply an app, WD My Cloud, which can see the box but cannot connect it. It might be better to focus on why my PC cannot access the router hub. Solve that and the main problem might also get solved.

      • #1962701 Reply

        PKCano
        Da Boss

        Well, I suspect if you can’t see the router, you won’t be able to see a box connected to it. That surely might solve the mystery! 🙂

      • #1962753 Reply

        PaulK
        AskWoody Lounger

        What browser(s) is/are you using, on both computers?

        Are the network adapter settings the same on both computers?

        HTTP vs HTTPS ? I have an old gateway that I configured as an access point: no ‘S’ access.
        What router have you?

        A Google Search for [ browser cannot see router on network ] may help. One hit has more suggestions.

    • #1964331 Reply

      rogertrigg
      AskWoody Plus

      Both PCs use Firefox and Edge as browsers and both browsers produce the same negative result on the errant Win 10 Pro PC (1809 build). The Win 10 Home PC works perfectly well so I conclude the router is fine. It’s a BT Home Hub 5 router. The network settings appear to be the same on the two PCs. Using HTTP and HTTPS to find the router hub gives the same negative result. Also, File Manager cannot see my printer yet finds an external hard drive used for backups. Could File Manager be corrupted? I did read recently that some experts feel Microsoft screwed up home networking in a recent Win 10 build and there’s plenty of Google evidence to support the thought.

    • #1964539 Reply

      mn–
      AskWoody Lounger

      I once had a troubleshoot a weird case like this on a Windows server…

      In that cast it turned out that something had added persistent static ARP entries in the system. Incorrect ones too.

      Remove those with command “arp -d <IP>”.

      Very few people actually need the added security and the added maintenance work to use a proper static ARP table…

      Still don’t know what generated those entries.

    • #1965111 Reply

      rogertrigg
      AskWoody Plus

      Can you expand on the <IP> part of the command? Do I insert the IP address I’m seeking? Sorry to be so dumb

      • #1965366 Reply

        mn–
        AskWoody Lounger

        Well yes… but the “arp -d” case is really very specific.

        First do an “arp -a” and see if the list has any host addresses as static entries to begin with… broadcast and multicast addresses are perfectly normal to have as static though.

        Then, IF there are erroneous host entries, take the IP from the erroneous entry and use that in the”arp -d” command.

        Background: the arp table is associations between network hardware / MAC address and IP address. As in, what IP address lives at or behind which hardware device.

    • #1965167 Reply

      PaulK
      AskWoody Lounger

      On both PCs: open up a Command Prompt, and key in ipconfig .
      The ‘Default Gateway’ Address should be the same for both PCs.
      ipconfig

      On the problem PC, what is the result of a ping 192.168.1.254 ?
      ping

      I don’t see anything in the BT Help topics that gives me any ideas.

      Most Windows ‘commands’ are self-documenting.
      Key in the command name, followed by: space, slash, question-mark. Thus: arp /? .
      The syntax of commands is: command, space, options. And, many commands will default to this documentation by just entering the command itself without any options. Thus: arp . But see that ipconfig requires the [space]/? for the options information: ipconfig /? .

      Attachments:
    • #1965912 Reply

      rogertrigg
      AskWoody Plus

      Below you can see the ipconfig command result and ping result for both PCs. There’s a difference in the IPv4 values, and the Default Gateway for the Win Home machine has a line beginning “fe80…” which is absent from the Win Pro PC. I’m on the edge of my comfort zone as you can probably guess, so I don’t know whether or not these differences are significant.Win-10-Home
      Win-10-Pro

      Attachments:
      • #1965921 Reply

        Kirsty
        Da Boss

        I wonder if the lack of a MAC address (under Default Gateway) on the Pro machine is relevant (2nd screenshot)?

        • #1965963 Reply

          b
          AskWoody Plus

          It’s not a 48-bit MAC address, but a 128-bit IPv6 address.

          Knuckle dragger Cannon fodder Chump Daft glutton Idiot Crazy/Ignorant Toxic drinker Blockhead Unwashed mass Seeker/Sucker "Ancient/Obsolete" (Group ASAP) Win10 v.1909

          1 user thanked author for this post.
      • #1966138 Reply

        mn–
        AskWoody Lounger

        Well the “General failure” from ping really is a sign that something is badly wrong…

        It’s just, there’s at least half a dozen possible ways that can happen on Windows.

        I too suspect that these anomalies (no IPv6, no Gateway access) have a common root cause, but I have no idea where to probe. Google Searches result in interesting reading, but nothing definitive on this problem.

        Was https://appuals.com/fix-general-failure-error-running-ping-commands/ by chance among the results? That lists several ways people have been able to fix this, but I get the feeling that some of those might have been more like accidentally started working… and still doesn’t cover driver incompatibility with Windows updates and such.

    • #1966072 Reply

      PaulK
      AskWoody Lounger

      The IPv4 numbers are the addresses of the computers. Home is at 97, Pro is at 68. This is normal; each device on a network has an unique address.

      The lack of any IPv6 data on Pro is curious.
      In 1964331 you said: “The network settings appear to be the same on the two PCs.” These are the settings at [(right-click on Local Area Connection) > Properties], correct?
      LAConnProp

      Or if you click on Status –
      LAConnStat
      And here on Status, clicking on Details supplies more information.

      (The displays above are on Windows 7; Windows 10 may be different.)

      I too suspect that these anomalies (no IPv6, no Gateway access) have a common root cause, but I have no idea where to probe. Google Searches result in interesting reading, but nothing definitive on this problem.

      Would someone who speaks Networking care to enter this fray?

      Attachments:
    • #1966166 Reply

      Paul T
      AskWoody MVP

      @mn speaks networking and I agree with his assessment of “something badly wrong”.

      I suggest a complete reset of the network components or a re-install of Windows.

      cheers, Paul

    • #1966501 Reply

      rogertrigg
      AskWoody Plus

      Problem solved – or not so much solved as overcome. I re-installed Win 10Pro using the download MediaCreationTool1903.exe file choosing to retain all my programs & data. Took about 90 minutes and got updated from 1809 to 1903 in the process (hope I won’t regret that). The ipconfig state looks the same as before:

      Win-10-Pro-1

      File manger reduced to simplest state looks:

      File-Manager

      ‘Patt-Zoo’ is the Win 10 Home PC and ‘WDTVLIVE’ a media streamer that pumps music, video and photos into my TV from data stored on the WDMy CloudMirror box,

      My sincere thanks to all who contributed to this saga. I’m only sorry I still can’t put my finger on the errant setting.

      Attachments:
      2 users thanked author for this post.
      • #1966759 Reply

        PaulK
        AskWoody Lounger

        Congratulations! And thanks to @mn and to @paul-t for enlightenments.
        Now to the next challenge: getting IPv6 active (you never know when you’ll need it).
        Note too: A PING to an IPv6 address also works; you may omit the final ‘%8’ in your case.)

    Please follow the -Lounge Rules- no personal attacks, no swearing, and politics/religion are relegated to the Rants forum.

    Reply To: Windows 10 blind to NAS box

    You can use BBCodes to format your content.
    Your account can't use Advanced BBCodes, they will be stripped before saving.