• Windows 10 October update disables Internet Explorer 11

    Home » Forums » AskWoody support » Windows » Windows 10 » Questions: Win10 » Windows 10 October update disables Internet Explorer 11


    Windows 10 October update disables Internet Explorer 11

    I have a need to use Internet Explorer 11 – not Edge in Internet Explorer mode – with Windows 10 occasionally.

    Unfortunately, after installing the October cumulative update (5031356), Internet Explorer will no longer launch.

    I have Edge “blocked”, using EdgeBlock, because I use and prefer Firefox.

    When I attempt to open Internet Explorer it looks like it’s trying to launch Edge, but fails because Edge is blocked.

    That’s fine, because I don’t want to use Edge.

    But I do want to use Internet Explorer 11 from time to time, so does anyone have a method for circumventing whatever is blocking it?


    Viewing 6 reply threads
    • #2594519
    • #2594621

      Like @AusJohn, I still have a need to use MSIE11 to support several businesses that still use it for “in-house” processes.

      I’ve been using the following registry entries to prevent the MSIE to Edge redirect mode since Microsoft switched it “ON” back in Feb.


      Haven’t installed the Win10 Oct KB5031356 update yet, but so far those keys have worked to allow MSIE11 to launch as expected.

      BTW, I created an MSIE11 shortcut that points directly to the iexplore.exe program (C:\Program Files\Internet Explorer\iexplore.exe) to replace the default one that used a Windows “launch” routine to start it.

      2 users thanked author for this post.
      • #2594940


        Just installed Win10 Oct KB5031356 update and, as noted by others, it disabled MSIE (i.e. when I tried to run MSIE11 I got the following popup with the only option being to continue – which starts Edge in IE mode.)

        I reinstalled the above registry entries and MSIE11 now launches normally again!

        • #2594991

          Thanks @n0ads.  That’s really handy to know, especially if the @Alex5723 workaround fails for any reason.


        • #2597462

          Hello! I have tried to apply your changes, but i still cant lauch iexplore.exe. Maybe i am doing something wrong? have you made any other changes? do you have pictures of your applied registry changes?

          • #2597516

            It seems the change that prevents MSIE from starting wasn’t actually part of the Oct CU update but the Edge update from version 117 to 118.

            I have Edge set to only allow manual updates and, after I recently update from Edge v117.0.2045.60 to v118.0.2088.69, MSIE also stopped opening for me.

            I created my own special vbscript to open it using the CreateObject option listed in the Try these tricks link posted by Alex5723, with the addition of some AutoIt commands to customize how it opens, and it’s working again.

            Like what Les posted below, if I “manually” enter a site into the address bar, it’ll open in MSIE but, unlike him, my favorites do still work… although they open in Edge instead of MSIE!

            • #2597817

              I have Edge set to only allow manual updates…

              So how, pray tell, do you do that?? I haven’t noticed any such setting within the myriad of settings within Edge proper. Is it accomplished via Group Policy?? If so, exactly where within GP?

            • #2597819

              I have Edge updates ‘disabled’, in preference to ‘manual’, and did it by setting the 3 Edge update tasks listed in Task Manager to ‘disabled’, and the 2 Edge update entries in services.msc to ‘disabled’.

            • #2597818

              You may well be correct, but I have my doubts that what you’ve explained is correct in my case.

              Why? Because I have Edge updates disabled, and as far as I can ascertain the latest version of Edge installed on my Windows 10 desktop computer is 91.0.864.37 (circa May 2021), found at:

              C:\Program Files (x86)\Microsoft\Edge\Application\91.0.864.37

              And, as you’re aware, Internet Explorer 11 was working normally until I installed the October 2023 cumulative update.

              Like both you and Les, if I “manually” enter a site into the address bar, it’ll open in MSIE 11.

              Like Les, but unlike you, my favorites don’t work in MSIE 11. They don’t even open in Edge instead of MSIE, but that’s because Edge is disabled.

            • #2599165

              what version of ms edge webview2 runtime are you on?

            • #2599847

              Version 91.0.864.37

            • #2598183

              Ok, here’s my settings to disable Edge auto-update while still allowing me to “manually” update it when I want to.

              Open Task Scheduler and Disable both of the Microsoft Edge Update tasks.

                • Note: if you delete them, they’ll get recreated the next time Edge gets updated but, if they’re disabled, they’ll stay disabled.

              Open Services and set the following options:

                • Microsoft Edge Elevation Service (MicrosoftEdgeElevationService) – Manual
                • Microsoft Edge Update Service (edgeupdate) – Disabled
                • Microsoft Edge Update Service (edgeupdatem) – Manual (Trigger Start)

                  Note: if you disable all 3 services, you won’t be able to “manually” update Edge.

              I also have the following settings in Group Policy but am not sure if they really matter or not as setting the equivalent Google services to the same settings as above also prevents Google from auto-updating while still allowing it to be manually updated.

              Under Administrative Templates > Microsoft Edge Update > Applications > Edge set the following options:

                • Prevent Desktop Shortcut creation upon install – Disabled
                • Update policy override – Enabled and set to Manual updates only

              Under Administrative Templates > Windows Components > Microsoft Edge set the following options:

                • Allow Microsoft Edge to per-launch at Windows startup, when the system is idle, and each time Microsoft Edge is closed – Enabled and set to Prevent per-launching
                • Allow Microsoft Edge to start and load the Start and New Tab page at Windows startup and each time Microsoft Edge is closed – Enabled and set to Prevent tab pre-loading

              These settings prevent Edge from auto-starting and auto-updating on my Windows 10 PC.

              To “manually” update Edge, I open Edge > Settings > About Microsoft Edge and it initiates a update check and installs the “latest update” if one’s available.

              Note: on my PC Edge sometimes throws an error when it reaches the 66% complete mark during the update process.

              It seems to be a 50/50 chance of it occurring during update attempts and I’m not sure exactly what causes it (like a lot of MS error messages, the description of the problem doesn’t really help), but simply closing Edge and then restarting the manual update always works.

            • #2604335

              I don’t think so. I have Edge fully removed from the computer using Revo uninstaller and IE still won’t launch.

          • #2597816

            Same situation here – I’ve made the registry changes, but MSIE still won’t launch except when I use the IE11 desktop suggestion from:


    • #2594763

      after install 2023-10 cumulative update you cannot open IE 11

      you just need to uninstall KB5031356

    • #2594822

      after install 2023-10 cumulative update you cannot open IE 11

      you just need to uninstall KB5031356

      No, you don’t :


      Uninstalling a CU is futile because next months CUs will contain all previous CUs and add some, unless you uninstall and stop updating all CUs until EOL.

      Stand alone IE is gone forever.

      1 user thanked author for this post.
    • #2596473

      Thanks Internet Explorer now open but the set Home page is missing and my Favourites no longer open the associated web pages. They will open if I type the url in though. Hope someone has a solution

      • #2602064

        Thanks Internet Explorer now open but the set Home page is missing and my Favourites no longer open the associated web pages. They will open if I type the url in though. Hope someone has a solution

        You can put a homepage URL in quotes (including a URL scheme) in between the parentheses after “open” in the shortcut command.

    • #2607617

      Internet Explorer 11 is still working for me on my Windows 10 desktop and laptop – using mshta.exe javascript:open();close() – but there are several annoyances which I would like to be able to “fix” if it’s possible. Namely:

      1. Moving the window isn’t remembered; that is, on next use it opens in the old position.

      2. Resizing the window isn’t remembered; that is, on next use it opens the same size as previously.

      3. Maximising the window isn’t remembered; that is, on next use it opens the same size as previously.

      4. On opening IE11 the cursor isn’t visible; I have to click in the Address bar to start typing an URL.

      5. Favorites no longer work; that is, I click on a Favorite and nothing happens.

      If anyone has a fix, or workaround, for any or all of these annoyances, I would love to know.

    • #2607734

      You can solve items 1 – 4 by using a combination of the following vbscript & AutoIt to open Internet Explorer.

        ' Enable Object Commands for VBscript & AutoIt
        Set WshShell = CreateObject("WScript.Shell")
        Set oAutoIt = WScript.CreateObject("AutoItX3.Control")
        ' Open Internet Explorer 11
        ' Set AutoIt windows title match option to "EXACT"
        oAutoIt.Opt "WinTitleMatchMode", 3
        ' Maximize MSIE11 window & activate it
        oAutoIt.WinSetState "Internet Explorer", "", oAutoIt.SW_MAXIMIZE
        oAutoIt.WinActivate "Internet Explorer"
        ' Set focus to address bar
        WshShell.SendKeys "%D"

      The oAutoIt commands in the script bring the MSIE11 window to the front, maximize it, and set the focus (i.e. cursor) to the address bar.

        Note: AutoIt has other options for controlling the Window size and position but my preference is to have it maximized.

      I created a shortcut to the vbscript that I use to start MSIE and, so far, it still works.

      As for the Favorites & Bookmarks…

      Whatever Microsoft did during their last update to disable MSIE now prevents them from working, even if you disable the MSIE ⇒ Edge redirection they put in place, so now you have to manually enter an address to get it to open in MSIE.

      2 users thanked author for this post.
      • #2607898

        Thanks for the detailed information.

        I’m not familiar with using AutoIt or vbscript, but I’ll certainly give your suggestion a go when I get some time to give it my full attention.

        Knowing my capabilities, there’ll be a steep learning curve. 🙂

        • #2608160

          Well, I’ve had a go at doing this but, as I expected, I failed miserably.

          What I’ve done is:

          1. Download and install AutoIt

          2. Copy @n0ads code into a text editor, and save it as test-ie.vbs

          3. Double-click on test-ie.vbs (or right-click on it and click ‘Open’), which results in an error, as shown below.


          I’ve done some searching on the internet, and with my limited knowledge it appears that the error may be due to the fact that “Virtualization-based security” is not enabled.

          System information (below) shows my setting for it.


          Further reading has just left me confused, and not confident to try anything else at this stage.

          If some kind soul can give me a bit (or, probably a lot) of help, then I’m willing to persevere; otherwise, I’ll continue using IE11 “as is” and put up with the annoyances.

          • #2608224

            Actually, it looks like for some reason the AutoItX3.Control class which provides the I/F between AutoIt and processes that call it wasn’t properly registered when you installed AutoIt.

            To manually register it, open an elevated cmd.exe prompt (i.e. Run as administrator) and enter the following:

            regsvr32 "full path to AutoItX3_x64.dll"

            If you installed AutoIt in the default location, the command would be:

            regsvr32 "C:\Program Files\AutoIt3\AutoItX\AutoItX3_x64.dll"

            Press Enter and you “should” see a message similar to this:

            With the text indicting “DllRegisterService in C:\Program Files\AutoIt3\AutoItX\AutoItX3_x64.dll suceeded”.

            Your script should now work.

            1 user thanked author for this post.
            • #2608534

              Thank you so much, @n0ads, for taking the time to offer more feedback.

              When I installed AutoIt it seemed to be suggesting that I should choose the 32-bit option, for compatibility reasons, even though I’m running a 64-bit machine.

              So I took their ‘advice’ and installed the 32-bit option to C:\Program Files (x86)\.

              When I read your comments I figured you were pretty much on the ball, and decided there wasn’t any point trying to register the 64-bit .dll, so uninstalled AutoIt and reinstalled it as a 64-bit program to C:\Program Files\.

              Voila! Worked almost like you described, except for the fact that focus wasn’t set to the address bar. Disappointing, but I thought I could live with it.

              Then I decided maybe I can’t, so went looking for a fix or workaround.

              Once IE11 is running I can press Alt-D (the equivalent of your WshShell.SendKeys “%D”) and the cursor shows in the address bar, so I didn’t have any idea why the code wasn’t doing what it’s supposed to do.

              At first, after doing some searching on the internet, I tried a delay, like WScript.Sleep 2500 before WshShell.SendKeys “%D”.

              That didn’t help, so I tried something else:

              For i = 1 to 10
              WshShell.SendKeys “%D”

              To my amazement, it worked! That is, it now sets the focus to the address bar.

              Also, once I had it working I decided to tweak it a bit because I didn’t want it maximized if it was avoidable.

              So instead of using oAutoIt.WinSetState as you did, I’ve used oAutoIt.WinMove which allowed me to set both the position on the screen, and the size of the window.

              Very happy, and thank you once again for all your help; most appreciated.

            • #2608554

              On my PC, there is a noticeable delay before the cursor actually appears in the address bar (but only slight more than a sec) so I’m surprised you had to setup what’s basically a timing loop to get it to work?

              Maybe a difference in CPU clock speeds (my runs at 4.9 GHz).

              I knew about the AutoIt.WinMove command but, since I preferred MSIE to start maximized, didn’t use it. Glad to see you figured it out.

              How if only we could figure what MS did to disable the MSIE Favorites and get them reactivated?

              I know it’s not something they changed in the Internet Explorer folder itself because I restored both the x86 and x64 versions from my Jan 2023 backup and MSIE was still hamstrung.

              Like many others on the internet, I suspect it has something to do with the new ie_to_edge_bho.dll that was added during the Oct update but, so far, no one’s been able to figure out how to disable it from working (even renaming all versions of it on a PC to ie_to_edge_bho.dll.DISABLED doesn’t restore full MSIE functionality.)

              Anyway, glad I could help!

    Viewing 6 reply threads
    Reply To: Windows 10 October update disables Internet Explorer 11

    You can use BBCodes to format your content.
    Your account can't use all available BBCodes, they will be stripped before saving.

    Your information: