News, tips, advice, support for Windows, Office, PCs & more. Tech help. No bull. We're community supported by donations from our Plus Members, and proud of it
Home icon Home icon Home icon Email icon RSS icon
  • Windows 8.1 USB question

    Posted on southieguy Comment on the AskWoody Lounge

    Home Forums AskWoody support Windows Windows 8.1 Questions: Win 8.1 (and Win 8) Windows 8.1 USB question

    Viewing 5 reply threads
    • Author
      Posts
      • #2293561
        southieguy
        AskWoody Plus

        I hope this is the right place to ask this question/request for help . . .

        I have a Dell Latitude E5450 laptop, running 8.1

        A while back,I had backed up some of my data to a USB 2.0 thumb-drive, using this laptop.

        Something has changed such that when I try to read that thumb-drive on the only port available (it’s a USB 3.0 port), the system says it doesn’t support reading a 2.0 on a 3.0 port.

        Can someone please suggest how I might regain access to the data on my 2.0 thumb-drive?

        Thank you,

        Dick-Y

      • #2293577
        Alex5723
        AskWoody Plus

        the system says it doesn’t support reading a 2.0 on a 3.0 port.

        USB 3.0 is backward compatible with USB 2 and USB 1.

        What exactly is the notice ?

        1 user thanked author for this post.
      • #2293587
        DrBonzo
        AskWoody Plus

        @southieguy – When you say “…the only port available…” do you mean there is only one usb port or do you mean the other ports are being used for other stuff?

        I’ve got a Latitude E5450 and it’s got 3 usb ports, one on the right side near the display and two on the back (one on the right and one on the left). The port you’re using for the thumb drive might be bad/fussy/etc.

        • This reply was modified 4 months, 2 weeks ago by DrBonzo.
        1 user thanked author for this post.
      • #2293598
        southieguy
        AskWoody Plus

        When I plug the 2.0 into 1 of the ports (I’ve tried them all) it doesn’t show up when I click on Explorer.  So I click on “show hidden icons” and the green icon is there that says “Safely Remove Hardware and Eject Media.”

        I open ” Devices & Printers” and it shows my Cruzer 2.0

        I select Troubleshooter and it comes back: “USB mass storage device is an older USB Device and might not work with USB 3.0”

        I have ejected the device, rebooted, rinse and repeat . . . no joy.

        Dick-Y

      • #2293697
        Paul T
        AskWoody MVP

        The device may not have been initialized for some reason.

        1. Plug it into one of the ports where is “doesn’t show up”.
        2. Run Disk Management. Win R, diskmgmt.msc
        3. Can you see the USB? Post a screenshot if you can see it.

        cheers, Paul

        1 user thanked author for this post.
      • #2293748
        southieguy
        AskWoody Plus

        Thank you all for your help.  Last night I had a eureka moment (or my brain unfroze.)

        For years I have always used a 2nd partition for my data.

        Earlier this year I decided (bad decision) to switch to having everything on my C:\ drive.

        Last night I said to myself:  ‘I wonder what would happen if I create a small D:\ partition and then try the USB 2:0 again. I bet this thumb-drive was used when I had a separate data partition.’

        For reasons I don’t understand , it worked!  The system recognized my 2.0 thumb-drive.

        All is well again.

        Dick-Y

    Viewing 5 reply threads

    Please follow the -Lounge Rules- no personal attacks, no swearing, and politics/religion are relegated to the Rants forum.

    Reply To: Windows 8.1 USB question

    You can use BBCodes to format your content.
    Your account can't use Advanced BBCodes, they will be stripped before saving.

?
This website collects data via Google Analytics. Click here to opt in. Click here to opt out.
×