• Windows Defender is now working again

    Home » Forums » Newsletter and Homepage topics » Windows Defender is now working again

    Author
    Topic
    #201302

    Remember the problem everyone was having with Windows Defender definitions — on Win7 machines that didn’t have updated antivirus? Vess Bontchev repor
    [See the full post at: Windows Defender is now working again]

    5 users thanked author for this post.
    Viewing 9 reply threads
    Author
    Replies
    • #201308

      All,

      Already confirmed here on Askwoody in posts here & here & here

      Enjoy …

      EDIT:forgot to add 1st post link posted by @cybertooth July 3rd 11:31 PM

      Win7 - PRO & Ultimate, x64 & x86
      Win8.1 - PRO, x64 & x86
      Groups A, B & ABS

      3 users thanked author for this post.
      • #201314

        Excellent work… you beat Vess by three hours!

        1 user thanked author for this post.
        • #201320

          Well I saw @Cybertooth post yesterday 7/3 at 11:31 PM that Windows Update indicated he had a Defender update but it failed installing. I tried to duplicate his failure at 00:03 but it worked fine for me.

          But, it took forever to get my post up due to all the pics I wanted to put in so @columbia2011 beat me to it.

          So this was really a collaborate effort by all 3 of us 🙂

          Win7 - PRO & Ultimate, x64 & x86
          Win8.1 - PRO, x64 & x86
          Groups A, B & ABS

          2 users thanked author for this post.
          • #201364

            (Copied from another thread)

            I had a very similar situation on Win7 x64 when WD was doing its pre-scan autoupdate. Here’s what’s in the event log (July 4):

            WDefender log: failure to install 1.1.15000.2 engine over 1.1.14901.4, with error 0x80070666 (Another version of this product already present, unable to continue)
            Failure to install 1.271.442.0 definitions over 1.269.1974.0, same error

            WUpdate log: failure to install Definitions update for Windows Defender Antivirus KB915597 (1.271.442.0) with error 0x80070643

            Files that were downloaded during autoupdate (based on BITS log):
            mpsigstub_a92fa1376c528b0a06f18b1166ced0ab9b9d3d11.exe
            as_engine_patch_1.1.14901.4_9accbefa5fabb6521c7db3277ad9fe68ca219218.exe
            as_delta_f42b5f9faa06b2d66d23fa73ee707280e8898df8.exe

            Later today, I noticed those errors, opened WD and selected “Check for updates” from the dropdown menu. The update went successfully, engine and definitions upgraded to 1.1.15000.2 and 1.271.442.0, respectively.

            Files that were downloaded during manual update request (based on BITS log):
            as_engine_39d0766b21d22c41878b885b1242c855c50ba32c.exe
            as_base_619fbc1dae2e308505e30a4b9da476cbde9d4d5a.exe

            A thing to note: in June 11 updates and prior, definition update file was named mpas-d_*.exe and engine updates were named mpas-fe_bd_*.exe.

    • #201309

      M$ “Scared Straight” (for the moment) by the AW “lifers”??

      1 user thanked author for this post.
    • #201315

      However, in Windows 7, Defender only provides protection against spyware.

      Extracted from the foot of the MSFT page: MSE page As you state Woody, it is ‘ancient’ and not to be relied on considering MSE is the only other MSFT alternative for W7, which, is far better. (without going into various 3rd party AV’s)

      Win8.1/R2 Hybrid lives on...
      3 users thanked author for this post.
    • #201363

      Many years ago I got fed up by running Defender, McAffee, Norton and what not. Disabled Defender, installed MSE and just use standard Windows FireWall. Despite visiting darker corners of the web, never had any problems.

      Besides by then my backup/restore strategy was set, so nothing can’t really be anything more than annoying at the most, won’t break anything here.

      2 users thanked author for this post.
    • #201387

      I use the even more ancient MSE on Win7 and never had a problem.  Backed up with the ADW Cleaner.

      3 users thanked author for this post.
    • #201395

      Win 7 Pro x64. Hadn’t been offered an update for Defender at Defcon 3. Have it disabled anyway and just run scan when it nags ~ every two weeks. My AV is KIS 2018 anyway but Defender came with the O/S…

      Turned on WU and got Defender checked and a Powerpoint update unchecked, so that I ignored. First install attempt failed. Rechecked for updates and tried again and it succeeded. Go figure! Turned off WU checks again. Total incompetence… 🙁

    • #201458

      I can confirm that Windows Defender is updating itself on Vista too. Just checked, and the definitions version is up to 7/3/2018.

       

      3 users thanked author for this post.
    • #201463

      Are there any more-or-less qualified suggestions as to why Windows Defender updates failed?

      On permanent hiatus {with backup and coffee}
      offline▸ Win10Pro 2004.19041.572 x64 i3-3220 RAM8GB HDD Firefox83.0b3 WindowsDefender
      offline▸ Acer TravelMate P215-52 RAM8GB Win11Pro 22H2.22621.1265 x64 i5-10210U SSD Firefox106.0 MicrosoftDefender
      online▸ Win11Pro 22H2.22621.1992 x64 i5-9400 RAM16GB HDD Firefox116.0b3 MicrosoftDefender
      • #201471

        Not really sure why it stopped working for the last 3 weeks or so but suspect something at MS end got changed either deliberately or by accident. If deliberate, it probably shouldn’t be working now should it?

        I just invoked another defender update from within defender and it displays that it’s up to date with version “1.271.442.0”.

        But, the MS manual update site here displays the current version is “1.271.501.0” dated 7/4/2018 10:07 PM UTC.

        The MS defender release notes page here has version “1.271.504.0” dated 7/4/2018 11:28 PM UTC as the most current version. So far for today, 7/4/2018, there have been 16 version releases with 1st being “1.271.442.0” & last “1.271.504.0”.

        As noted in my previous post here

        But the interesting thing is that the update version that Windows Update & Defender found was the 1st one listed for 7/4/2018 – version “1.271.442.0” if you go by the release notes day & time so maybe this is normal.

        I’m thinking maybe Windows Defender update finds & downloads only the 1st version of the day. If this isn’t the case, maybe it’s BROKEN again … ?

        If you don’t use it or any other malware protection … ?

        I’ll try it again in a few hours to see if it still works.

        p.s. – good to know it’s back up for VISTA 🙂

        Win7 - PRO & Ultimate, x64 & x86
        Win8.1 - PRO, x64 & x86
        Groups A, B & ABS

        3 users thanked author for this post.
    • #201480

      There might still be a problem for Vista SP2 users.

      I started  Windows Defender (it’s normally disabled on my Vista SP2 machine and I only check for definition updates every month or so) and ran a manual Windows Update this evening.  Windows Update did find one available update for Windows Defender, but the installation failed with an error 8070666.

      I also noticed that, unlike previous Windows Defender updates, the name of this failed update was Definition Update for Windows Defender Antivirus – KB915597 (Definition 1.271.422.0) so I don’t know if Microsoft has changed the name of the update (i.e., by adding the word “Antivirus”) or if they tried to deliver the full Win 8.x / Win 10 set of antivirus definitions to Vista machines by mistake, which in turn caused the failure.

      My Windows Defender is currently on definition set 1.269.1075.0 / scan engine 1.1.14901.4.  I’ve posted images of my Windows Update failure in post # 16 of devilus’ thread No More Updates for WD in Vista? in the bleepingcomputer Vista board.
      ————
      32-bit Vista Home Premium SP2 * Firefox ESR v52.9.0 * Norton Security v22.14.2.13

      Edited for HTML. Please use text tab for copy/paste.

      • #201484

        Further to my reply above about my error 8070666 with Windows Update (which I accidentally posted anonymously) I tried the workaround suggested in another thread and used the built-in updater by opening Windows Defender and clicking the Check for Updates Now button (or Help | Check for Updates).  That worked and I was successfully updated to to definition set 1.271.442.0 / scan engine 1.1.15000.2.
        ————
        32-bit Vista Home Premium SP2 * Firefox ESR v52.9.0 * Norton Security v22.14.2.13

        1 user thanked author for this post.
    • #201691

      Hey Guys,

      I still think there’s something terribly wrong with Windows Defender running on Windows 7 and maybe Vista & XP too.

      Yesterday, it seemed to work but only found & updated up to version “1.271.442.0” dated 7/4/2018 12:18 AM UTC which was the very 1st version released for 7/4/2018.

      I just did another Win7 defender update using the pull-down within defender and it said it was “up-to-date” shown below:

      Windows Defender Update 7-5-2018

      However, there were a total of 15 version updates after “1.271.442.0” released yesterday 7/4/2018 and another 16 total versions released today 7/5/2018 starting with “1.271.511.0” dated 7/5/2018 12:39 AM UTC and so far ending with “1.271.572.0” dated 7/5/2018 11:19 PM UTC.

      So, after finding the 1st one released yesterday, defender hasn’t been able to find any of the more current versions released since then even though up to now 31 more current versions have been released.

      Now I realize that some or all of these 31 updates may only be incremental updates and maybe defender only finds an update when a new complete update file that incorporates the incremental updates is released.

      If this is the case (maybe it always was), Windows 7 Windows Defender really is a piece of s**t. Reviewing MS’s last 20 version release notes here, there have been dozens upon dozens of added detection’s added to these 31 update releases.

      I wouldn’t expect MS to be virtually constantly updating in real time everyone’s definitions as detection’s are discovered. But I would expect that if you manually invoke a defender update, it would find/download/install the MOST current definitions available whether it/they be incremental or not.

      I use Symantec Endpoint Protection (SEP) version 12.1.6 MP10 and when I update, it updates. (you can also set it to update automatically at 1hr increments from every 1 to 4hrs)

      I don’t know how MSE or other vendor products update their definitions but I’m now of the opinion that, unless you grab & run the appropriate current definition update file from MS’s Anti-Malware Definition Update website here, you really don’t have a clue as to whether you’re scanning with “up-to-date” definitions even though defender (maybe MSE) shows that you’re “up-to-date”. Maybe this is why it’s got the reputation of being a piece of c**p because it doesn’t find anything.

      Also, I don’t have a clue if any of this applies to other Windows versions but it may.

      Any other testers out there … ?

      Win7 - PRO & Ultimate, x64 & x86
      Win8.1 - PRO, x64 & x86
      Groups A, B & ABS

      • #201745

        I just tried updating again with four 7/6/2018 revisions already released on MS website and still NOGO. Defender says I’m up-to-date with 1.271.442.0 released at 12:18 AM UTC on the 4th.

        That’s 35 revisions, countless added detections & 48hrs+ without updates … maybe we’ll be waiting another 3 weeks or so to get updated again. 🙁

        I give up – Windows Defender seems useless as far as definition currency on Windows 7 is concerned.

        Win7 - PRO & Ultimate, x64 & x86
        Win8.1 - PRO, x64 & x86
        Groups A, B & ABS

      • #201827

        I just tried checked for WD updates via both WU and the WD GUI, on a Vista and a 7 system.

        Both of them report there are no new updates to download, and both have definition version 1.271.442.0 from July 3 at 6:12 PM.

        One observation: even when Defender updates were working properly, new definitions would become available only every 3-4 days. So the fact that they can’t find anything more recent than July 3 yet, would appear to be normal (as such things go). But if it gets to be July 8 or 9 and there’s still nothing to be found, then we might have a problem.

         

        1 user thanked author for this post.
    Viewing 9 reply threads
    Reply To: Windows Defender is now working again

    You can use BBCodes to format your content.
    Your account can't use all available BBCodes, they will be stripped before saving.

    Your information: