News, tips, advice, support for Windows, Office, PCs & more
Home icon Home icon Home icon Email icon RSS icon

We're community supported and proud of it!

  • Windows Loading/Timing Error?

    Home Forums AskWoody support Windows Windows 7 Questions: Windows 7 Windows Loading/Timing Error?

    Viewing 6 reply threads
    • Author
      Posts
      • #2279668

        Got a slight pain here- seems that occasionally when I open the lid on my sleeping-but-already-booted laptop, I get either one of two failures: my Bluetooth driver CsrHCRPServer.exe and/or my WiFi card applet/driver will stop working when the laptop comes out of Hibernation. I _very_ occasionally see this on bootup, but it’s mostly happening on coming out of hyber. Happens sometimes on bootup with MSE, but very rarely.

        I have faced similar issues with XP a long time ago, and recall it’s a ‘Windows Loading/Timing Issue”. I do remember it was almost impossible to fix, and I just got used to having to reboot the system when it happened.

        Is there a fix in Win 7 any better at fixing this issue? If so, what can I try? I’ve just accepted it as a Windows “Feature” :/  It’s a minor pain, and I live with it, but was just wondering…

        Clue: They’re all network-dependent programs….  </:/  …and I do have MSE set to check for updates every 2 hours…could it be trying to load at the same millisecond as the Bluetooth driver or the network tray applet/program?

        Stumped.

        Win7 Pro SP1 64-bit ESU, Dell Latitude E6330, Intel CORE i5 "Ivy Bridge", 12GB RAM, Group "0Patch", Multiple Air-Gapped backup drives in different locations. Linux Mint Greenhorn
        --
        "Civilization is fun! Anyway, it sure keeps me busy["

        -Zippy

      • #2279728
        Rick Corbett
        AskWoody_MVP

        Could you supply more info? The Latitude E6330 specs show it uses a Dell Wireless 380 Bluetooth module (same as my Latitude E6230).

        1. Which WiFi module does your E6330 use (the specs show multiple options – Dell 1504 and 1540; Intel 6205 and 6250).

        2. Have you run a full system check using the Dell System Detect/Dell Support Assistant (which should be built-in and available from the Start menu… but may need to be updated) when either device fails after hibernation?

        3. Have you disabled ‘Power Saving’ on the USB Root Hubs (in Device Manager)? Speccy will show you which USB controller the Bluetooth module is using but not which USB Root Hub so disable ‘Power Saving’ on all USB Root Hubs. (My own Latitude 6230 shows its Wireless 380 Bluetooth module shares the same USB controller with the built-in webcam.) Note: This will only effect the Bluetooth module as the WiFi module is a PCI device, not USB.

        4. When one or both devices don’t work from hibernation, what do they show as in Device Manager under Network adapters? Disabled?

        5. Does your system show any Windows Updates that have failed to install. (Speccy will show you this.) If so, have you checked whether they are related to power/hibernation issues? (Unfortunately MS has a bit of history in this respect.)

        6. Is the BIOS up-to-date?

        7. Any mention in Reliability Monitor (Start > Search > Reliability) or Event Viewer about any of the following when the failures occur?:

        • “CsrHCRPServer.exe Application Error.”
        • “CsrHCRPServer.exe failed.”
        • “CsrHCRPServer.exe has encountered a problem and needs to close. We are sorry for the inconvenience.”
        • “CsrHCRPServer.exe is not running.”
        • “Error starting program: CsrHCRPServer.exe.”
        • “Faulting Application Path: CsrHCRPServer.exe.”

        I doubt there will be because IMO the issue is with the OS’ power management rather than any third-party software.

        Note 1: With Speccy, it’s usually easier and quicker to run it then save the results to a text file to look through.

        Note 2: When I use the Bluetooth icon in the Notification Area to turn the Bluetooth adapter OFF, its 2 virtual adapters disappears from Network adapters in Device Manager but the device (module) itself is still visible under Bluetooth Radios (but not its enumerator). I wasn’t expecting that:

        dell-380-bluetooth-adapter

        Hope this helps…

        Attachments:
        3 users thanked author for this post.
        • #2279746

          Thanks, Rick, for your detailed and comprehensive list. Won’t have any time until Tuesday night latest to dive back into this, as Monday is often a cruncher here!

          Talk to you then!

          Win7 Pro SP1 64-bit ESU, Dell Latitude E6330, Intel CORE i5 "Ivy Bridge", 12GB RAM, Group "0Patch", Multiple Air-Gapped backup drives in different locations. Linux Mint Greenhorn
          --
          "Civilization is fun! Anyway, it sure keeps me busy["

          -Zippy

      • #2279757
        Rick Corbett
        AskWoody_MVP

        Duh! I completely forgot about power management on the Wifi card itself.

        1. Go to Control Panel > Device Manager.

        2. Right-click on the WiFi adapter, select Properties then select the Power Management tab.

        3. Remove any tick from the Allow the computer to turn off this device to save power checkbox.

        4. Click OK then close any remaining Device Manager dialogs.

        5. Back at Control Panel, go to Power Options (You may need to change to View by: Small icons.)

        6. Click on the link for Change plan settings for whichever power plan option you are using.

        7. Click on the link for Change advanced power settings.

        8. Scroll down to Wireless Adapter Settings and click on the + sign to expand the view then the next + sign to expand the Power Saving Mode.

        9. Change both options to Maximum Performance:

        wifi-adapter-power-saving

        This will (should) disable the OS’ ability to Selective Suspend.

        10. Click on the Apply and OK button then close Control Panel.

        Hope this helps…

         

        Attachments:
        1 user thanked author for this post.
        • #2280272

          Rick,

          Got home tonight late after a 200-mile, 10-hour bolt-and-strut crunching round trip tour of Southern California’s alleged Freeway “System” (including navigating, TWICE, “The Orange Crush” , the most complicated freeway interchange in the world [see Wikipedia]), and actually had three brain cells left talking to each other afterwards, so I applied your power fixes in your last post #2279757 above.

          I also incorporated the USB Hub power changes in your first post #2279728 as well, as they were set to “power saving” as well.

          I’m going to keep an eye on this machine for a few days and see if this turned the trick, and, if it does not, I’ll dive in deeper and try more of the fixes in your first post #2279728.

          As the settings were on “Maximum Power Saving” I have a hunch power management was where the gremlin lay. Or lied. (Never was clear on that one.) I could be very wrong. (I always remember my old PC Guru (R.I.P.) who said, “Computers do screwy things all the time for no apparent reason.” …and this guy started at DEC in Santa Monica in 1961, when they used ranks and ranks and row upon row of  VACUUM TUBES!!)

          I shall report back. Excellent analysis and directions, many thanks!

          P.S. Speccy is a useful little tool, isn’t it? Gone To Plaid turned me on to it.

          Win7 Pro SP1 64-bit ESU, Dell Latitude E6330, Intel CORE i5 "Ivy Bridge", 12GB RAM, Group "0Patch", Multiple Air-Gapped backup drives in different locations. Linux Mint Greenhorn
          --
          "Civilization is fun! Anyway, it sure keeps me busy["

          -Zippy

      • #2281233

        Rick,

        I thought we had the blasted thing fixed, but the Bluetooth server went nuts again and stopped.

        I may have to postpone further work on this until Tuesday earliest, as tomorrow I get to have another tooth yanked out, and Monday is a close relative’s birthday, for which I have to be vertical.

        (Bluetooth as a standard is a nightmare anyway-over years, the spec/stack/mess was developed by several committees, and my tagline lets you know about what I think about committees, having served on many during many decades.)

        Talk to you then, if the dentist doesn’t pull my whole skull out of my head (He already has an unseasonably large amount of my money due to previous “cashectomies”.)

        Cheers. :/

        Win7 Pro SP1 64-bit ESU, Dell Latitude E6330, Intel CORE i5 "Ivy Bridge", 12GB RAM, Group "0Patch", Multiple Air-Gapped backup drives in different locations. Linux Mint Greenhorn
        --
        "Civilization is fun! Anyway, it sure keeps me busy["

        -Zippy

      • #2282374
        Rick Corbett
        AskWoody_MVP

        When you’re feeling up to it, make both these changes… but not at the same time. Allow a few days between each change to see if the issue disappears. If the issue disappears then it’s a pointer that the issue is related to the OS’ power-saving rather than the Bluetooth/WiFi devices themselves.

        Change 1:
        Turn hibernation off completely for a few days to determine whether the issue is solely the result of the OS failing to consistently re-power the devices after sleep.

        Change 2:
        Change the power plan to a different one for a few days so see if it makes any difference to the devices being re-powered after a sleep.

        Again, make the two changes above at separate intervals.

        Change 3:
        Make both changes again… but this time at the same time. MS has an unfortunate and long-standing history with device failures after sleep events. You need to find a combination that works for your device.

        Hope this helps…

        1 user thanked author for this post.
      • #2282442
        Rick Corbett
        AskWoody_MVP

        Oops! In previous post I meant – in ‘Change 1’ – turn off Sleep, *not* Hibernation.

        One thing I forgot to mention… its interesting that the 2 devices you are having problems with are both radios – Bluetooth and WiFi – yet are on different data communication buses (USB and PCI respectively).

        That’s why I suspect it’s an OS power management issue (which Win 7 is notorious for) rather than a device/device driver issue.

        As a matter of interest, how do you put your laptop into a Sleep state? Power button or just close the lid?

         

        1 user thanked author for this post.
        • #2288235

          Hi Rick,

          Sorry it’s taken so long, but I’m just becoming close to 100%, after both the ms. AND I have  been undergoing “The Joy of Root Canal” at the same time, taking turns nursing each other between stages.

          To biz, then. “As a matter of interest, how do you put your laptop into a Sleep state? Power button or just close the lid?”

          Two ways: 1) Close the lid and 2) if it’s open with no activity for 15 minutes (unplugged).

          I will implement your suggestions of July 22nd ASAP.

          In the meantime I thought I’d let you know that after implementing your first set of changes, the WiFi stopped crashing…but it now takes about 50 seconds for the WiFi to connect with the gateway. That’s fine with me! Looks like it’s one down, one to go (Bluetooth Server).

          …roger on Windows power management issues…it’s infamous…have a workstation offline running XP that took me a month of canoodling with the system settings, BIOS (S1 or S3? Take yer pick…it was S3) before it behaved itself.

          But, as it said on the sign in the PC repair shop, “Laptops Are Different”.

          TTY soon as I run your other suggestions with results.

          Many Thanks!

          Win7 Pro SP1 64-bit ESU, Dell Latitude E6330, Intel CORE i5 "Ivy Bridge", 12GB RAM, Group "0Patch", Multiple Air-Gapped backup drives in different locations. Linux Mint Greenhorn
          --
          "Civilization is fun! Anyway, it sure keeps me busy["

          -Zippy

          • #2288261
            GoneToPlaid
            AskWoody Plus

            Hi Nibbled,

            Try this. Copy all of the following in between the two rows of asterisks into Notepad, and then save the file with this file name: Change IRP Stack Size To 39 (27hex).reg

            ********************************
            [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\lanmanserver\parameters]
            “IRPStackSize”=dword:00000027

            ********************************

            Then right-click on the saved REG file and select Merge to save it to the registry. What this setting does is to increase the IRP stack size for all I/O operations which are performed by the low level drivers for various devices in your computer. This REG file works for Windows XP and for everything higher, including Windows 10. I highly recommend using the above REG file to everyone in order to avoid potential issues if you have a lot of additional hardware installed in your computer, such as multiple hard drives or multiple hard drive partitions and/or network cards and/or video cards, et cetera.

            Don’t try other settings for IRPStackSize other than the default dword value of 15 hex (21 decimal) or the above dword value of 27 hex (39 decimal), as some values are not recommended by Microsoft.

            When you had your issues, did you check to see if you also lost all of your System Restore points? You might want to check to see what System Restore points you currently do have. If you have also been losing all of your System Restore points, then I have a fix to prevent this as well. The cause for losing all of your System Restore points may also be related to your issue.

            Best regards,

            –GTP

            1 user thanked author for this post.
            • #2288277
              Paul T
              AskWoody MVP
            • #2288493

              Wow! Hi, GTP! No, the restore points didn’t go away.

              So many great suggestions, and so little time to try them! Though I will, I will.

              Tomorrow (the 13th) through Monday (the 16th) the NWS has called a “Excessive Heat Watch” for my area, and the CAISO* has called for voluntary power conservation, as we’re forecast to hit 47.2 GW at peak…and the record is 50.27; that’s not a lot of room for error, so a “Flex Alert” has been called, meaning “If it ain’t strictly necessary, turn it off.” Guess I’ll have to charge the PC from a bicycle or something if we lose the juice and my UPS runs out… 🙂

              Anyway, I’ll get to all these changes after the heat wave dies down. Many Thanks, all! Stay safe!

              *CAISO= California Independent System Operator

              http://www.caiso.com/

              Yeah, I know..no https!!?? Sheesh!

              Win7 Pro SP1 64-bit ESU, Dell Latitude E6330, Intel CORE i5 "Ivy Bridge", 12GB RAM, Group "0Patch", Multiple Air-Gapped backup drives in different locations. Linux Mint Greenhorn
              --
              "Civilization is fun! Anyway, it sure keeps me busy["

              -Zippy

      • #2289923

        Folks,

        Don’t want to appear unappreciative or rude in not responding promptly to your great suggestions; it’s just that we’re in the middle of a horrible heatwave here (104 yesterday), my HVAC is running badly (it’s still 80F in here at 2 A.M.), so…so long as I am up against wondering when the next round of rolling blackouts will come, and being heat-punchy, I’m going to defer surgery on this, my only machine, until it’s cooled off, or I can get an appointment with a HVAC tech (“Two weeks!”) who won’t pick me up by the heels and shake me until every dime clatters out onto the floor, I am just going to put this annoyance to the side.

        I deeply appreciate all the help.

        Three cheers for the CAISO! (NOT!)

        http://www.caiso.com/TodaysOutlook/Pages/default.aspx

         

        Win7 Pro SP1 64-bit ESU, Dell Latitude E6330, Intel CORE i5 "Ivy Bridge", 12GB RAM, Group "0Patch", Multiple Air-Gapped backup drives in different locations. Linux Mint Greenhorn
        --
        "Civilization is fun! Anyway, it sure keeps me busy["

        -Zippy

        • #2289970
          GoneToPlaid
          AskWoody Plus

          Go outside, grab the garden hose, and wet down your roof. Evaporating water is 50 times more efficient at removing heat than air alone. Then set the end of the garden hose on top of the grill above the fan for your AC’s outside condenser unit. Hold the hose in place with a couple of bricks. Then slightly turn on the hose such that a small stream of water from the hose gets sucked into the rotating fan blades. The blades will sling the water onto the condenser coils, keeping the coils wet. Do this, and your indoor temperature will quickly drop during the next hour.

          • #2290080

            Thanks!

            Unfortunately, the condenser fan is an exhaust type, and the water bill here is already a national disgrace. 🙁

            I will, however, take the advice about wetting the roof!

            Win7 Pro SP1 64-bit ESU, Dell Latitude E6330, Intel CORE i5 "Ivy Bridge", 12GB RAM, Group "0Patch", Multiple Air-Gapped backup drives in different locations. Linux Mint Greenhorn
            --
            "Civilization is fun! Anyway, it sure keeps me busy["

            -Zippy

    Viewing 6 reply threads

    Please follow the -Lounge Rules- no personal attacks, no swearing, no politics or religion.

    Reply To: Windows Loading/Timing Error?

    You can use BBCodes to format your content.
    Your account can't use Advanced BBCodes, they will be stripped before saving.