Woody Leonhard's no-bull news, tips and help for Windows, Office and more… Please disable your ad blocker – our (polite!) ads help keep AskWoody going!
Home icon Home icon Home icon Email icon RSS icon
  • Windows Update in Win7 now appears to be working properly

    Home Forums AskWoody blog Windows Update in Win7 now appears to be working properly

    This topic contains 66 replies, has 16 voices, and was last updated by  rontpxz81 2 days, 11 hours ago.

    • Author
      Posts
    • #149830 Reply

      woody
      Da Boss

      @mrbrian notes, and @abbodi86 confirms, that the bad value <ExpiryDate> updates itself when you check for Windows updates. Windows Update’s new
      [See the full post at: Windows Update in Win7 now appears to be working properly]

      4 users thanked author for this post.
    • #149844 Reply

      dgreen
      AskWoody Lounger

      Mine is not working again.
      I had done the workaround (unchecked check for other microsoft products) yesterday.
      This morning when I read that it was fixed, I tried to do an update and it doesn’t work.
      I should have followed others advice and do nothing on my end.
      I’m thinking maybe unchecking that option and now it disappeared was not a good thing.
      I remember there is a way to get that option back.
      How do I get that option back or should I do a system restore? (sigh)
      maybe I don’t even need it???

      Edit to add:
      I just did a check and it is working again.
      Honestly, I’m about ready to tear my hair out!!!!!

      • This reply was modified 1 week, 5 days ago by  dgreen.
      • This reply was modified 1 week, 5 days ago by  dgreen.
      • This reply was modified 1 week, 5 days ago by  dgreen.
      2 users thanked author for this post.
      • #149944 Reply

        anonymous

        How did you get the checkbox back? Now i have the same problem due to unchecking the box as a quick fix because of microsoft’s utter utter incompetence.

        -T

        2 users thanked author for this post.
    • #149856 Reply

      anonymous

      M$ gave a new <ExpiryDate> of 2025-07-01 for the authorization.xml file, which is contained within the authcab.cab file, which happens to be the EOL year for Win 10.
      … This likely means that M$ are expecting most ot the affected-2017 Win 7 users to upgrade to Win 10 when it reaches EOL in 2020. Will this become a reality in 2020.?
      … This also likely means that the free Win 10 upgrade offer will continue until 2020.

      In comparison with the Nov 2014 incident affecting Win Server 2003 and Win XP SP3, M$ changed the <ExpiryDate> from 17 Nov 2014 to 03 Dec 2017, which happened to be the EOL year for Win Vista. EOL for Win XP SP3 was April 2014 and for Win Server 2003 was July 2015.
      … This likely meant that M$ expected most of the affected-2014 Win XP SP3 users to upgrade to Win Vista. But in reality, most of them upgraded to Win 7 or Win 8.x by buying new computers. …

      My Windows Server 2003 R2 SP2 and Windows XP Pro SP3 worked again as expected too.

      For your information, authcab.cab’s ExpiryDate changed to 2017-12-03T11:59:25.7927833-08:00, and muauth.cab’s ExpiryDate not change (still 2014-11-17…).

      https://social.technet.microsoft.com/Forums/en-US/77990b62-d97f-4648-815f-b021ddc07b5e/windows-update-for-windows-server-2003-will-not-load?forum=winservergen

      2 users thanked author for this post.
    • #149872 Reply

      alpha128
      AskWoody Lounger

      Windows Update still doesn’t work for me.  The window now loads, but I seem to be getting the same error others were getting earlier.

      Windows Update now tells me that I need to check for updates, but then says I can’t because the service is not running.  But I checked Services, and the Windows Update service is running.

      So the “fix” of checking for Windows updates isn’t going to help because I can’t check for updates.

      • This reply was modified 1 week, 5 days ago by  alpha128.
      2 users thanked author for this post.
      • #149914 Reply

        woody
        Da Boss

        Is it working now?

        If not, could you tell me exactly what error messages you’re seeing?

        Did you try applying any of the various fixes that have appeared?

        Thanks.

        • #150068 Reply

          alpha128
          AskWoody Lounger

          Is it working now?

          If not, could you tell me exactly what error messages you’re seeing?

          Did you try applying any of the various fixes that have appeared? – woody (Da Boss)

          When I first booted up my computer tonight it was not working.

          The error messages I was receiving were well described by byteme here: https://www.askwoody.com/forums/topic/windows-update-in-win7-now-appears-to-be-working-properly/#post-150052

          I used his posted solution and that did correct the problem.

          However, the Windows Update window won’t even load on my work computer.  I don’t know how to fix the issue if I can’t access the Windows Update settings.

          I wish Microsoft would at least publish a support document with instructions on how to clean up their mess.

          1 user thanked author for this post.
        • #150082 Reply

          OscarCP
          AskWoody Lounger

          I had a related problem to the one others have reported here today:

          When clicking on “Windows Update” at the “Action Center” of the Control Panel, all I was getting was the little “busy now” hourglass running endlessly and keeping me from accessing anything other than the Task Bar, where I would kill the “control panel”, and so regain full control.

          So I tried stopping the “wuauserv” service, and that got me to the Windows Update window without trouble, only now no updates were accessible, because the service was stopped (of course).

          So I restarted the service, but that did not register with WU, because I still got the same NO SERVICE! message. I restarted the PC: same story.

          So I went to the Settings page for Windows Update, and changed from “tell me when there are updates available, but let me choose when to download and install” to “download automatically, but let me install”. Now the Windows Update window opens OK, with the invitation to see if I have any updates. So I tried that, but WU went on looking and looking for quite a while, with no end in sight.

          Maybe the MS servers are swamped by people trying to download those latest Windows Office updates Woody has mentioned elsewhere, maybe not. I’ll try again tomorrow, see how it goes.

          If this problem has not been resolved by then, wasn’t there, some time ago, a similar problem with Update searching endlessly for updates, and what was the fix for that?

          Thanks.

           

          1 user thanked author for this post.
          • #150083 Reply

            PKCano
            AskWoody MVP

            The problem was on Microsoft. They expired an authorization file for Microsoft Update. It’s fixed now, that’s why things started working again.

            • #150094 Reply

              OscarCP
              AskWoody Lounger

              I just tried again, by changing WU settings back to “Check for updates but let me install them”.

              The opened the Windows Update window and… I got the news that there was an “Important” update ready to install! (for Excel 2010).

              So… Problem Solved!!!(?)

              Which makes perfect sense: once more, as in innumerable occasions before, one nasty Win 7 problem solved by doing something that can be described, generically as:

              (1) Rub your belly and tap your head while quacking like a duck.

              (2) Repeat (1) three times; the first time while facing East, the second, facing North, the third, facing West.

              Problem solved!!!

               

              1 user thanked author for this post.
    • #149882 Reply

      PKCano
      AskWoody MVP

      For those of you who wiped the datastore and lost the MS Update “Give me updates for other MS products,”

      HERE ARE THE INSTRUCTIONS FOR GETTING “Give me updates for other MS products” BACK.

      • This reply was modified 1 week, 5 days ago by  PKCano.
      5 users thanked author for this post.
    • #149874 Reply

      anonymous

      i have the same issue as alpha128

    • #149885 Reply

      anonymous

      How is authcab.cab actually changed on user’s machines if the WU service can’t connect?

      • #149912 Reply

        woody
        Da Boss

        VERY good question, and I don’t have an answer.

        At least, an hour ago, Mary Jo confirmed that Microsoft says it has fixed the problem.

        https://twitter.com/maryjofoley/status/938034672218624001

      • #149988 Reply

        abbodi86
        AskWoody MVP

        authcab.cab is requested and verified on each search session, it’s not the actual Microsoft Update service that failed

        1 user thanked author for this post.
      • #150036 Reply

        anonymous

        Like the martian red weed microsoft are likely to be in every nook and cranny of our machines. With windows 10 that is a given but i’ve long believed it’s true of the earlier versions as well, that they have access to certain areas, can interrogate at will, change metadata etc.

        -T

    • #149915 Reply

      anonymous

      I used this tip to reset  windows update to search for other ms software https://www.bleepingcomputer.com/forums/t/647004/updates-for-other-ms-products-option-gone/

      The reg key for ms office 2003-7 isn’t present  in my setup

      • #149924 Reply

        PKCano
        AskWoody MVP

        This method suggests you install Silverlight (providing you want Silverlight on your PC).

        After installation, you are probably going to get an options box to “install updates for other MS products.” I am going to give the same caution as I gave for the Office method:
        CAUTION: Read the check box. This may reset Windows Update to Automatic. HIDE anything in WU you don’t want to install until you can reset the choice to “Let me choose” or “Never”

        And then you are going to have to uninstall Silverlight if you don’t want it.

        2 users thanked author for this post.
        • #149971 Reply

          anonymous

          Yes , not ideal i know, I also uninstalled  it, The. This may reset Windows Update to Automatic. HIDE anything in WU you don’t want to install until you can reset the choice to “Let me choose” or “Never”

          Never was disabled on my machine, and i have since set it back to never,

    • #149916 Reply

      anonymous

      I’m not sure if this makes a difference in getting windows update to work again but here is what i did.  I went to setting in windows update and noticed that it changed to install automatically.  I changed it to never check for updates and widows update immediately started checking for updates.  I then check the cab file and it had updated to the new version with today’s date 12-5-17 and a size of 17kb.  I went back in to windows update and it show a couple of updates.  I then went back into setting and changed those to what i normally use.  So far everything seems to be working.  Not sure if this will help anyone but this is what worked for me.

      • #149947 Reply

        anonymous

        Thanks, anonymous. Changing the setting to “Never check for update” and then back to “Install updates automatically” did the trick! It did not work before and it did not fix itself until I changed the setting.

        1 user thanked author for this post.
        • #150070 Reply

          anonymous

          Glad it worked for you TY

      • #150567 Reply

        anonymous

        This tip worked for me also:

        I wasn’t initially showing the check-box option “Give me updates for Microsoft products and check”…, nor did I have the option to “Show me detailed notifications when new Microsoft software is available”…, so I couldn’t use the “deselect” workaround.
        After resetting to “Never check for updates”, & deselecting the only 2 check-box options I *did* have & confirming with OK, then resetting back to my original “let me choose”, everything was working again, and I also had the additional 2 options above restored (4 check-boxes in total).
        – rChaz

        EDIT html to text

    • #149930 Reply

      gborn
      AskWoody MVP

      Yes, it’s fixed. The question how they fixed it: via ActiveX an control in IE 11. If somebody used my workarounds and lost some update settings options or if the bug isn’t fixed, see Windows 7: Fix broken Update (Error 0x80248015) 12/4/17 for further assistance.</span>

      • This reply was modified 1 week, 5 days ago by  gborn. Reason: removed span tags
      1 user thanked author for this post.
      • #149941 Reply

        woody
        Da Boss

        it is possible that users may have to make manual steps, to repair Windows Update search.

        Any idea which users will have to repair Windows Update search – and what caused them to have problems in the first place?

      • #149987 Reply

        abbodi86
        AskWoody MVP

        The authorization is requested on server-side, it’s not related to client-side

        MU itself is a COM element registered to the system, you don’t need IE11 or Active-X to use it (i.e. you can use powershell, vbscript, WUMT)

    • #149936 Reply

      anonymous

      FWIW, for the h**l of it, opened WU and changed setting from never to let me decide. Check took a while but finally coughed up a Defender update. Installed it. Changed settings back to never until next Defcon 3. Whew… 🙁 Win7 Pro x64, Group B.

      Edit for content

    • #149945 Reply

      anonymous

      Yesterday my husband used the pc. it is set on Check for updates but… Etc. So WU got into the Red Cross modes. When I rebooted the pc today, after having read about there being a fix, I hoped clicking on Look for updates would help. It did not. In my case, there was NO auto updating of the cab file. In the end I turned the clock back to December 2nd, ran Windows Update, checked the cab (which then had renewed) and put the clock back to December 5th. So I had the same problem as Alpha128.
      Annemarie

    • #149977 Reply

      anonymous
    • #149995 Reply

      anonymous

      An anecdotal report: I was running into the Windows 7 update issue yesterday, as many people did (originally, it just gave me the error message when I tried to check for updates, but it progressed to the point where I couldn’t open the Windows Update panel at all; when I tried, the window froze until I closed it with Task Manager). I didn’t modify anything, hoping it’d be fixed automatically.

      Today, starting up the computer and checking Windows Update, it hadn’t repaired itself (though I was able to access the panel again, it still failed when I tried to check for updates). However, I went to Services and restarted the Windows Update service… and things went back to normal!

      I’m not sure how useful this report is, but just in case, I thought I’d share.

    • #149996 Reply

      anonymous

      While I was able to get WU working again using one of the above methods, the icon still does not appear in the taskbar. I’m running Win7 Home Prem SP1.

      Anybody have similar results and/or suggestions on how to get the icon back?

      Thanks

      1 user thanked author for this post.
      • #150107 Reply

        GoTheSaints
        AskWoody Lounger

        If you have chosen the setting “Never check for updates (not recommended)” the icon will not appear in the taskbar.

        Choosing any of the other three options in Change settings (why would you want to? 😉 ) will bring the icon back but that’s only if there are any updates available for your computer of course.

    • #150008 Reply

      anonymous

      None of the tweaks seemed to work except turning the clock to 2 Dec, opening WU and noting it now offered 2 optional updates, then putting the clock correct again, then opening WU and it now allows a Check for Updates which offers the same 2 optionals.  So actually fairly easy, but there will surely be millions who won’t find a fix…

    • #150025 Reply

      BobbyB
      AskWoody Lounger

      Well its working here, curiously managed to pull up some old long since installed or hidden Drivers including one for Connexant circa 2005, well it is an old Win7Prox86 machine in the corner.

      These promptly disappeared after about 5 mins with no user intervention here. It seems we are in to (re)hiding Silverlight again probably all 13-14 versions that seem to get offered on new installs.

      kb3177467 reappeared after being installed Sept, only to disappear again after being de-selected. As it is a servicing stack, although generally safe to install, it causes, well here any way, the reappearance of the user picture and frame on the “log in” page so it hasn’t installed in stealth mode and doesent appear in the installed updates list.

      “Curioser and curioser” but nothing mind bendingly serious to task the average user YET?

    • #150042 Reply

      anonymous

      I’m in the same boat as some other folks … didn’t touch anything yesterday but when checking today my Windows Update was still not working, just giving the red x and saying the service isn’t running.

      I rolled my clock back to Dec 2nd and the Update worked and found one an Office 2010 update published 12/5.  I put my computer back to the proper date and time rebooted.  Check and Windows Update is still running.

      Do this mean I’m fixed, or tomorrow will it be broken again … ie do I have to roll back my clock to before 12/3 everyday to get Window update to work?  Why did I have to roll back my clock when update was working for others but not all of us?

      • #150064 Reply

        anonymous

        anonymous #149436 from another thread here.

        I agree with your questions, and do not have an answer. I have a laptop very similar to the original question by KarenS. I had exactly the same symptoms described. That laptop is not my primary device, so I opted to do the reset described by Canadian Tech. And my problem was resolved immediately in terms of connecting to Windows Update, and having updates offered, and being able to hide those updates. All of this was many hours before the expirydate issue was acknowledged, and many more before the fix. To me, this means expirydate alone does not explain things.

        Because of the method used, my history was lost. This is of no consequence in my opinion, it is a convenience only. All real information is available from Installed Updates.

        Also, because of the method used, I lost the option to have other products offered through Windows Update. The consequence here is debatable, but not insurmountable. The important thing is that I was now able to connect to the Update server in order to do the search for updates function.

        So when the fix happened, and I connected, changes were made in the same manner as the reset. By that I mean that I had to hide yet again the items I do not want. There was not an additional set of folders made. I assume I have also been given the new expirydate code. But I do not believe that is what enabled me to connect as I have described yesterday, before that fix occurred.

        Now the truly unexplained item: My settings have reverted to ‘You receive updates: For Windows and other products from Microsoft Update’ through no action taken by me. It was simply displayed there when I was done hiding things. I went to check settings and all four options were available, and set the way they were 3days ago. The real kicker, I had already deleted those duplicate folders.

        My experience is different than many described in these three threads. And I do not have an adequate explanation to offer. Thanks for reading. Opinions welcome.

        • #150072 Reply

          PKCano
          AskWoody MVP

          Also, because of the method used, I lost the option to have other products offered through Windows Update.

          Follow the link in this post above

        • #150114 Reply

          anonymous

          #149436 here.

          Part of my confusion is that others are continuing to have that problem. Because on my machine the settings reverted to all available options, without any further action taken locally by me at all. As we have all seen, the reset takes it away. But for me it returned, as part of the fix, even though I had already deleted my renamed folders.

          This is contradictory to me, a puzzle, but requires no further effort, because all options are available just as it was several days ago. I offer the information for review, not because I require further action.

      • #150071 Reply

        PKCano
        AskWoody MVP

        The problem occurred because MS expired an authorization file.
        They have since corrected it, and everything reverts to normal.
        The problem was not on individual PCs, although Users stood on their heads to try to fix it.
        The measures you took changed things on your PC, but it wasn’t fixed until MS fixed the expired file. For example, rolling the date back just made the date on the PC earlier than the expiration date of the file.

    • #150052 Reply

      byteme
      AskWoody Lounger

      I had the same issue as alpha128, and FWIW, I didn’t do any workaround tweaking while WU was down.

      I’d go to Control Panel and click on “Check for updates” from the menu that also includes a link for “Windows Update.” Up would pop a Windows Update dialog with a red-X shield to the left of a message that said, “Check for updates for your computer,” with a “Check for updates” button in the lower left right.

      So I’d click on the “Check for updates” button, and up would pop a little dialog box that said, “Windows Update cannot currently check for updates, because the service is not running. You may need to restart your computer.”

      So I’d restart, but that didn’t help.

      What finally worked for me on the 2nd try (WU froze on me on the first try) was going to Windows Update settings and switching from good old “Check for updates but let me choose whether to download and install them” to “Never check for updates” (and OK-ing that change), and then going back and switching back to “Check for updates but let me choose whether to download and install them” (and OK-ing the change). At that point WU immediately checked for updates, and all’s been normal since.

      And the WU icon returned to the Notification Area, and remained there after rebooting.

      • This reply was modified 1 week, 5 days ago by  byteme.
      • #150104 Reply

        anonymous

        Thank you for this post. I had the same issues as alpha128 and this is the solution that worked for me. Had to restart WU in Services (even though it said WU was running) just to get the WU panel back – but then followed these instructions from byteme and now seem to have WU back and operating. It has been useful reading all of the posts in this thread – thank you everyone for sharing your experiences and solutions.

    • #150074 Reply

      gkarasik
      AskWoody Lounger

      Windows Update is still freezing on my Win7/Ent machines. I tried changing the date, but that didn’t help. The drill I have to do, and it’s really annoying, is to login, start WinUp and let it freeze, close it with Task Manager, reboot the machine, start Win Up (which now opens with the Red X) change settings to Never, Check for updates, install updates, reset WinUp settings, and re Check for Updates.

      Does anyone know of a way to reset Windows Update settings without going through Control Panel/Windows Update? It would save me some steps if I could change the Windows Update setting beforehand.

      GaryK

      • This reply was modified 1 week, 5 days ago by  gkarasik.
      • This reply was modified 1 week, 5 days ago by  gkarasik.
      • #150081 Reply

        PKCano
        AskWoody MVP

        There is a Registry entry that lets you set the value between 1-5 (1 being Automatic, 5 giving the option of Never. I picked it off the Internet somewhere, the Registry key was correct but the values it showed were in the wrong place. If you pull down the settings in WU, the first is Auto and the last is Never. That corresponds to 1-5 values in the same order.

        The Registry settings are in the Knowledge Base under the “Discussion on AKB2000003” (not in AKB2000003 itself) and some other place on this site. But with the access so messed up I get get 504s trying to look right now.

    • #150126 Reply

      anonymous

      Everything I’ve read, so far, has not helped me regain control of the MS updates.  I went through all the suggested fixes, including the suggestions on getting the icon/prompt back in the tray to update the OS. 

      To make a long story short, what finally worked for me was invoking the MS FixIt Center in Control Panel and choosing the MS Updates category.  It fixed the problem totally.  I followed the prompts and finally got the machine updated.  Voila!…  End of problem.

      • #150152 Reply

        The Surfing Pensioner
        AskWoody Lounger

        Well, I did not turn on WU whilst the service was unavailable at all – had no need to. However, encouraged by the fact that my MSE updates are listed once again in my WU installed updates section, I tried an experimental check for updates. Several attempts only threw up the red X and error code 80244019 and changing the settings did not help at all. This did not entirely surprise me – my past experience of WU is that if it can go wrong, it will – but what did surprise me was that a last-ditch attempt to launch it from the Control Panel succeeded and the subsequent check threw up the MO 2010 Excel patch I’ve read about here (which I have downloaded and saved to instal in a couple of weeks if the step seems prudent). Did I bypass the error code through the back door? Will I have to launch WU this way indefinitely? Who knows. What would we do for fun if we didn’t have software?

        1 user thanked author for this post.
    • #150136 Reply

      anonymous

      My husband had used the pc on Monday. Our WU is set to ‘Check for updates but let me …’. He never looks at it (it is my task), but in the background it turned in the famous red shield-page. Yeesterday, after reading there was a fix, I went to check, Started the pc but still the red shield and a sign saying: service has stopped working, you need to restart the pc. But like other commentors, in Task Management it was running. Could not kickstart it any other way than turning the date back to December 2nd. Ran update. Turned date back to December 5th. Update worked, cab-expirare-date now 2025. So solution for me was the date-trick.
      ~Annemarie

    • #150206 Reply

      MayfieldPhil
      AskWoody Lounger

      Not working for me. I’m getting one after another Win 7 Pro pcs unable to update. Please is there a fix? Has MS responded at all? One of my suppliers said “ upgrade to Win 10” . Not very helpful. This is school. I’ve better things to do at the moment but security is paramount.

      MayfieldPhil

    • #150217 Reply

      gkarasik
      AskWoody Lounger

      >Probably one of the easiest is to set Windows to “Never check for updates,” click OK, then set it back to the original setting. It should update the file on the first scan. If that does not work, try some of the other methods mentioned in the threads.

      This is possible only if the Windows Update dialog opens. On most of my machines it freezes so I can’t get to the Windows Update settings to change them to “Never check for updates.” In these instances a reboot helps. Note that after Windows Update runs successfully, changing the settings back to whatever your default is causes a lengthy recheck.

      Microsoft has lost its moral compass.

      GaryK

    • #150228 Reply

      anonymous

      Does having “Microsoft updates” installed/enabled play into this? I had to set the date back and disable “Microsoft updates” to get things fixed. (Didn’t need to reboot)

      • #150232 Reply

        PKCano
        AskWoody MVP

        Yes, it was the file for Microsoft Updates, which gives you updates for other MS products, that was expired (as opposed to Windows Updates that deals with only Windows).

    • #150234 Reply

      anonymous

      Brilliant. That seems to be the answer.

      Set to “never check for updates”

      Come out, go back in.

      Set back to Automatic, and it starts working again.

      Thanks for nothing MS

       

       

    • #150238 Reply

      gkarasik
      AskWoody Lounger

      One tweak that saves a reboot: Open Windows Update. It freezes. Close Windows Update with Task Manager. Open a CMD prompt. Stop WinUp Service (net stop wuauserv). Start WinUp Service (net start wuauserv). Open Windows Update. This time the Windows Update box shows. Set settings to “Never check…). Click OK. Click Check for Updates. Reset to your default Windows Update settings. Note that when you reset the settings, Windows Update will run a new update scan. (grrrr)

      GaryK

      • This reply was modified 1 week, 4 days ago by  gkarasik.
    • #150244 Reply

      anonymous

      Changed Windows Update Settings to “Never”, then checked for updates (it works). Then changed setting back.

    • #150266 Reply

      Charlie
      AskWoody Lounger

      Well it’s Dec. 6th, on my WIN 7 main computer I have NO little blue WU icon in the systray, clicking it in Control Panel brings up an endlessly running hourglass preventing me from doing anything else, and I can’t get anywhere near the settings to set anything to anything.

      I’m so fed up at this point that unless M$ does something to correct THEIR mistake, I’m going Group W!!!!  And then as SOON as possible going completely Linux!

      GRRRRRRRRRRRRR!!!!!!!!!!!!!!!!!!!!!

      • #150269 Reply

        PKCano
        AskWoody MVP

        Try opening Administrative Tools\Services
        Scroll down to Wundows Update Service, higlight and in the upper left click “stop”

        Once it’s stopped, click “start”
        The expired authorization file should update on the first scan

    • #150283 Reply

      Charlie
      AskWoody Lounger

      That didn’t work either.

       

      • #150285 Reply

        PKCano
        AskWoody MVP
        • #150313 Reply

          Charlie
          AskWoody Lounger

          Okay well somehow, something I did got it working.  The most likely thing is doing a Troubleshoot on Windows Update.  It didn’t appear to work but it did do a Check for Updates.  A little while later, up pops Windows Update.  So it’s here for now.

          I think I have to do the big group B updates before doing the Office Updates so I got those and I hope WU will still be there after the re-boot.  What a mess!

          • #150377 Reply

            anonymous

            FYI, in case this helps anyone:

            I too was getting the hourglass upon clicking on Windows Update (in Windows 7), and couldn’t close it even in task manager.  So I rebooted, which force-closed the frozen blank Windows Update window.  After I rebooted WU would seem to open normally, but with a red shield saying I needed to check for updates.  But upon clicking Check for Updates it would immediately failed, saying the service is turned off, and that I would need to reboot.  But rebooting again change anything (I tried twice), nor did stopping and restarting the Windows Update service.

            So next I tried opening the WU dialog and clicking on Change Settings.  I then changed the dropdown under Important Updates from my usual “Check for Updates but let me choose whether to download and install them” to “Never check for Updates (not recommended).  This simple goosing fixed it, as  I was then able to Check for Updates as normal.  Afterward I went back into Change Settings and reverted to my usual “Check for Updates but let me choose whether to download and install them,” and it is still working normally.

            So the fix turned out to be pretty painless for me after an inauspicious start, but obviously it’s ridiculous that anyone should have to research or devise a way to fix this slovenly mess created by MS.

    • #150307 Reply

      anonymous

      ? says:

      if anyone is wanting to update XP, they (microsoft) have sent along the majic updated expiry file into the software distribution>Auth.cab CLSID(s)…

      Martin Brinkmann’s take on the problem:

      https://www.ghacks.net/2017/12/04/getting-windows-7-update-error-80248015-you-are-not-alone/

      note his AskWoody website reference! and also Gunter (sorry no umlaut) Born.

      p.s. the new server works great, loads quicker than the Wayback Machine’s!

    • #151611 Reply

      anonymous

      it is fixed now…

      <IssuedDate>2017-12-01T00:00:00.0000000-00:00</IssuedDate>

      <ExpiryDate>2025-07-01T00:00:00.0000000-00:00</ExpiryDate>

    • #152198 Reply

      rontpxz81
      AskWoody Lounger

      Not fixed- was waiting for update notice and finally checked manually.   Error couldn’t connect to server- followed SIMPLE suggestion, changed to Never Check for Updates, then it connected and worked.  Then changed all my settings back to what I had.

    Please follow the -Lounge Rules- no personal attacks, no swearing, and politics/religion are relegated to the Rants forum.

    Reply To: Windows Update in Win7 now appears to be working properly

    You can use BBCodes to format your content.
    Your account can't use Advanced BBCodes, they will be stripped before saving.

    Your information:


    Comments are closed.