• Windows Update not available in Settings

    Home » Forums » AskWoody support » Windows » Windows 10 » Windows 10 version 21H2 – November 2021 Update » Windows Update not available in Settings

    • This topic has 22 replies, 8 voices, and was last updated 1 week ago.
    Author
    Topic
    #2500295

    Hello! I am running Win 10Pro V 21H2 and have a question about a Windows Update setting page issue.

    After Susan’s email today with the DEFCON info, I decided to see which of the updates she recommends are listed in my Windows Update. When I first went to settings, the Windows Update page was just not there. My settings started with Delivery Optimization. So I Googled that and found that making a change in Group Policy > Control Panel to Not Configured would fix that. Mine wasn’t configured, so the directions were to check disabled>apply and then Not Configured>apply – but that didn’t actually fix it.

    Now I can see the Windows Update page, but it says “Something Went Wrong. Try to Reopen Settings Later”.

    WU

    I realized that Windows Update hasn’t nagged me about pending updates is a few weeks. I generally use WuMgr to get all updates, so I wasn’t really tuned into that till I just looked now. I can get the updates Susan recommends using WuMgr – just wondering why my Windows Update setting page wasn’t even there, and now is just saying “something Happened” – it did indeed.

    Is there a way to get it back. I’ll be happy to list my Group Policy update settings if that will help – maybe something there is causing this – though I think all of those changes were made when I first got this laptop in September and not recently that would cause this.

     

    • This topic was modified 1 week, 2 days ago by LHiggins.
    • This topic was modified 1 week, 2 days ago by LHiggins.
    • This topic was modified 1 week, 2 days ago by LHiggins.
    Attachments:
    Viewing 10 reply threads
    Author
    Replies
    • #2500304

      Have you use WUmgr to disable the WU interface?

      Susan Bradley Patch Lady

      1 user thanked author for this post.
      • #2500311

        Hi Susan! Thanks! Well I don’t remember doing that, but here’s what it looks like, below.

        WuMgr

        I can’t “undisable” that for some reason. Should I go ahead and get one update using WuMgr and then see if it changes and then I can see the Windows Update settings? I’m not really interested in using Windows Update, just seemed odd that it wasn’t available anymore.

         

         

        Attachments:
        • #2500361

          Selecting “Disable Automatic Update” hides the WU Settings Page.

          Selecting “Automatic Update (default)” gives you the option of showing it or hiding it.

          Windows 10 Home 21H2, Acer Aspire TC-1660 desktop + LibreOffice, non-techie

          1 user thanked author for this post.
          • #2500376

            Selecting “Disable Automatic Update” hides the WU Settings Page. Selecting “Automatic Update (default)” gives you the option of showing it or hiding it.

            OK – I changed it to Automatic Update – and chose not to hide WU page – still the same thing. WU settings still say something has gone wrong.

    • #2500313

      Posted WUMgr Hide WU jpg just after OP posted his …. Delete if able

      W10 Pro 21H2 / Hm-Stdnt Ofce '16 C2R / HP Envy Desk-Ethernet - SSD-HDD/ i5(8th Gen) 12GB / GP=2 + FtrU=Semi-Annual + Feature Defer = 1 + QU=0

    • #2500368

      Hi Susan! Thanks! Well I don’t remember doing that, but here’s what it looks like, below.

      WuMgr

      I can’t “undisable” that for some reason. Should I go ahead and get one update using WuMgr and then see if it changes and then I can see the Windows Update settings? I’m not really interested in using Windows Update, just seemed odd that it wasn’t available anymore.

       

       

      are you running WuMgr with “admin” or administrator privileges, LHiggins?
      non-admin users running Wumgr will always have that option grayed out

      when using Wumgr (and assuming UAC is always on), I always right-click on the wumgr app and choosing “run as administrator” and the Hide WU settings page option is not “grayed out” & available on my end

      1 user thanked author for this post.
      • #2500377

        are you running WuMgr with “admin” or administrator privileges, LHiggins?

        Yes – I am. And the only way to see that choice is to select Automatic Update – but as noted in the post above – that hasn’t changed anything on the WU settings page – still telling me something is wrong.

        • #2500379

          Did you remember to reboot after making the changes?

           

          We posted at the same time. I see it seems to be working after the reboot. Good news.

          Windows 10 Home 21H2, Acer Aspire TC-1660 desktop + LibreOffice, non-techie

          • This reply was modified 1 week, 2 days ago by samak. Reason: Simultaneous posting
          1 user thanked author for this post.
          • #2500382

            Yes – thanks! I didn’t think of that right off when I posted my initial results – but it seems to be fine now after the reboot. Good news indeed! Thanks again!!

    • #2500378

      And – I restarted just now, and WU is now checking for updates. Shows me the ones Susan recommends and also what is found in WuMgr. So – I guess maybe changing to Automatic Update AND a restart did the trick!

      Thanks for the help and ideas – I’ll keep an eye on it and hopefully it will all be OK. And as I said – I don’t actually use Windows Update – but I do like to have it notify me when there are new updates so I can then check WuMgr.

      Thanks again!

    • #2500485

      OK – I guess I still really don’t have this right. This morning I checked my other laptop – also Win 10 Pro V 21H2 to see what the WuMgr settings were. I ran it as an administrator and it was showing “Disable Automatic Update and Hide WU settings page. So I checked and the WU settings page also wasn’t visible. Guess I must have changed that setting on both computers along the way.

      Group POlicy Settings

      Anyway – I changed WuMgr to Automatic Update and unchecked hide settings page, restarted and when I then went to check the WU settings – it had three updates – 2 recommended by Susan and the malicious software tool – and it was already downloading all three! I hadn’t tried in WuMgr – and my Group policy for Windows update is 2 – notify – not download.

      WuMgr settings

      So – now I am concerned that somehow it is going to automatically always download updates without me having any control over them. Thankfully this time it was after Susan had changed the DEFCON, but how do I get this back to not downloading any – just showing me on the WU settings what is there and allowing me to use WuMgr to do the updates when I choose.

      Will check the other laptop again to see if this is the same issue there.

      Thanks for any additional advice!

      ETA: Same exact settings for the first laptop that had issues yesterday and when I check WU settings page – it shows me the updates pending, but doesn’t automatically download them.

      WU-settings

      Attachments:
      • #2500518

        https://www.askwoody.com/forums/topic/60002-guide-to-using-wumgr-for-windows-10-updates/

        Uncheck automatic update.
        First check for updates (nothing is downloaded)
        Select and hide the updates you don’t want to install
        Select the remaining updates and select the (download) install icon.

        Attachments:
        2 users thanked author for this post.
        • #2500538

          Thanks!

          Uncheck automatic update.

          OK – tried that and I can’t just uncheck Automatic Update. The only way to make it unchecked is to click on Disable Automatic Updates – then it isn’t checked. I also can’t check Notification Only – that is greyed out.

          ETA – if I select Disable Automatic Updates – then I can’t see the WU settings page anymore. I know that I could always see that page and get reminders – just no automatic download as happened this morning. I’ve tried resetting it, restarting, running as an administrator and I can’t match you view and select Notification Only either.

    • #2500553

      Here’s what my own WuMgr screen looks like.

      WuMgrUpdate-Tab

      As you can see nothing is selected and, even though it’s grayed-out, it indicates Auto Update is set to “Notification Only“)

      Here’s the values stored in the Windows AU (Auto Update) section of my registry.

      AutoUpdate-Registry-Settings

      Note: these values are located at…

      HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Microsoft\Windows\WindowsUpdate\AU

      If any of the values in that location on your PC are different, I’d suggest setting them to match mine, reboot, and see if that gives you the same WuMgr Auto Update tab as me.

      Reboot.

       

      Attachments:
      1 user thanked author for this post.
      • #2500562

        Thanks! So this needs to be a registry change? I have Group Policy set to 2 – notify only – but that didn’t seem to work with WU this morning.

        Here’s what mine looks like – seems like a lot to change when it was all working well earlier.

        Regedit

        Thanks for the help!

         

        Attachments:
    • #2500568

      The AUOptions , ScheduledInstallDate and ScheduledInstallTime values are controlled by the Configure Auto Updates Group Policy.

      The fact none of those values were created and set with a value on your PC means your attempt to change the Configure Auto Updates Group Policy didn’t work! If it had, those 3 values would be in that registry key and have the appropriate values.

      1 user thanked author for this post.
    • #2500571

      The fact none of those values were created and set with a value on your PC means your attempt to change the Configure Auto Updates Group Policy didn’t work!

      Well, that’s not good! Should I manually add those values or try Group Policy again? I need to check the Registry settings for the other laptop as well – that’s the one that had the problem this morning – maybe that was the issue – though it has worked fine with the GP settings I’ve changed for about 3 years – till today!

    • #2500572

      So this needs to be a registry change?

      No. GPEdit setting ‘notify..’=2 (grayed in WUmgr).
      You don’t need any settings in WUmgr (except for ‘register updates’ so you can see them in Windows update uninstall updates).

      1 user thanked author for this post.
      • #2500581

        No. GPEdit setting ‘notify..’=2 (grayed in WUmgr). You don’t need any settings in WUmgr (except for ‘register updates’ so you can see them in Windows update uninstall updates).

        Thanks! I didn’t make any changes to the registry manually – just went back to Group Policy to try to reset Notify – 2. My WuMgr now does show” register updates” and hopefully everything else is fine – all greyed out.

        1 user thanked author for this post.
    • #2500574

      The AUOptions , ScheduledInstallDate and ScheduledInstallTime values are controlled by the Configure Auto Updates Group Policy.

      OK – maybe some success?? On the HP laptop with the problem this morning, here’s what I did. I went into Group Policy and in the Configure Auto Updates, I cycled through disabled>apply, not configured>apply and then configure>set to 2, apply and OK. I then looked at the registry and there’s how it now looks. Has a few more things that you do, but all of yours are there, I think.

      Regedit-1

      I then checked WuMgr, and it is almost like yours, except I guess I had the Disable Store Auto Updates checked, so that is still checked, but the rest are not.

      WuMgr-2

      Checked the WU settings and it is there and says updated from the downloads this morning.

      Will check my Thinkpad and do the same and see if it is the same. Hope that does it – guess I’ll need to keep an eye on it and see if it does try to download something again without my permission. I guess I can always uninstall if that’s the case and it causes issues.

      Thanks for the help and guidance!

      ETA: Checked the Thinkpad and did the same thing to the GP settings –  then checked registry and all of the settings GP controls seem to be there. WuMgr now has no boxes checked, and I just got a notification that updates are pending. So – seems OK?? I also restarted the HP to see if the changes held – and they did. Keeping fingers crossed that it does work as it should now!

      Thanks again for the help!

      Attachments:
    • #2500720

      Just out of curiosity, I wonder if LHiggins using an older version of WuMgr v0.9a, when the newest version (I think) is v1.1b could possibly be part of the problems, maybe? Review Alex link to Topic 60002 Guide to using WuMgr, Susan has a link to GitHub recommendinig version 1.1b. Might help?

      1 user thanked author for this post.
      • #2500733

        Thanks for the suggestion. I did just check and I do have v 1.1b, so I am up to date on my Thinkpad, I guess. So far today I got a nag from WU that I had updates on my Thinkpad – not the one that had issues yesterday (note to self: check version for that laptop!) – and they downloaded with WuMgr without issues.

        I’ll check the other computer – maybe it is still on an older version and that may have contributed to the issue.

        Thanks!

        ETA – Yes, the one that had the issues with the automatic download yesterday is still on v0.9a. Guess I’ll need to look into getting the latest version running on both laptops. Thanks again for that idea!

        1 user thanked author for this post.
    Viewing 10 reply threads
    Reply To: Windows Update not available in Settings

    You can use BBCodes to format your content.
    Your account can't use all available BBCodes, they will be stripped before saving.

    Your information: