News, tips, advice, support for Windows, Office, PCs & more
Home icon Home icon Home icon Email icon RSS icon

We're community supported and proud of it!

  • Windows won’t boot with RAID enabled

    Home » Forums » AskWoody support » Windows » Windows 8.1 » Windows won’t boot with RAID enabled

    Tags:

    Author
    Topic
    #2403189

    I have a computer system running Windows 8.1. The computer has been working just fine for many years. The relevant hardware configuration is a Gigabyte motherboard, GA-Z77-DS3H, with a SSD boot drive. I also have two sets of mirrored hard drives (seen as drives D and E). Intel RAID is built into the motherboard.

    The issue is, last week, the system crashed and when it rebooted, I got a message saying that it was reloading the BIOS from the backup BIOS image. It appears that when that happened, the setting were reset to their defaults. Namely, the “SATA Mode Selection” in the BIOS settings got changed from “RAID” to “IDE”. The computer stills boot, but my hard drives are not longer mirrored. Nor do I get the RAID BIOS screen and the Intel RST service isn’t running.

    I’ve tried changing the “SATA Mode Selection” to “RAID”. When I did that, I did get the RAID BIOS screen showing the mirror sets, but Windows won’t boot. The Windows splash screen shows, the circle of dots go around for awhile, and then I get a blue screen saying there was an issue booting with the error message about “inaccessible boot device”. Changing the “SATA Mode Selection” setting back to “IDE” does allow the to boot the computer.

    It appears that when Windows booted with the “IDE” settings, something in the boot configuration got changed.

    Does anyone have any suggestions as to how to fix the issue?

    Viewing 3 reply threads
    Author
    Replies
    • #2403277

      and the Intel RST service isn’t running.

      this may be a possible problem.
      you didn’t say whether your sytem was restored following the crash but if it was your RST may not have been re-activated.

    • #2403295

      Try to boot it at least once in safe mode with RAID enabled. In Windows 8.1 and later this forces the OS to load all storage drivers, even disabled ones. If it boots OK in safe mode, you should be able to boot it normally from then on.

      • #2403324

        I tried as you suggested.  Unfortunately, it didn’t fix the issue.

        I did a reboot, changed the setting in the BIOS to “RAID”, and then selected “Safe Mode with Networking” at the appropriate screen.  Windows started to load in safe mode (at least the spinning dots were larger than normal).  Then the system rebooted and I got the Windows icon and the spinning dots and it basically hung at that point.  Gave the system over an half hour and it never moved on from the spinning dots.

    • #2403316

      In a mirrored array if you booted off 1 drive in is now different from the non booted ‘mirror’ drive. You would need to do a raid rebuild IMHO. I believe that would be done from the ‘Raid Bios’ screen you saw. I have a slightly new GB M/B but have never used the raid option so do not know first hand. You may want to load a backup config for the Bios, but read the manual first.

      🍻

      Just because you don't know where you are going doesn't mean any road will get you there.
      • #2403325

        Thanks for replying.  But, no, I’ve always booted off of the SSD drive, which is not mirrored.  The mirrored drives are strictly just data drives.

         

    • #2403343

      I am still of the opinion that a rebuild might be in order. Having a non functional raid array maybe confusing the heck out of Windows. Have you set the Intel RST service running when you boot in IDE mode so it runs when you try raid?

      BTW I do hope you have a good backup.

      🍻

      Just because you don't know where you are going doesn't mean any road will get you there.
    Viewing 3 reply threads
    Reply To: Windows won’t boot with RAID enabled

    You can use BBCodes to format your content.
    Your account can't use Advanced BBCodes, they will be stripped before saving.