• WinPE — many useful tools in a single package

    Home » Forums » Newsletter and Homepage topics » WinPE — many useful tools in a single package

    • This topic has 14 replies, 8 voices, and was last updated 1 week ago.
    Author
    Topic
    #2632276

    BEN’S WORKSHOP By Ben Myers For years, I have been using Windows PE in a variety of forms to carry out many tasks necessary to service Windows compute
    [See the full post at: WinPE — many useful tools in a single package]

    8 users thanked author for this post.
    Viewing 6 reply threads
    Author
    Replies
    • #2632341

      Very informative and helpful article!

      You mentioned in your article “designate the folder for the Nirsoft suite as immune to antivirus quarantine” I tried searching how to do this with no joy. Would you please point me in the right direction on how to do it?

      Thanks!

      1 user thanked author for this post.
    • #2632389

      Thanks for this, it’s going to bee very helpfull.

      A couple of questions.

      I download the ISO from the Older Geeks link in your article (being an older geek, myself) but when I try to add it to Rufus, to burn it as you suggest, Rufus says the file is truncated, the size of the ISO is incorrect and the MD5 and SHA checksums are wrong. You can calculate the checksums of the file in Rufus and they, indeed don’t match.

      These are the ones on the Older Geek page:
      ISO MD5 BEC7304FE2EB11DE495B9EA7B73C38AA
      ISO SHA1 EC7D4EC02A8772A4ECAEE59A9095D65B043AA77D
      ISO SHA-256 8281107683E81BE362AFD213026D05B2219BC6A7CA9AF4D2856663F3FFC17BFD

      These are the ones calculated by Rufus:
      MD5 697759228b432217e00635bce4afa2cb
      SHA1 424912e5d1c59d52020e2f0f57bae82de8e2af76
      SHA256 275976a6d9cdf8f487fd8ebf6f3e92655fac41c3b9e0e8f71df917c8721ffc35

      I downloaded the ISO twice but got the same error. I also tried getting it from https://www.hirensbootcd.org/download/ but there is no download available there, at least no button to download.

      I get no error when downloading the ISO.

      Rufus fails when writing the ISO to the USB drive. In the Rufus log, it says it’s because the file is truncated. I’ve attached a screenshot.

      Below is the contents of the Rufus.Log:

      Rufus x64 v4.4.2103 (Portable)
      Windows version: Windows 11 Home x64 (Build 22631.3007)
      Syslinux versions: 4.07/2013-07-25, 6.04/pre1
      Grub versions: 0.4.6a, 2.06
      System locale ID: 0x0409 (en-US)
      Will use default UI locale 0x0409
      SetLGP: Successfully set NoDriveTypeAutorun policy to 0x0000009E
      Localization set to ‘en-US’
      Found 517 officially revoked UEFI bootloaders from embedded list
      Found 2351 additional revoked UEFI bootloaders from this system’s SKUSiPolicy.p7b
      Found UAS (USB 3.0) device ‘Fantom External HDD UAS Device’ (152D:0562)
      Device eliminated because it was detected as a Hard Drive (score 63 > 0)
      If this device is not a Hard Drive, please e-mail the author of this application
      NOTE: You can enable the listing of Hard Drives under ‘advanced drive properties’
      Found USB 3.0 device ‘Kingston DataTraveler 3.0 USB Device’ (0951:1666)
      1 device found
      Could not get Disk Extents: [0x00000001] Incorrect function.
      Disk type: Removable, Disk size: 16 GB, Sector size: 512 bytes
      Cylinders: 1881, Tracks per cylinder: 255, Sectors per track: 63
      Partition type: GPT, NB Partitions: 2
      Disk GUID: {7D1C9593-C331-4098-B9FA-1614C2B5A2E1}
      Max parts: 128, Start Offset: 17408, Usable = 15472012800 bytes
      Partition 1:
      Type: Microsoft Basic Data Partition
      Name: ‘Main Data Partition’
      Detected File System: NTFS
      ID: {4848FE69-D338-4EC8-97FE-26C0AA1E3241}
      Size: 14.4 GB (15469912064 bytes)
      Start Sector: 2048, Attributes: 0x0000000000000000
      Partition 2 (UEFI:NTFS):
      Type: Microsoft Basic Data Partition
      Name: ‘UEFI:NTFS’
      Detected File System: FAT12
      ID: {F27BD3F3-D21C-4A91-A57E-03924AF50864}
      Size: 1 MB (1048576 bytes)
      Start Sector: 30216720, Attributes: 0x9000000000000000
      Scanning image…
      ISO analysis:
      Image is a UDF image
      Disk image analysis:
      Image does not have a Boot Marker
      ISO label: ‘HBCD_PE_x64’
      Size: 2.9 GB (Projected)
      ERROR: Detected that file on disk has been truncated by 36.1 MB!
      Uses: EFI
      Uses: Bootmgr (BIOS and UEFI)
      Using image: HBCD_PE_x64.iso (2.9 GB)

      Computing hash for ‘C:\BIN\Make a Windows PE\Hiren’s BootCD PE x64 v1.0.2\HBCD_PE_x64.iso’…
      MD5: 697759228b432217e00635bce4afa2cb
      SHA1: 424912e5d1c59d52020e2f0f57bae82de8e2af76
      SHA256: 275976a6d9cdf8f487fd8ebf6f3e92655fac41c3b9e0e8f71df917c8721ffc35

    • #2632592

      As for the “Classic” 32bit version of Hiren’s BootCD, there is a newer version on the Hiren’s site (ver 15.2) than the one linked in the article (ver 15.1). It has some added tools and is a year newer. https://www.hirensbootcd.org/old-versions/

       

      Moderator Note: This post was caught in the spam filter, but is now rescued!

       

      Win10 Pro x64 22H2, Win10 Home 22H2, Linux Mint + a cat with 'tortitude'.

      1 user thanked author for this post.
    • #2633173

      Thank you. I will download it and replace the older one.

    • #2633174

      And, hardly more than 48 hours since my article was posted, I received notice that Hiren’s BootCD PE x64 (v1.0.3) based on Windows 11 PE x64 is available. And so I downloaded it. Gotta try it.

      Also, apologies for the Hiren’s at OlderGeeks. I verified the Hiren’s download link there, but neither downloaded it nor used Rufus to create a bootable USB flash drive.

    • #2636085

      Just built my first Hiren’s WinPE and have a question before I use it.

      Question: Why are the Hiren’s and the article’s RUFUS setup different?  I’m going to add some programs and I would like to know if the differences are significant. Thanks.

      • I will be using the stick on two Win11 desktops and one Win10 laptop. The stick is a 32GB USB3.0 drive. The stick I built is from a Hiren’s compliant setup.
      • USB setting [GPT versus MBR]?
      • Target system [UEFI [nonCSM] versus BIOS or UEFI]?
      • File system [NTFS versus FAT32]?
      • I built a Hiren’s WinPE using an ISO v1.0.4 that came from the Hiren’s site link on Feb 10.
      • The build seemed to go as advertised.
      • I have not tried adding anything beyond the drive build.

      Win11 Pro desktop [2], one 22H2/22621.3007, one 23H2/22631.3007

      • #2637404

        You’re running Win 11 and late versions of Win 10, so I have to guess that the drive format on all your systems is GPT and the BIOS is set to UEFI. Either FAT32 or NTFS formatting will work. AS I did, you can add your favorite portable programs not already there to the flash drive, and you will be able to find them.

    • #2636087

      Just built my first Hiren’s WinPE

      Different author do it differently. Both work.

      MBR is my preferred for maximum compatibility.

      BIOS or UEFI, ditto.

      FAT32 is my preference but it doesn’t matter.

      Boot all your machines to make sure they work. If not you can change some of the above, or ask here.

      cheers, Paul

      1 user thanked author for this post.
    Viewing 6 reply threads
    Reply To: WinPE — many useful tools in a single package

    You can use BBCodes to format your content.
    Your account can't use all available BBCodes, they will be stripped before saving.

    Your information: