News, tips, advice, support for Windows, Office, PCs & more
Home icon Home icon Home icon Email icon RSS icon

We're community supported and proud of it!

  • Word Displays Fonts Incorrectly

    Viewing 5 reply threads
    • Author
      Posts
      • #2389882
        anonymous
        Guest

        About 2 weeks ago, Word started displaying many fonts incorrectly. I haven’t checked all fonts, but Word seems no longer to recognize Adobe fonts and displays them all as Arial, even though the selected Adobe font is correctly displayed in the ribbon. Word prints the fonts as displayed on-screen, i.e., in Arial.

        It is a big problem for me because I normally use one of several Adobe serif fonts in my work and none of them now work.

        I have reinstalled the fonts in Windows and I have uninstalled and reinstalled Office 365 to no avail. My version of Word is 2102 (Build 13801.20864 Click-to-run).

        I am being forced to use WordPerfect to get my work done since the fonts work in WordPerfect and apparently in everything but Word. However, I am much more accustomed to Word and would much prefer to be able to use it.

        Any ideas on how to fix the problem?

      • #2389897
        doriel
        AskWoody Lounger

        Click File tab | Options | Advanced, and then click the Font Substitution button. What do you see in the dialog box?

        If the message says: “No font substitution is necessary. All fonts used in the document are available.” then I am affraid, I have not other advice. If otherwise, the fonts are corrupted.

        Have you thought about copying fonts again to the Fonts directory instead of current ones?

        Dell Latitude E6530, Intel Core i5 @ 2.6 GHz, 4GB RAM, W10 20H2 Enterprise

        HAL3000, AMD Athlon 200GE @ 3,4 GHz, 8GB RAM, Fedora 29

        PRUSA i3 MK3S+

      • #2389942
        Moonshine
        AskWoody Lounger

        With Word closed – try creating another Normal.dotm Template.
        Copy the following text and paste it in your Search Bar:

        %userprofile%\AppData\Roaming\Microsoft\Templates

        Press the Enter key when you see the entry.
        In the opening Templates folder, locate and rename the existing Normal.dotm file to Normal.dotm.old.
        Open Word and a new, fresh Normal.dotm file will be created.
        See if your fonts are recognised now.

      • #2392201
        anonymous
        Guest

        Thanks for the suggestions, but neither helped.

        I clicked File tab | Options | Advanced, and then click the Font Substitution button. I got the message: “No font substitution is necessary. All fonts used in the document are available.”

        I deleted normal.dotm. Word generated a new, fresh Normal.dotm file, but my fonts still are no longer recognized.

        My work around is to use .ttf fonts similar to the .otf fonts that Word no longer recognizes. Fortunately, I found  .ttf versions of Adobe’s Brioso fonts, and I am using a .ttf version of Sabon to replace Adobe’s Garamond Premier Pro. However, I have a LOT of licensed Adobe fonts and it is disconcerting no longer to be able to use them in my work in Word.

      • #2392219
        Susan Bradley
        Manager

        Have you tried the slower channel version?

        How to Change the Update Channels for Microsoft 365 Apps (fmsinc.com)

        Scroll down to that command prompt section.

        Susan Bradley Patch Lady

      • #2392222
        anonymous
        Guest

        I hadn’t paid attention to which channel I am on, but it turns out that I am on the semi-annual channel. Apparently, that is the slowest version. Would you suggest switching to the Current Channel?

    Viewing 5 reply threads

    Please follow the -Lounge Rules- no personal attacks, no swearing, no politics or religion.

    Reply To: Word Displays Fonts Incorrectly

    You can use BBCodes to format your content.
    Your account can't use Advanced BBCodes, they will be stripped before saving.