News, tips, advice, support for Windows, Office, PCs & more. Tech help. No bull. We're community supported by donations from our Plus Members, and proud of it
Home icon Home icon Home icon Email icon RSS icon
  • What’s happening with X-Fi audio and Win10 versions 1903 and 1809?

    Posted on May 8th, 2019 at 09:05 woody Comment on the AskWoody Lounge

    Microsoft has already admitted that the new (not yet released) Win10 version 1903 knocks out audio on Creative’s premium — and relatively pricey — X-Fi sound cards. According to the Win10 1903 release notes, dated March 20:

    Creative X-Fi sound cards are not functioning properly. We are partnering with Creative to resolve this issue.

    A (purported) Creative engineer posted on Reddit last week:

    We have a couple driver packages coming up in the next few days that will address these issues. Titatnum, XtremeMusic, and XtremeGamer cards will be included with the fixes. I’m expecting to see them go live by the end of this week.

    “The end of this week” has come and gone, with no new drivers in sight.

    Our own @radosuaf has warned us about the problem — but not just with Win10 1903, which is still in beta. He’s seeing the same problems with the latest “second second” cumulative update for Win10 1809, KB 4495667:

    I reinstalled the drivers twice, removed the device and installed again – nothing. Removed tha update – works flawlessly.

    Which sure sounds like a retrograde patching bug.

    Anybody else seeing this bug?